Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 20

Thema: CPU315-2 DP geht in STOP

  1. #1
    Registriert seit
    28.04.2004
    Beiträge
    33
    Danke
    4
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hilfe, ich bin am Verzweifeln.

    Die CPU315-2 DP geht sproradisch in STOP.

    Diagnosepuffer:

    Ereignis 7 von 10: Ereignis-ID 16# 2942
    Peripherie-Zugriffsfehler, lesend
    P-Bereich , Wortzugriff, Zugriffsadresse: 338
    Angeforderter OB: Peripheriezugriffsfehler-OB (OB 122)
    Prioritätsklasse: 1
    externer Fehler, kommendes Ereignis

    Es ist ein zweizeiliger Aufbau. Im Zentralrack befinden sich:
    CP 340, 2xSiwarexU, 3xAI, 1x AA
    Im Erweiterungsrack
    5xDI, 2x DA

    Am Profibus:
    Beckhoff Klemmen DI DA AA
    ET200S, SEW Movidrive, FESTO Ventilinsel, ET200L

    - Alle Kabel und Schirme wurden überprüft
    - Baugruppe aus Diagnosepuffer und Baugruppe davor getauscht
    - PS307 2A gegen 5A getauscht
    - CPU getauscht
    - OB122 ist im Programm (leer) CPU geht trotzdem auf STOP

    Was kann man noch tun?

    Vielen Dank für Eure Ratschläge
    Zitieren Zitieren CPU315-2 DP geht in STOP  

  2. #2
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.616
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard

    Peripherie-Zugriffsfehler, lesend
    P-Bereich , Wortzugriff, Zugriffsadresse: 338

    Also PIW338.

    Wo verwendest du PIW338 in deiner Programm ?
    Wo wird PIW338 (oder IW33 in den Hardware Config zugewiesen?
    Jesper M. Pedersen

  3. #3
    Registriert seit
    28.04.2004
    Beiträge
    33
    Danke
    4
    Erhielt 1 Danke für 1 Beitrag

    Standard

    An dem analogen Eingang hängt ein E+H Druck Füllstandsmesser
    PEW338 wird in einem FC (der im OB1 aufgerufen wird) aufgerufen.
    Weiter greift ein OP270 auf das PEW 338 lesend zu. (Anzeige Füllstand)
    Der Eingang ist in der HW-Konfiguration als Analoger Eingang 2DMU konfiguriert

  4. #4
    Registriert seit
    16.12.2004
    Ort
    Schleswig-Holstein
    Beiträge
    400
    Danke
    21
    Erhielt 23 Danke für 20 Beiträge

    Standard

    Ist der Analog Eingang auf dem Zentralrack oder über DP zu erreichen. Im letzteren Fall könntest Du Bussprobleme haben.

  5. #5
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.616
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard

    Wenn online mit STEP7:
    Rechtsclicken auf der CPU mit der Maus, dann Wählst du "PLC" und dann "Hardware diagnostics" vor.
    Du kannst dann sehen, wenn alle Profibus Statione vorhanden sind (einschließlich E+H Sensor).
    Wenn es eine Störung gibt, spezifiziert die Hardware Diagnostics mehr über sie.

    (NB: Mein STEP7 ist auf english eingestellt).

    edit:
    Wenn es eine normale Analogeingabe ist, dann hilft die Hardware Diagnostics auch.
    Jesper M. Pedersen

  6. #6
    Registriert seit
    02.02.2005
    Beiträge
    51
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Schmiegel,

    ok, anscheinend gibt es mit dem Füllstandsmesser bzw mit der Baugruppe über die er eingebunden ist Probleme.
    Kontrolliert doch mal, ob die Daten (immer) zur Verfügung stehen.

    Du schreibst, dass der OB 122 existiert. Wurde er denn auch auf die CPU geladen? Oder gibt es ihn nur im STEP7-Projekt?
    Wenn die CPU nach STOP geht, obwohl der OB geladen wurde, müssen weitere Fehlermeldungen im Diagnosepuffer der CPU zu finden sein, die Aufschluss über das Problem geben.

    Allerdings sollte das Problem mit dem Füllstandsmesser geprüft werden, auch wenn es mit mit OB122 eine "Umgehung" gibt. Immerhin werden mit dem Bausteinaufruf nur die Syntome aber nicht die Ursache bekämpft.

    Kannst ja eventuell mehr als diesen einen Auszug aus dem Diagnosepuffer posten. Vielleicht finden wir ja noch was.

    Gruß ulkula

  7. #7
    Anonymous Gast

    Standard

    Hast du einen OB82 und einen OB86 drinnen
    wenn nicht einfach mal einspielen

    Peter

  8. #8
    Registriert seit
    28.04.2004
    Beiträge
    33
    Danke
    4
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo,
    erst mal vielen Dank für Eure Unterstützung.

    Die Analog-Eingangsbaugruppe sitzt im Zentralrack. Der E+H Sensor ist direkt angeschlossen.

    Da der Fehler nur sporadisch auftaucht, ist in der HW-Diagnose nichts zu sehen.

    OB82, OB86 und OB122 sind im Projekt und auch in der Steuerung (mehrfach überprüft)

    Als Anlage ein vollständiger Diagnosepuffer.

    Für mich ist wichtig, dass die CPU erst mal nicht mehr in STOP geht. Bringt SFC 36 MASK_FLT in diesem Fall was?
    Angehängte Dateien Angehängte Dateien

  9. #9
    Registriert seit
    02.02.2005
    Beiträge
    51
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Schmiegel,

    habe mir die Diagnosepuffereinträge mal angesehen.
    Es sind ja mehrere Meldungen hintereinander, das der OB 122 aufgerufen wird. Funktioniert also.
    Was mir dabei aber aufgefallen ist, dass er wegen 2 Adressen aufgerufen wurde (lesender Zugriff auf die Peripherieworte 336 und 33 und außerdem, dass der Zeitabstand zwischen den Fehlermeldungen ziemlich gering ist.
    08:47:59:061 12.07.05
    08:47:59:062 12.07.05
    08:47:59:063 12.07.05
    08:47:59:063 12.07.05

    dann kommt die eigentliche STOP-URSACHE:

    Ereignis 6 von 10: Ereignis-ID 16# 4548
    STOP durch Peripherieverwaltung
    Bisheriger Betriebszustand: RUN
    Angeforderter Betriebszustand: STOP (intern)
    interner Fehler, kommendes Ereignis
    08:47:59:073 12.07.05

    Könnte mir vorstellen, dass das Problem ist, dass die Fehlzugriffe einfach zu schnell hintereinander kamen.

    Kann jetzt nicht nachsehen was zu dem Diagnosepuffereintrag z.B. in der Hilfe steht.

    Aber ich hoffe, dass mit der Info vielleicht ein anderes Forenmitglied weiterkommt.

    Viel Erfolg bei der Lösung des Problems
    ulkula

  10. #10
    Registriert seit
    16.12.2004
    Ort
    Schleswig-Holstein
    Beiträge
    400
    Danke
    21
    Erhielt 23 Danke für 20 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich glaube nicht, dass es durch zu viele oder zu schnelle Peripheriefehler passiert ist. In dem Fall ist die Ursache für den STOP ein Buffer Overflow. Das Prozessabbild wird so schnell gelesen.

    Diese Meldung "STOP durch Peripherieverwaltung" habe ich nie gesehen. Könnte es sein dass in den CPU Eigenschaften "Anlauf bei Sollausbau ungleich Istausbau" nicht gecheckt ist?

Ähnliche Themen

  1. SPS geht in Stop
    Von Fidibus im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 25.08.2011, 18:22
  2. CPU geht bei Programmwechsel in Stop
    Von nonguru im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 21.05.2010, 09:23
  3. CPU geht in Stop
    Von JoJo17 im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 26.05.2008, 11:06
  4. 315 2DP geht in Stop
    Von Christian Schröder im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 01.08.2006, 01:53
  5. S5 geht des öfteren in Stop
    Von Andreas.W im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 13.01.2006, 11:59

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •