Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: OB1 Zuweisungsfehler FUP & SCL

  1. #1
    Registriert seit
    03.12.2010
    Beiträge
    29
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    Versuche gerade im OB1 (FUP) einen FB(SCL) zu verbinden.
    Ein Eingang ist ein UDT, welches in einem DB ist.

    Nun Folgende Fehlermeldung: „Keine Komponente von DB100“ .

    Im DB steht unter STRUCT Variablennamen : UDT110;

    Im UDT stehen meine Parameter, die ich benötige.

    Danke & Gruß

    Max (neu in SCL)
    Zitieren Zitieren OB1 Zuweisungsfehler FUP & SCL  

  2. #2
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.710
    Danke
    398
    Erhielt 2.397 Danke für 1.997 Beiträge

    Standard

    Hallo Max,
    wie hast du das denn gemacht ?
    Hat der DB einen symbolischen Namen ?

    Gruß
    Larry

  3. #3
    max_sho ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    03.12.2010
    Beiträge
    29
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Larry,

    der Name in der Symboltabelle ist eigentlich: DB100(Param)
    also ja.

    Grüße max

  4. #4
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Hallo,

    Hat die UDT im FB den gleichen Aufbau wie die UDT in dem DB100?

  5. #5
    max_sho ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    03.12.2010
    Beiträge
    29
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    Was genau ist mit Aufbau gemeint?

    Grüße max

  6. #6
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Die UDT zum Beispiel

    schnickschnack----Real
    blabla-------------Dword
    jaja---------------bool

    So muss es im FB dann auch aufgebaut sein

  7. #7
    max_sho ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    03.12.2010
    Beiträge
    29
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Im FB 4 rufe ich Param_S2 : UDT110; auf (als VAR_IN_OUT)
    Im FB 5 rufe ich Param_S2 : UDT110; auf (als VAR_IN_OUT)
    Im DB 100 rufe ich Param_S2 : UDT110; auf (als Struct)

    Im UDT stehen dann alle Parameter, auf die ich dann zugreife.

    direkt neu
    schnickschnack----Real
    blabla-------------Dword
    jaja---------------bool
    mach ich im FB und DB nicht.

    Grüße max

  8. #8
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Die Länge und Eigenschaften der Komponenten der UDT
    müßen im FB In/Out Deklaration dieselbe Structur haben.

    Am Besten mal:

    Im FB Datei---Zugriffe prüfen und aktualisieren

    Bausteinkonsistenz prüfen:

    --->Bausteinordner markieren---Rechtsklick---konsistenz prüfen--alles übersetzen.

  9. #9
    max_sho ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    03.12.2010
    Beiträge
    29
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Lösung gefunden: Es liegt an der 2.

    mit Param_MS statt Param_S2 geht es.

    aber warum?

    Hatte heute auch ein ähnliches Problem mit T1 in einem SFB04? Sonst wäre ich da jetzt nicht drauf gekommen.

    Was weiß ich da denn nicht?

    Grüße max (neu in SCL)
    Zitieren Zitieren Lösung  

  10. #10
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von max_sho Beitrag anzeigen
    Lösung gefunden: Es liegt an der 2.

    mit Param_MS statt Param_S2 geht es.

    aber warum?

    Hatte heute auch ein ähnliches Problem mit T1 in einem SFB04? Sonst wäre ich da jetzt nicht drauf gekommen.

    Was weiß ich da denn nicht?

    Grüße max (neu in SCL)
    mit Param_MS statt Param_S2 geht es.
    heißt das jetzt, die UDT wurde geändert und keiner hats mitbekommen?

    Zugriffe prüfen
    Konsistenzprüfung durchlaufen lassen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •