Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 13

Thema: Kommunikation PN-Cpu und Tim 3V-IE, put get......

  1. #1
    Registriert seit
    02.09.2008
    Ort
    Algund
    Beiträge
    221
    Danke
    16
    Erhielt 13 Danke für 12 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo

    Habe gerade versucht eine Verbindung zwischen einer 315 PN/DP und einer Tim 3V-IE aufzubauen. Dazu verwende ich das von S... gegebene beispiel über put und get. http://support.automation.siemens.co...ew/de/18610307
    Habe also im Netpro eine einseitige S7-Verbindung zu einem unbekannten Partner projektiert. Das ganze funktioniert anscheinend nur wenn ich die 3V-IE mit einer anderen PN-Cpu tausche, also von cpu zu cpu.
    Gibt es andere FBs als put und get die eventuell die Tim unterstützt??

    ICH WOHNE DA WO IHR URLAUB MACHT
    Zitieren Zitieren Kommunikation PN-Cpu und Tim 3V-IE, put get......  

  2. #2
    Registriert seit
    29.03.2004
    Beiträge
    5.793
    Danke
    144
    Erhielt 1.706 Danke für 1.238 Beiträge

    Standard

    Willst du die Verbindung von der 315 PN/DP zur TIM aufbauen, oder andersherum?
    Wenn du eine unspezifizierte Verbindung anlegst, musst du die IP-Adresse und vor allem Rack/Slot des Partners per Hand korrekt einstellen.

  3. #3
    simon.s ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.09.2008
    Ort
    Algund
    Beiträge
    221
    Danke
    16
    Erhielt 13 Danke für 12 Beiträge

    Standard

    Hallo

    Ja genau, brauche eigendlich nur eine Verbindung von CPU
    zur Tim.
    Habe in diese unspezifizierte Verbindung die richtige IP-Adresse
    und Rack/Slot eingetragen. Die Statusmeldung von put und get
    zeigen "1", laut F1-hilfe Kommunikationsprobleme an.

    Ip- richtig!
    Rack/Slot 0/4 (313c-2dp mit Tim)
    Verbindungsressource 03
    TSAP 03.04

    Komm da irgendwie nicht weiter....zumal das anstandslos
    funktioniert mit einer weiteren 315 die im Netz hängt.
    Irgendwie komisch oder einfach typisch Siemens.....
    womöglich brauch ich einen extra CP dafür........

    ICH WOHNE DA WO IHR URLAUB MACHT

  4. #4
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.639
    Danke
    377
    Erhielt 803 Danke für 644 Beiträge

    Standard

    Meinst du die Einstellungen unter der "Adressendetails" Taste ?
    Dann must du Rack=0 und Slot=2 spezifizieren.

    Disclaimer: Haben keine Erfahrungen mit TIM 3V-E1 !
    Jesper M. Pedersen

  5. #5
    Registriert seit
    02.10.2010
    Beiträge
    453
    Danke
    62
    Erhielt 87 Danke für 69 Beiträge

    Standard

    Zitat Zitat von JesperMP Beitrag anzeigen
    Disclaimer: Haben keine Erfahrungen mit TIM 3V-E1 !
    Der ist gut!!!

  6. #6
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.639
    Danke
    377
    Erhielt 803 Danke für 644 Beiträge

    Standard

    Ich verstehe das es lustig vorkommt. Das ich etwas vorschlägt obwohl ich keine Ahnung von TIM 3V-E1 habe.

    Aber, bei S7 Verbindungen muss man immer der "Ziel-Partner" spezifizieren. In dieser Fall der CPU in slot 2.
    Es kann ja sein das es ist anders in diesen Fall, aber ich glaube nicht.
    Wenn so, denn wäre es erste mal.
    Jesper M. Pedersen

  7. #7
    Registriert seit
    02.10.2010
    Beiträge
    453
    Danke
    62
    Erhielt 87 Danke für 69 Beiträge

    Standard

    Jesper, ich möchte mich nicht über Dich lustig machen, sondern der Satz mit "Disclaimer" ist wirklich gut.

  8. #8
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.639
    Danke
    377
    Erhielt 803 Danke für 644 Beiträge

    Standard

    Naja OK dann.

    Jesper M. Pedersen

  9. #9
    simon.s ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.09.2008
    Ort
    Algund
    Beiträge
    221
    Danke
    16
    Erhielt 13 Danke für 12 Beiträge

    Standard

    Hallo

    Habe dies mit 0/2 auch schon versucht, leider auch ohne Ergebnis.
    Denke dass die Tim wohl nix kann..... wenn ich das gewusst hätte,
    dann wär wohl ein CP343 und eine seperate RS 232 die bessere Wahl gewesen...

    ICH WOHNE DA WO IHR URLAUB MACHT

  10. #10
    Registriert seit
    29.03.2004
    Beiträge
    5.793
    Danke
    144
    Erhielt 1.706 Danke für 1.238 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von simon.s Beitrag anzeigen
    Hallo

    Habe dies mit 0/2 auch schon versucht, leider auch ohne Ergebnis.
    Denke dass die Tim wohl nix kann..... wenn ich das gewusst hätte,
    dann wär wohl ein CP343 und eine seperate RS 232 die bessere Wahl gewesen...
    Mit der TIM sollte auf jeden Fall Put/Get funktionieren. Denn ich habe z.B. ein WinCC über Ethernet mit der TIM gekoppelt, und diese wird dort auch als "teurer" Ethernet-CP benutzt. Die Kommunikationart von WinCC ist die gleiche wie die der Put/Get-Bausteine.
    Aber ich kann aus dem Gedächtnis nicht mehr sagen welche Rack/Slot Nummern ich dort eingestellt habe.

    Kannst du denn mit deinem PG über die TIM online gehen? Wenn das funktioniert könnte man sich dort die passende Rack/Slot-Kombination mit Wireshark auslesen. Aber schneller wird es sein ein paar Kombinationen wie 0/2, 0/3, 0/4 auszuprobieren und testen welche funktioniert.

Ähnliche Themen

  1. Kommunikation PC <--> S7
    Von blackknights im Forum Simatic
    Antworten: 44
    Letzter Beitrag: 14.01.2010, 13:25
  2. DP-Kommunikation 315 <--> 414
    Von Reto im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 11.06.2009, 22:07
  3. Kommunikation CPU - CPU
    Von klauserl im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 01.05.2007, 12:12
  4. S7 Kommunikation mit PC
    Von xpert im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 25.04.2006, 11:44
  5. MPI Kommunikation
    Von jas im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 10.04.2006, 09:50

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •