Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 10 von 10

Thema: Variablentabelle lügt ??

  1. #1
    Anonymous Gast

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo

    Habe letztens ein wahres Phänomen gesehen :
    Anlage mit 5x S7 315 2DP
    Verbindung Profibud DP I-Slave
    Phänomen der DP Eingang E173.2 war in der Variablentabelle TRUE
    und im Programm FALSE !!!!

    Wie kann das sein kann das überhaupt sein ???
    Oder spinn ich ??

    Danke
    Zitieren Zitieren Gelöst: Variablentabelle lügt ??  

  2. "Hallo,

    wie ist dein Steuern -Variablen eingestellt? Mußt du von "Hand" das Triggerereignis aktualisieren oder wird Zyklisch aktualisiert?

    Läuft die Anlage oder habt ihr damit Probleme?
    Grade bei Änderungen an Graph-7 Ketten ist es meist nötig den Instanz-DB neu zu erstellen und zu übertragen. Wenn das nicht gemacht wird kann es auch zu solchen Ereignissen führen. (Maschine läuft dann nicht)

    Markus"


  3. #2
    Registriert seit
    16.03.2004
    Beiträge
    273
    Danke
    2
    Erhielt 10 Danke für 6 Beiträge

    Standard

    Hallo,

    wie ist dein Steuern -Variablen eingestellt? Mußt du von "Hand" das Triggerereignis aktualisieren oder wird Zyklisch aktualisiert?

    Läuft die Anlage oder habt ihr damit Probleme?
    Grade bei Änderungen an Graph-7 Ketten ist es meist nötig den Instanz-DB neu zu erstellen und zu übertragen. Wenn das nicht gemacht wird kann es auch zu solchen Ereignissen führen. (Maschine läuft dann nicht)

    Markus

  4. #3
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.850
    Danke
    78
    Erhielt 800 Danke für 543 Beiträge

    Standard

    ist der eingang permanent da?

    für inbetriebnahmen benutze ich zb folgendes im NW1 des ob1 um eingänge zu steuern.

    Code:
    U M 199.0
    = E 1.0
    oder z.b. ob1 letzetes NW um ausgänge zu steuern

    Code:
    L MB 198
    T AB 8
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  5. #4
    Registriert seit
    08.02.2005
    Beiträge
    82
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    hallo,

    ist mir schon öfter genauso gegangen.
    aber, schuld war nie die variablentabelle sondern immer ich, meistens doppelzuweisungen.

    gruss lutz
    buenger-sps-technik

  6. #5
    Registriert seit
    16.03.2004
    Beiträge
    273
    Danke
    2
    Erhielt 10 Danke für 6 Beiträge

    Standard

    Hallo lutz,

    Doppelzuweisungen bei Eingängen, wie meinst du das?
    Bitte mal erklären, Doppelzuweisungen bei Merkern und Ausgängen kenne ich, aber bei Eingängen da ist mir neu.

    Markus

  7. #6
    Registriert seit
    07.05.2004
    Ort
    Campbelltown
    Beiträge
    2.437
    Danke
    131
    Erhielt 276 Danke für 86 Beiträge

    Standard

    Kann es sein, dass die Var-Tab. nicht auf Online geschaltet war? Also, wenn die Verbindung SPS-PG unterbrochen wurde oder Verbindung abbauen gewählt wurde, dann bleiben die alten Werte der Variablen erhalten.

    pt
    Gegen Schwachsinn, Schwachköpfe und armselige Trittbrettfahrer kann man nicht argumentieren.

    Gott sieht alles, auch Signaturen in Geheimschrift,,... aber er petzt nicht.

  8. #7
    Registriert seit
    27.08.2004
    Ort
    Bei Bremen
    Beiträge
    648
    Danke
    11
    Erhielt 12 Danke für 10 Beiträge

    Standard

    @SPS Markus,
    die SPS hat diverse Speeicherstellen

    Es gibt je einen Bereich für Eingänge
    Ausgänge
    Merker
    etc.

    Das Betriebssystem der SPS schreibt die Ein- und Ausgänge in diese Speicherstellen (das ProzessNurabbild, je nach SPS Typ ist dieser Bereich unterschiedlich groß) .

    Eine Verändeung des Abbildes kann gemacht werden, weil für die SPS Eingänge und Ausgänge ganz normale Speicherstellen sind.

    Um z.B. einen Eingang zu negieren reicht im 1. Netzwerk des OB1 aus:
    UN E 2.0
    = E 2.0

    Das geht nur mit Eingänge, Wo ein Befehl steht L PEW 2 wird der aktuelle Wert aus der Pheripherie geladen.
    Gruß
    Heinz

  9. #8
    Anonymous Gast

    Standard

    Mir passiert das wenn der FC in dem der Eingang verarbeitet wird nicht aufgerufen wird dann zeigt die var Tabelle true aber der Eingang im Programm False

    mfg

    Andi

  10. #9
    Registriert seit
    07.05.2004
    Ort
    Campbelltown
    Beiträge
    2.437
    Danke
    131
    Erhielt 276 Danke für 86 Beiträge

    Standard

    Was sagt der physikalische Eingang denn?

    pt
    Gegen Schwachsinn, Schwachköpfe und armselige Trittbrettfahrer kann man nicht argumentieren.

    Gott sieht alles, auch Signaturen in Geheimschrift,,... aber er petzt nicht.

  11. #10
    Anonymous Gast

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Step 7 / Version 5.3 verursacht diese ungewöhnlichen
    Zustände.
    Ist mir bereits mehrfach vorgekommen.
    Siemens hat hierfür keine Erklärung !
    Wechsel in den Offline - Betrieb und lade den zu beobachteten
    Baustein aus der Station.
    Anschließend Online- Betrieb und du wirst sehen - Alles ist gut -
    Gruß

Ähnliche Themen

  1. Schreibfunktionen der Variablentabelle....
    Von Jochen Kühner im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 30.03.2011, 09:55
  2. Variablentabelle
    Von Andy_Scheck im Forum Simatic
    Antworten: 17
    Letzter Beitrag: 24.02.2010, 13:33
  3. Variablentabelle Ersatzwert?
    Von Hans.S im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 13.10.2009, 21:51
  4. Steureung in Variablentabelle
    Von manas im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 03.10.2007, 14:40
  5. Variablentabelle
    Von Pimsti im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 16.06.2006, 08:55

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •