Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 2 von 2

Thema: IM 174, brauche Hilfe

  1. #1
    Registriert seit
    18.05.2007
    Beiträge
    71
    Danke
    17
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich bin dabei, eine hydraulische Presse aufzurüsten. Dabei will ich einen hydraulischen Gleichgangzylinder mit Inkrementalmesstab über eine T-Cpu und IM 714 regeln.
    Ablauf soll wie folgt sein: Nach dem Einschalten der Anlage erfolgt zuerst eine Referenzfahrt (FB 403 MC_Home). Wenn die Achse referenziert ist, fahre ich mit dem FB 410 MC_MoveAbsolute die gewünschten Positionen an.

    Fragen: Wie kann ich erkennen, ob die Achse referenziert ist oder nicht, d.h. woher weiss ich, wann ich die Referenzfahrt auslösen muss?
    Was ist mit dem FB401 MC_Power? Muss dieser die Achse auch für die Refernzfahrt freigeben?

    Was muss ich noch machen, ausser auf S7-Seite die o.g.Bausteine zu parametrieren und die Konfiguration der Technologie durchzuführen.
    Wenn ich jetzt mit der S7 auf dem Schreibtisch (kein angeschlossens Ventil, nur das Lineal ist angeschlossen) den FC_Home enable, geht die SPS auf stopp.
    Erkennt die Achse, dass sie keine Lageregelung durchführen kann (fehlendes Stelglied) und geht deshalb auf Störung?

    Mach ich einen generellen Denkfehler?
    Wie würdet ihr vorgehen?
    Danke für eure Hilfe

    Harri
    Zitieren Zitieren IM 174, brauche Hilfe  

  2. #2
    Registriert seit
    21.12.2006
    Beiträge
    61
    Danke
    2
    Erhielt 18 Danke für 16 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Harri,

    - Der MC_Power schaltet den Lageregler aktiv und muß "enabled" sein und am Ausgangsparameter auch den Status=1 liefern bevor jeglicher Bewegungsbefehl ausgeführt werden kann , also auch bein Referenzieren

    - Ob die Achse referenziert ist siehst Du in den Statusinformationen des Achsdatenbausteines den Du nach der Konfiguration mit dem TOM angelegt hast

    - Wenn deine CPU beim Aufruf der Bausteine in Stop geht, solltest Du mal im Diagnosepuffer der CPU nachschauen, ich gehe davon aus das Du einen der Bausteine nicht online geladen hast. Generell sollte die CPU nämlich nicht wegen eines nicht vorhandenen Stellgliedes oder "einfachen" Parametrierfehlers in der Technologie in Stop gehen.

    Du solltest vielleicht auch mal die F1 Taste zu den Bausteinen verwenden, die Online Hilfe beschreibt die Funktionen eigentlich ganz gut, ansonsten gibt es auch noch das S7-Technology Handbuch.

    Bei der Positionierung/Regelung hydraulischer Achsen kann es notwendig sein der optimalen Einstellung der Regelparameter erhöte Aufmerksamkeit zu widmen.
    Evtl. sollte je nach Anwendungsfall, Anforderung und verwendeten Ventilen die Kennlinie der Regelstrecke ermittelt werden und der Steuerung mitgeteilt werden.
    Dazu gibt es von Siemens diesen FAQ:
    http://support.automation.siemens.co...ew/de/27731588

    Bei geringen Anforderungen an Dynamik oder "guten Ventilen"(linearisiert, kleine Totzone um den Nullpunkt) kann das aber evtl. auch enfallen.

    Gruß
    Watchdog

Ähnliche Themen

  1. Antworten: 90
    Letzter Beitrag: 21.03.2010, 12:35
  2. Brauche in S5 Hilfe
    Von knockout im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 11.08.2007, 20:19
  3. Brauche Hilfe OP5
    Von spsler im Forum HMI
    Antworten: 1
    Letzter Beitrag: 16.01.2006, 10:42
  4. Brauche Hilfe
    Von Anonymous im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 08.03.2005, 12:56
  5. Brauche mal Hilfe OP 5
    Von Anonymous im Forum HMI
    Antworten: 8
    Letzter Beitrag: 20.02.2005, 11:47

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •