Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 17 von 17

Thema: Wo ist der Fehler?

  1. #11
    Registriert seit
    30.10.2009
    Ort
    10 km vom Herzen der Natur
    Beiträge
    1.626
    Danke
    120
    Erhielt 340 Danke für 255 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    @Rainer
    Das wollte ich auch gerade fragen.
    Gruß
    Michael

  2. #12
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.186
    Danke
    923
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Gibt der Button "Hilfe zum Ereignis" nichts her?
    Bei Dir ist das eine indirekte Adressierung ohne Bereichskennung.

    siehe Step7-Hilfe zu SFBs/SFCs > SFCs für die Hantierung von Synchronfehlerereignissen > Synchronfehlerereignisse maskieren
    oder Referenzhandbuch System- und Standardfunktionen für S7-300/400, Kapitel 11
    Code:
    Ereignis-ID W#16#2524: Bereichsfehler beim Lesen
    
    Fehler tritt auf, ...
    ... wenn bei indirekter, bereichsübergreifender Adressierung eine 
        falsche Bereichskennung für den Operanden angegeben wird.
    Beispiel:
    Richtig: LAR1 P#E 12.0
             L    W[AR1, P#0.0]
    Falsch : LAR1 P#12.0
             L    W[AR1, P#0.0] Bei dieser Operation wird der 
                                Bereichsfehler gemeldet.
    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  3. #13
    erzteufele ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.11.2008
    Ort
    Schweigen am Weintor
    Beiträge
    707
    Danke
    191
    Erhielt 161 Danke für 92 Beiträge

    Standard

    @ PN/DP
    Hilfe sagt nur wasses ist aber auch nicht wo...
    das Programm ist recht groß, teile sind in scl geschrieben ...
    ich weiß also nicht wo ich ansetzen soll alles durchschauen mach ich erst wenn´s nicht anders geht

    hab den fehler ob mal gemacht wenn der fehler wieder auftaucht sollte ich die daten haben, gespannt bin

    Ich könnte das programm ja auch mal hochladen aber das wollte ich euch nicht antun, ich denk mir nur jedesmal wenn ich es öffnen muss, warum nur warum... zudem ist es größer wie 9mb
    Geändert von erzteufele (13.01.2011 um 16:40 Uhr)

  4. #14
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.186
    Danke
    923
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    @erzteufele
    Du könntest aus allen OB+FC+FB eine gesamt-AWL-Quelle generieren und nach [AR suchen.
    Immer wenn der Ladebefehl ohne Bereichsangabe/nur mit Größenangabe ist (z.B. B[ARx, W[ARx, D[ARx, oder nur [ARx bei U/O/X/=/S/R),
    dann muß der vorhergehende AR1/AR2-Ladebefehl eine Bereichskennung enthalten (z.B. P#DBX.., P#DIX.., P#E.., P#A.., P#M.., P#P..).
    Es könnte auch sein, daß der Pointer erst in den Akku und von da aus in AR1/AR2 geladen wird.
    So könntest Du die Fehlerquelle(n) auch ohne U-Stack und OB121 logisch finden.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  5. #15
    erzteufele ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.11.2008
    Ort
    Schweigen am Weintor
    Beiträge
    707
    Danke
    191
    Erhielt 161 Danke für 92 Beiträge

    Standard

    hmmm stimmt tool= PN/DP

  6. #16
    erzteufele ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.11.2008
    Ort
    Schweigen am Weintor
    Beiträge
    707
    Danke
    191
    Erhielt 161 Danke für 92 Beiträge

    Standard

    so habe heute morgen mal ausgewertet ... der ob sagt mir nun das es ein fehler auf einen instanz db mit bitzugriff gibt... mmm

  7. #17
    Registriert seit
    11.09.2007
    Ort
    Suedwestpfalz
    Beiträge
    917
    Danke
    81
    Erhielt 209 Danke für 192 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Da würde ich jetzt die Bausteinkonsistenzprüfung drüberlaufen lassen.

    Vllt. muss ja nur ein I-DB neu generiert und eingespielt werden...

    Ist aber nur 'ne Theorie meinerseits...
    Das Grauen lauert in der Zwischenablage !!

Ähnliche Themen

  1. Antworten: 9
    Letzter Beitrag: 17.06.2011, 08:02
  2. OPC BDE Fehler
    Von Power_Pete im Forum Hochsprachen - OPC
    Antworten: 13
    Letzter Beitrag: 19.05.2011, 13:53
  3. Wo ist der Fehler???
    Von husox81 im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 30.01.2010, 16:07
  4. S5 DB1 Fehler
    Von mariob im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 26.01.2009, 17:25
  5. SR - Fehler
    Von sedie im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 30.09.2003, 14:41

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •