Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 19

Thema: Programmier Möglichkeit gesucht

  1. #1
    Registriert seit
    17.01.2011
    Beiträge
    10
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo alle zusammen, habe vor Kurzem kostengünstig eine S7 317-2PN/PD erstanden, und benutze das Programm Step7 v5.2. Dachte der USB/MPI Adapter, würde funktionieren.

    (http://cgi.ebay.de/USB-MPI-SIEMENS-T...item3cb235d82a)

    Das tut er leider nicht, also dachte ich mir ich versuche es über Ethernet, die CPU zeigt auch eine Link Verbindung an doch das Programm will nicht so recht. Was kann ich tun, funktioniert dies überhaupt. Leider habe ich seit meiner Ausbildung als Elektroniker nicht mehr mit Siemens gearbeitet, da meine Firma den Konkurrenten aus Amerika führt.
    Zitieren Zitieren Programmier Möglichkeit gesucht  

  2. #2
    Registriert seit
    25.06.2007
    Ort
    Dresden
    Beiträge
    3.930
    Danke
    465
    Erhielt 878 Danke für 634 Beiträge

    Standard

    Wenn die S7 317-2PN/DP gebraucht war, wird der DP/MPI-Port
    bestimmt schon auf DP eingestellt sein. Dadurch kannst du
    natürlich nicht zugreifen, wenn dein China-Adapter nur MPI-kann.
    Außerdem war im Step7 v5.2 noch kein Ehernet-Treiber im Lieferumfang,
    das heißt, damals war Softnet-PG separat zu erwerben.

    Das heißt, das du wohl in dieser Konfiguration mit der CPU nicht
    wirst arbeiten können, wenn dir nicht jemand den MPI/DP-Port
    auf MPI stellt.

    Gruß

    Frank
    Grüße Frank

  3. #3
    Registriert seit
    14.06.2005
    Beiträge
    223
    Danke
    9
    Erhielt 15 Danke für 15 Beiträge

    Standard

    Hallo,

    mein "guter" Siemens USB Adapter (schon 3mal USB gelötet!) kann auch nur MPI und kein Profibus.

    Was du machen kannst, ist ein Urlöschen vornehmen, gibt es eine Anleitung im Handbauch, das allein wird nichts nützen wenn auf deine Speicherkarte eine Konfi ist die der alles wieder auf Profibus umstellt, also Speicherkarte auch löschen, auch Anleitung im Handbuch, da sollte es aber funktionieren!

    Du kannst aber auch nach einem kompletten löschen der Karte und CPU eine IP Adresse in der Hardware Konfig zuweisen, gibt es einen Punkt im Menu.

    Servus.

  4. #4
    Registriert seit
    10.07.2010
    Beiträge
    40
    Danke
    4
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Zitat Zitat von SIX Beitrag anzeigen
    Hallo alle zusammen, habe vor Kurzem kostengünstig eine S7 317-2PN/PD erstanden, und benutze das Programm Step7 v5.2. Dachte der USB/MPI Adapter, würde funktionieren.

    (http://cgi.ebay.de/USB-MPI-SIEMENS-T...item3cb235d82a)
    Hi,
    mein china-adapter funktioniert 1a (312IFM, Step7 5.4)

  5. #5
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.166
    Danke
    921
    Erhielt 3.286 Danke für 2.655 Beiträge

    Standard

    Zitat Zitat von ross Beitrag anzeigen
    Hi,
    mein china-adapter funktioniert 1a (312IFM, Step7 5.4)
    Bei Dir muß der ja auch nur MPI können ...

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  6. #6
    SIX ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    17.01.2011
    Beiträge
    10
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Also meine CPU ist neu und unbenutzt, habe inzwischen auf Simatic 5.5 aufgerüstet, die "Sende/Empfange LED" blinkt des Öfteren auf der CPU. Aber vom "China Adapter" kein Ton, brauche ich für *den spezielle Treiber?

  7. #7
    Registriert seit
    05.10.2005
    Beiträge
    2.373
    Danke
    321
    Erhielt 296 Danke für 266 Beiträge

    Standard

    Treiber sollten dazu sein. Aber stell bitte die Nr. der virtuellen COM-Schnittstelle nicht zu hoch ein. Es funktioniert glaub ich nur bis COM5?. Dazu gabs schon mal ein Thema hier.

    Thomas

  8. #8
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.166
    Danke
    921
    Erhielt 3.286 Danke für 2.655 Beiträge

    Standard

    Zitat Zitat von SIX Beitrag anzeigen
    habe vor Kurzem kostengünstig eine S7 317-2PN/PD erstanden
    Zitat Zitat von SIX Beitrag anzeigen
    Also meine CPU ist neu und unbenutzt, habe inzwischen auf Simatic 5.5 aufgerüstet,
    Wenn Du Deinen Programmier-PC direkt mit einem Netzwerkkabel (Patchkabel) mit der CPU verbindest, dann müßtest Du für die erste Inbetriebnahme der CPU eine IP-Adresse zuweisen können (Du brauchst Deinen China-Adapter gar nicht). Das müßte unter Zielsystem > Ethernet-Teilnehmer bearbeiten sein (oder so ähnlich). Da kannst Du die CPU suchen lassen (MAC-Adresse). Probiere auch mal am unteren Port P2, falls es am oberen Port P1 nicht funktioniert.

    Du kannst auch einfach ein Test-Projekt mit einer Hardware-Konfig und Wunsch-IP-Adresse erstellen und per Netzwerkkabel auf die CPU laden. Da wird dann die MAC-Adresse der CPU angezeigt, die wählst Du als Zielstation aus. Hat die CPU noch keine IP-Adresse, dann fragt HW-Konfig, welche IP-Adresse es der CPU zuweisen soll.

    Appropos neu und unbenutzt: hast Du in der CPU eine MMC drin? (Siemens Micro Memory Card)

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  9. #9
    Registriert seit
    26.05.2009
    Ort
    Nähe Bremen
    Beiträge
    243
    Danke
    11
    Erhielt 40 Danke für 36 Beiträge

    Standard

    Hi,
    mein China Adapter funktioniert auch..allerdings nicht mit der mitgelieferten Treiber CD meine ich sondern habe mir den Treiber aus dem Netz (Siemens?) geladen..kann aber auch an meiner Problematik Win7 64 Bit und virtuelle XP Maschine gelegen haben...

    Aber er funktioniert

  10. #10
    SIX ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    17.01.2011
    Beiträge
    10
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Dankeschön an PN/DP habe die CPU über die MAC gefunden. Habe ihm auch eine IP zugewiesen, die er auch angenommen hat. Nur beim Laden meldet er "der Verbindungsteilnehmer meldet sich nicht". Was mir seltsam erscheint ist das mein PC bei der Verbindung meint "keine oder nur eingeschränkte Konnektivität", brauche ich ein cross-over für die Verbindung?

Ähnliche Themen

  1. Andere Möglichkeit als PAP oder Struktogramm
    Von Mitschy86 im Forum Programmierstrategien
    Antworten: 7
    Letzter Beitrag: 02.05.2011, 14:05
  2. Programmier für Tiger-Basic gesucht
    Von Knuth im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 01.06.2008, 19:13
  3. Möglichkeit ein komplettes PRG zu schützen??
    Von Olafius im Forum Simatic
    Antworten: 44
    Letzter Beitrag: 14.11.2007, 11:20
  4. Antworten: 8
    Letzter Beitrag: 09.08.2007, 09:22
  5. andere möglichkeit als ein schieberegister??
    Von gorden im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 16.09.2004, 20:31

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •