Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 10 von 10

Thema: AG_SEND mit PN-CPUs

  1. #1
    Registriert seit
    14.06.2005
    Beiträge
    223
    Danke
    9
    Erhielt 15 Danke für 15 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Leute,

    ich habe noch eine ältere PN-CPU da ist es nicht möglich eine "unspezifizierte Verbindung" mit AG_SEND oder AG_RECIEVE aufzubauen.

    Nun meine Frage, ist das immer noch so ???
    Ich würde mir gerne meinen Ethernet CP sparen.
    Ich weiss ich kann meine Visu anbinden, meine Perepherie, aber AG_SEND ???

    Danke für eine Info.
    Zitieren Zitieren AG_SEND mit PN-CPUs  

  2. #2
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.746
    Danke
    209
    Erhielt 421 Danke für 338 Beiträge

    Standard

    AG - Send geht nicht, da du die Verbindung nicht in NetPro Konfigurieren kannst!

    Aber eine Verbindung geht trotzdem, du musst nur dafür die FBs TSEND und TRCV verwenden. Die Verbindung musst du mit dem FB TCON aufbauen.

    Helfen kann dir dabei noch der OpenCommunicationWizzard, den bekommst du bei Siemens zu Download.
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten

  3. #3
    paula23 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    14.06.2005
    Beiträge
    223
    Danke
    9
    Erhielt 15 Danke für 15 Beiträge

    Standard

    ....heisst meine Modbus TCP Verbindungen kann ich auch knicken.

    Naja bleib ich beim CP.

  4. #4
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.746
    Danke
    209
    Erhielt 421 Danke für 338 Beiträge

    Standard

    Folgende Verbindungen kannst du mit dem Tool anlegen:
    Angehängte Grafiken Angehängte Grafiken
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten

  5. #5
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.746
    Danke
    209
    Erhielt 421 Danke für 338 Beiträge

    Standard

    Zitat Zitat von Jochen Kühner Beitrag anzeigen
    AG - Send geht nicht, da du die Verbindung nicht in NetPro Konfigurieren kannst!
    Korrektur: AG-SEND geht bei TCP/IP Verbindungen nicht, bei S7 Verbindungen sollt's schon gehen.
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten

  6. #6
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.746
    Danke
    209
    Erhielt 421 Danke für 338 Beiträge

    Standard

    Zitat Zitat von paula23 Beitrag anzeigen
    ....heisst meine Modbus TCP Verbindungen kann ich auch knicken.
    Warum, sind das keinen Standard TCP-IP Verbindungen?
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten

  7. #7
    paula23 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    14.06.2005
    Beiträge
    223
    Danke
    9
    Erhielt 15 Danke für 15 Beiträge

    Standard

    Stimmt, man müsste es halt mal ausprobieren.

    ich habe bis jetzt immer eine 315 mit CP eingesetzt.
    ich wollte jetzt mal auf einen IM153 PN umsteigen und in diesem Zuge noch den CP rausschmeisen.

    meine mysql verbindung macht mir noch sorgen, ist halt bis jetzt über ein ag_send realisiert.

    Servus.

  8. #8
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.746
    Danke
    209
    Erhielt 421 Danke für 338 Beiträge

    Standard

    Zitat Zitat von paula23 Beitrag anzeigen
    Stimmt, man müsste es halt mal ausprobieren.

    ich habe bis jetzt immer eine 315 mit CP eingesetzt.
    ich wollte jetzt mal auf einen IM153 PN umsteigen und in diesem Zuge noch den CP rausschmeisen.

    meine mysql verbindung macht mir noch sorgen, ist halt bis jetzt über ein ag_send realisiert.

    Servus.
    Die TCP/IP Verbindungen funktionieren im Prinzip gleich, man muss nur andere Bausteine verwenden, welche aber fast die gleichen Parameter haben!

    Also Ich denke das sollte schon gehen!
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten

  9. #9
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.626
    Danke
    377
    Erhielt 801 Danke für 642 Beiträge

    Standard

    Verwendest du das Modbus TCP Bibliotek von Siemens ?
    Es kommt in 3 Varianten, für PN CPUs (2XV9450-1MB02), für CPs (2XV9450-1MB00) und für redundante H-Verbindungen (2XV9450-1MB11).
    Jesper M. Pedersen

  10. #10
    Registriert seit
    22.05.2005
    Ort
    sonniges Maifeld
    Beiträge
    1.067
    Danke
    77
    Erhielt 205 Danke für 159 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von paula23 Beitrag anzeigen
    ....heisst meine Modbus TCP Verbindungen kann ich auch knicken.

    Naja bleib ich beim CP.
    Wieso das denn ?
    "Man kann auf seinem Standpunkt stehen, aber man sollte nicht darauf sitzen" - Erich Kästner

Ähnliche Themen

  1. ISO on TCP AG_SEND
    Von markuscps im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 17.02.2011, 15:03
  2. nochmals AG_SEND
    Von phoo82 im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 06.02.2010, 03:48
  3. FC5 AG_Send
    Von klauserl im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 07.02.2009, 18:18
  4. Fehlermeldung in AG_SEND
    Von quant81 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 08.06.2007, 09:21
  5. Ag_send
    Von reiki im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 06.10.2006, 13:02

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •