Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: PID-Regler für Temperaturregelung.

  1. #1
    Registriert seit
    11.02.2011
    Beiträge
    14
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen!

    ich weis es ist schon Freitag mittag und jeder freut sich aufs Wochenende, aber vielleicht is ja noch wer da der mir bei meinem kleinen Problem helfen kann & will!

    Ich habe mir einen FC zum regeln einer Heizplatte gebastelt,(SFB/FB41 Cont_C) mit übergabe an den SFB/FB58 PULS_GEN, und soweit auch funktionsfähig.
    Nur muss ich auf ein halbes °C genau an den sollwert regeln, und bei meinem Baustein enden die Pulse 17°C vor erreichen des Sollwertes!
    Hab mir im Hilfemenü die ganzen Parameterschnittstellen durchgelesen und konnte aber nicht herausfinden wo ich das wie parametrieren muss um meine vorgaben zu erreichen!

    Falls jemand von euch schonmal mit dem PID-Bausteinen gearbeitet hat und mir helfen kann wär ich sehr dankbar!

    mfg Mike
    Zitieren Zitieren PID-Regler für Temperaturregelung.  

  2. #2
    Registriert seit
    24.02.2011
    Ort
    Bern, Schweiz
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Mike
    Habe auch schon mit PID gearbeitet ist allerdings schon ein bissl her. Eine Möglichkeit wäre das am Regler die Totzonenbreite etwas zu hoch eingestellt hast (DEADB_W). Könnte das sein? Dies ist ja die Totzone in der der CONT_C keine Korrektur mehr am Stellwert vornimmt.
    Gruss Andi

  3. #3
    Mike Vanstrike ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    11.02.2011
    Beiträge
    14
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Andi!

    also eig. hab ich an der Totzonenschnittstelle keine Wertangabe vorgenommen! Hab aber auch schon versucht den Wert vorzugeben mit +20 und -20 und hab aber keine Änderung bemerkt.
    Was ich inzwischen rausgefunden hab, ist das ich vorhin mit der falschen cpu (VIPA) verbunden war! Hab den Baustein jetzt in die siemens cpu 315/-2 pn/dp reingespielt, und jetzt hab ich impulse bis 5°C vor dem Sollwert.
    Brauch aber immer noch eine Regelung bis 0,5°genau

    lt dem Siemens hilfe-kontext erhält man eine genauere Regelung wenn man den Baustein Puls_gen öfter aufruft als den CONT_C, aber auch hier hab ich beim Parameter CYCLE 500ms zu 5ms parametriert!

    mfg mike

  4. #4
    Registriert seit
    30.08.2010
    Ort
    Östereich
    Beiträge
    1.458
    Danke
    503
    Erhielt 217 Danke für 192 Beiträge

    Standard

    vielleicht Offset?

    regelt er denn deinen SW -5° ?
    Elektrotechnik und Elektronik funktioniert mit Rauch (Beweis: Tritt Rauch aus, funktioniert auch das Bauteil nicht mehr)

  5. #5
    Registriert seit
    23.10.2009
    Beiträge
    392
    Danke
    58
    Erhielt 113 Danke für 87 Beiträge

    Standard

    Bei Heizungsregelungen musst Du immer mit I-Anteil arbeiten, weil Du auch im ausgeregelten Zustand einen Stellwert verschieden von Null brauchst. Hast Du einen I-Anteil drin? Wenn Ja, muss dein Stellwert weiter ansteigen, so lange die Temperatur zu klein ist.
    Gruß
    Erich

  6. #6
    Mike Vanstrike ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    11.02.2011
    Beiträge
    14
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    hey,

    ja hab P & I auf on gesetzt und beide mit einem real-wert von 60.0 beaufschlagt! Hab auch hier schon mit verschiedenen werten getestet und keine veränderung festgestellt!
    Ich gehe davon aus das die Werte für P & I als %satz angegeben werden und habe mit dem wert 100 und 20 getestet, vieleicht sollte ich nicht immer den selben Wert bei P & I vorgeben???

    any ideas?

    mfg mike

  7. #7
    Registriert seit
    23.10.2009
    Beiträge
    392
    Danke
    58
    Erhielt 113 Danke für 87 Beiträge

    Standard

    Dir ist aber klar, dass TI eine Zeit und kein Faktor ist?
    Das sind bei Dir also 60 Sekunden. Größere Zeit entspricht kleinerem Faktor.
    Sieh Dir doch mal die internen Werte an, z. B. LMN_I, das ist der aktuelle I-Anteil. Geht der hoch solange eine Regelabweichung besteht?
    Geändert von LargoD (25.02.2011 um 18:05 Uhr)

  8. #8
    Mike Vanstrike ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    11.02.2011
    Beiträge
    14
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke für die hilfe!

    Habs dann doch noch hingekriegt am freitag!

  9. #9
    Mike Vanstrike ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    11.02.2011
    Beiträge
    14
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Danke für die hilfe!

    Habs dann doch noch hingekriegt am freitag!

Ähnliche Themen

  1. Temperaturregelung
    Von Fechten im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 02.12.2009, 14:51
  2. PID Regler _ Temperaturregelung
    Von hank12 im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 19.05.2008, 11:28
  3. Temperaturregelung
    Von Phil im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 29.04.2008, 18:21
  4. PID Regler für Temperaturregelung (110V) gesucht
    Von HSThomas im Forum Elektronik
    Antworten: 3
    Letzter Beitrag: 09.11.2006, 15:38
  5. Temperaturregelung mit S7 und Pt 100
    Von rainer_step5 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 11.10.2005, 10:37

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •