Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 18 von 18

Thema: Wibond Anzeige

  1. #11
    alexbr ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    11.03.2011
    Beiträge
    8
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    //edit Markus
    Beitrag aufgrund von Meldung durch WIBOND gelöscht.
    Unpassende Ausdrucksweise...
    Geändert von Markus (04.06.2012 um 18:15 Uhr)

  2. #12
    Registriert seit
    20.03.2011
    Beiträge
    1
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Alexbr,

    ich hoffe, daß ich es auswendig hin bekomme. Das Datentelegramm müsste so aussehen, falls es sich um eine Textanzeige handelt:

    Sendefreigabe 00hex oder 80hex
    Startzeichen <ESC>
    Adresse z. B. 1 (Achtung ist nicht die Profibusadresse (Slave), sondern die interne Adresse der Anzeige)
    Befehl für Textanzeige z. B. A
    Feld z.B. 1
    Schriftgröße z.B. 1
    Schriftart z.B. 1
    Helligkeit z.B. 3
    Daten z. B. Test
    Stoppzeichen <CR>

    "00hex oder 80hex"<ESC> 1 A 1 1 1 3 Test <CR>

    Vorab muss für die Sende Freigabe "00hex" oder "80hex" gesendet werden. Dies wechselt nach jedem Telegramm. Kommt dararuf an, was vorher gesendet wurde.

    Bei einer numerischen Anzeige würde ich folgendes probieren:

    "00hex oder 80hex"<ESC> 1 A 1 1 1 1 1 1 1 <CR>

    Da sollten dann 1er erscheinen.

    Wenn nicht den Support von Wibond anrufen, die wissen da schon Bescheid.

  3. #13
    alexbr ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    11.03.2011
    Beiträge
    8
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Vielen Dank ! Aber kannst du mir sagen wie ich dies programmieren soll?
    Mit Wibond bin ich seit 3 Wochen in Kontakt...

    //edit Markus
    Beitrag aufgrund von Meldung durch WIBOND geändert.
    Unpassende Ausdrucksweise...
    Geändert von Markus (04.06.2012 um 18:15 Uhr)

  4. #14
    Registriert seit
    17.07.2009
    Ort
    Am Rande der Ostalb
    Beiträge
    5.480
    Danke
    1.141
    Erhielt 1.241 Danke für 973 Beiträge

    Standard

    @meister

    So kenn ich das auch.

    @alexbr

    Ich hatte das mit einer kurzen Schrittkette gelöst
    War kein Akt.

    Gruß
    Dieter

  5. #15
    alexbr ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    11.03.2011
    Beiträge
    8
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Wie sah deine Schrittkette aus? Schreib mir die doch bitte mal auf!

  6. #16
    Registriert seit
    17.07.2009
    Ort
    Am Rande der Ostalb
    Beiträge
    5.480
    Danke
    1.141
    Erhielt 1.241 Danke für 973 Beiträge

    Standard

    Zitat Zitat von alexbr Beitrag anzeigen
    Wie sah deine Schrittkette aus? Schreib mir die doch bitte mal auf!
    Code:
    N1 Freigabe toggeln
    N2 Freigabe senden
    N3 Abfrage "Freigabe senden" fertig und ok
    N4 Wartezeit 100ms
    N5 Daten senden
    N6 Abfrage "Daten senden" fertig und ok
    N7 Ende
    Bei den Anzeigen gibt es wohl verschiedene Ausführungen. Es kann sein, dass du die Bytes einzeln und nicht als Datentelegramm schicken musst. Dies siehst du aber bei der GSD-Datei.

    Gruß
    Dieter

  7. #17
    Registriert seit
    09.04.2011
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo zusammen,
    habe die gleichen Probleme mit einer Wibond Textanzeige.
    Habe bei Wibond auch den Funktionsbaustein und Datenbaustein gekauft.
    Allerdings kann mir bei Wibond sonst keiner weiterhelfen.
    Wie soll der Quell-DB den man zusätzlich erstellen soll aussehen???
    Wann soll das Text Bit und das Copy Bit angesteuert werden???
    Für ein paar Typ`s im voraus vielen Dank.
    Zitieren Zitieren Textanzeige Wibond  

  8. #18
    Registriert seit
    09.04.2011
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo alexbr,
    habe die gleichen Probleme im Moment mit einer neuen Wibond Textanzeige.
    Bekomme trotz der bei Wibond gekauften Bausteine (FC99+DB8 keinen
    Text angezeigt. (über Profibus an S7-315DP)
    Wie muß der zusätzliche Quell-DB aussehen und wann muß ich welche Bit´s ansteuern.
    Vielleicht hast du schon ein Ergebnis,würde mich über jede Hilfe freuen.
    Im voraus vielen Dank.

Ähnliche Themen

  1. Wibond Anzeige programmieren
    Von Sebbl im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 26.01.2011, 11:48
  2. Antworten: 1
    Letzter Beitrag: 23.04.2010, 06:00
  3. Wibond Anzeige über S5 ansteuern
    Von Silversurfer im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 14.12.2009, 19:37
  4. S7-400 Ethernet CP + Wibond LED Anzeige
    Von jackjones im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 15.08.2007, 11:38
  5. Wibond Anzeige
    Von dna909 im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 12.07.2006, 18:11

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •