Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: Zuweisung verändert VKE nicht, oder vielleicht doch?

  1. #1
    Registriert seit
    05.10.2006
    Beiträge
    169
    Danke
    21
    Erhielt 19 Danke für 11 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich habe mal eine kleine Frage zu der einfach Zuweisung. In untenstehendem Code habe ich mehrere Zuweisungen untereinander, das heisst über M100.0 wird der VKE auf 1 gesetzt und per Zuweisung nach M200.0 kopiert, da das VKE nicht geändert wird kann ich auch noch M200.2 setzen.
    Jetzt möchte ich den vorhanden VKE zusätzlich noch mit M100.1 ODER verknüpfen und M200.1 zuweisen, das funktionert aber nicht, wieso?

    Code:
          U     M    100.0
          =     M    200.0
          =     M    200.2
          O     M    100.1
          =     M    200.1
    Zitieren Zitieren Zuweisung verändert VKE nicht, oder vielleicht doch?  

  2. #2
    Registriert seit
    31.08.2010
    Beiträge
    50
    Danke
    2
    Erhielt 10 Danke für 10 Beiträge

    Standard

    Funktioniert nicht, weil bei einer Zuweisung das Erstabfrage-Bit gesetzt wird. Damit beginnen nach "=" "R" "S" immer neue Logikabfragen.

    Will man M200.2 mit verodern, muss es also neu aufgerufen werden:
    = M200.2
    U M200.2
    O m100.1
    = M200.1

  3. #3
    Züttu ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.10.2006
    Beiträge
    169
    Danke
    21
    Erhielt 19 Danke für 11 Beiträge

    Standard

    Danke für die schnelle Antwort

    Wieso funktionieren denn zwei Zuwiesungen untereinander??

    Kann ich dieses Erstabfrage-Bit irgendwo beobachten?

  4. #4
    Registriert seit
    19.07.2010
    Beiträge
    1.289
    Danke
    213
    Erhielt 267 Danke für 233 Beiträge

    Standard

    Weil das Erstabfragebit bei nicht bei Zuweisungen sondern bei U bzw. O abgefragt wird.
    mfG Aventinus

  5. #5
    Registriert seit
    19.07.2010
    Beiträge
    1.289
    Danke
    213
    Erhielt 267 Danke für 233 Beiträge

    Standard

    Übrigens ist das Erstabfragebit das Bit 0 im Statuswort

    Wenn du dir den Bausteinstatus anschaust kannst du in AWL das Statuswort einblenden.
    mfG Aventinus

  6. Folgender Benutzer sagt Danke zu Aventinus für den nützlichen Beitrag:

    Züttu (23.03.2011)

  7. #6
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Nach einer Zuweisung ist die nächste Operation eine Erstabfrage.
    Da wird das VKE neu gebildet.
    Es gibt diese Art der Programmierung so weit ich weiß nur von BigS.
    Bei anderen PLC heißt es LD zu beginn der Abfragen.


    bike

Ähnliche Themen

  1. eigentlich doch flip/flop - oder?
    Von xinix im Forum CODESYS und IEC61131
    Antworten: 11
    Letzter Beitrag: 23.03.2011, 07:31
  2. FIFO oder doch nicht?!
    Von bapfy im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 12.04.2010, 18:35
  3. Antworten: 19
    Letzter Beitrag: 28.03.2010, 13:05
  4. China Export, oder doch CE?
    Von MSB im Forum Stammtisch
    Antworten: 3
    Letzter Beitrag: 04.08.2009, 22:03
  5. Hart is doch 'n Begriff , oder?
    Von Anonymous im Forum Feldbusse
    Antworten: 4
    Letzter Beitrag: 02.05.2004, 14:55

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •