Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: IM151-8 PN an Cognex

  1. #1
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.224
    Danke
    533
    Erhielt 2.698 Danke für 1.950 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich versuche gerade rel. erfolglos eine IM151-8 PN per TCP/IP mit einer Cognex-Kamera zu verbinden.
    Ich nutze das Siemens-Beispiel für OpenTCP.
    Der TConn-Baustein scheint die Verbindung aufzubauen. Es kommt ein Done und der MErker Connected geht auf True. Nun wird dem TRCV-Baustein der Req auf True gesetzt und dieser bringt mir dann dauerhaft 7002hex als Status, lt. Siemens-Hilfe "Zwischenaufruf (REQ irrelevant), Verbindung wird aufgebaut.

    Hat irgendwer einen Tip?

    PS: IP: 192.168.0.103
    Port: 23 --> Telent auf en Cognex vom PC aus hat funktioniert.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal
    Zitieren Zitieren IM151-8 PN an Cognex  

  2. #2
    Registriert seit
    22.05.2005
    Ort
    sonniges Maifeld
    Beiträge
    1.067
    Danke
    77
    Erhielt 205 Danke für 159 Beiträge

    Standard

    Connection-Typ? B#16#01 (TCP-Kompatibilitätsmodus) hat mir schon mal weiter geholfen, Fehlerbild war da ähnlich.
    "Man kann auf seinem Standpunkt stehen, aber man sollte nicht darauf sitzen" - Erich Kästner

  3. #3
    Avatar von Ralle
    Ralle ist offline Super-Moderator
    Themenstarter
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.224
    Danke
    533
    Erhielt 2.698 Danke für 1.950 Beiträge

    Standard

    Ha, er empfängt Daten, aber wenn der REQ von TRCV-Baustein auf Dauer-True steht gibt er immer 7002 aus...
    Ich hab das jetzt so gelöst, dass ich am TRCV eine Flanke für REQ anlege und einen internen Stat-Merker setze (Busy). Wenn das Done oder der Error kommt, dann wird Busy zurückgenommen. So kann man erkennen, ob auch wirklich etwas passiert.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  4. #4
    Registriert seit
    22.05.2005
    Ort
    sonniges Maifeld
    Beiträge
    1.067
    Danke
    77
    Erhielt 205 Danke für 159 Beiträge

    Standard

    Ach, du hast gar kein Problem

    Status 7002 ist normalzustand, ja.
    "Man kann auf seinem Standpunkt stehen, aber man sollte nicht darauf sitzen" - Erich Kästner

  5. #5
    Avatar von Ralle
    Ralle ist offline Super-Moderator
    Themenstarter
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.224
    Danke
    533
    Erhielt 2.698 Danke für 1.950 Beiträge

    Standard

    Zitat Zitat von Lars Weiß Beitrag anzeigen
    Ach, du hast gar kein Problem

    Status 7002 ist normalzustand, ja.
    Lol, scheint so.
    Aber so richtig schick ist das noch nicht, muß noch etwas mit den Auf- und Abbau machen.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  6. #6
    Registriert seit
    22.05.2005
    Ort
    sonniges Maifeld
    Beiträge
    1.067
    Danke
    77
    Erhielt 205 Danke für 159 Beiträge

    Standard

    Aufbau ? Einmalig. Ob100 Neustartmerker. Fertig. Abgebaut wird net.
    "Man kann auf seinem Standpunkt stehen, aber man sollte nicht darauf sitzen" - Erich Kästner

  7. #7
    Avatar von Ralle
    Ralle ist offline Super-Moderator
    Themenstarter
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.224
    Danke
    533
    Erhielt 2.698 Danke für 1.950 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Lars Weiß Beitrag anzeigen
    Aufbau ? Einmalig. Ob100 Neustartmerker. Fertig. Abgebaut wird net.
    Na ja, wenn einer das Kabel zieht, geht nix mehr. Deshalb werde ich bei jeder Grundstellungsfahrt die Verbindung ab- und wieder aufbauen. Das scheint ganz gut zu funzen. Ob die Kamera noch am Netz läuft, erkennt man leider erst über ein Timeout, beim Lesen. Das mag ich nicht so sehr.

    Aber nebenbei, das Teil kann man auch per Profinet einbinden, habe gerade die XML-Datei bekommen, warte aber noch auf ein paar Daten. Wenn das so funktioniert, wie es aussieht, gibt es dann sogar ein Betriebsbereit von der Kamera. Testen werde ich das auf jeden Fall.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

Ähnliche Themen

  1. Cognex & C# via Ethernet
    Von Wolf im Forum Hochsprachen - OPC
    Antworten: 3
    Letzter Beitrag: 29.11.2010, 21:50
  2. TCP Verbindung an Cognex Kamera
    Von Snoopy123123 im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 23.08.2010, 15:27
  3. [Biete] Cognex Checker 3G7
    Von erzteufele im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 06.08.2010, 09:29
  4. Cognex Kamera
    Von Trötschi im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 05.08.2010, 16:54
  5. Cognex dataman200
    Von bluebird277 im Forum CODESYS und IEC61131
    Antworten: 0
    Letzter Beitrag: 10.02.2010, 11:01

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •