Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: Analogausgang 4-20mA Softwaremäßig programmieren

  1. #1
    Registriert seit
    08.10.2009
    Ort
    Würzburg
    Beiträge
    24
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    meine Frage dazu ist das ich gerade daran scheitere das ich das software,äßig einfach nicht hinbekomme das er ab den 4mA "startet" fängt immer von 0 A an obwohl ich den lowlim und highlim festgelegt habe...

    kann auch im anhang mal das programmierte mitschicken falls es euch weiter hilft

    danke im vorraus
    Zitieren Zitieren Analogausgang 4-20mA Softwaremäßig programmieren  

  2. #2
    Registriert seit
    17.06.2010
    Ort
    nähe Memmingen
    Beiträge
    610
    Danke
    93
    Erhielt 116 Danke für 100 Beiträge

    Standard

    welche steuerung?
    üblicherweise wird das in der hardwareconfiguration
    eingestellt (0-20mA oder 4-20mA)

  3. #3
    bigrey ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    08.10.2009
    Ort
    Würzburg
    Beiträge
    24
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard

    ja ich weiß aber ich habe eine analogbaugruppe die nicht parametrierbar ist d.h. das ich das nicht hardwaremäßig machen kann... sondern nur softwaremäßig!!!!!

    6es7 334-0CE01-0AA0

  4. #4
    Registriert seit
    17.01.2010
    Beiträge
    197
    Danke
    81
    Erhielt 21 Danke für 20 Beiträge

    Idee

    Du errechnest, was der Sensor bei 0mA für einen Wert haben würde: Wert bei 0 (4mA) minus (Messbereich / 4).

    Diesen Wert gibst Du bei Lo_Lim ein.

  5. #5
    bigrey ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    08.10.2009
    Ort
    Würzburg
    Beiträge
    24
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von bimbo Beitrag anzeigen
    Du errechnest, was der Sensor bei 0mA für einen Wert haben würde: Wert bei 0 (4mA) minus (Messbereich / 4).

    Diesen Wert gibst Du bei Lo_Lim ein.

    funktioniert irgendwie nicht...
    habe jetzt ne andere lösung gefunden und zwar einfach addition... funktioniert ebenfalls

  6. #6
    Registriert seit
    17.01.2010
    Beiträge
    197
    Danke
    81
    Erhielt 21 Danke für 20 Beiträge

    Reden

    Genau!
    Geändert von bimbo (26.04.2011 um 16:31 Uhr)

  7. #7
    Registriert seit
    23.10.2009
    Beiträge
    398
    Danke
    59
    Erhielt 114 Danke für 88 Beiträge

    Standard

    Addition allein funktioniert bestimmt nicht, weil Du damit auch das Bereichsende verschiebst.

  8. #8
    Registriert seit
    17.06.2010
    Ort
    nähe Memmingen
    Beiträge
    610
    Danke
    93
    Erhielt 116 Danke für 100 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    0-20mA = 0 -27648 auf dem analogwert (peripheriewort)

    => 4-20mA = 5530 - 27648 (differenz = 22118 )

    geht dein wert zb. von 0 - 1000
    um diesen auszugeben:

    1. wert * 22,118 (ergibt 0-22118 => 0-16mA)
    2. addition von 5530 (addiert 4mA)
    3. auf ausgangswort schreiben

Ähnliche Themen

  1. Logo Baugruppe Analogausgang 4-20mA????
    Von MRT im Forum Sonstige Steuerungen
    Antworten: 9
    Letzter Beitrag: 17.12.2008, 14:41
  2. AE-Kanäle softwaremäßig deaktivieren?
    Von DarkLykan im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 04.12.2008, 16:21
  3. Antworten: 8
    Letzter Beitrag: 14.03.2008, 13:55
  4. 331 6ES7 7KF01 0AB0 0-20mA / 4-20mA
    Von BastiMG im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 06.12.2007, 08:08
  5. Analogausgang an CPU 224 XP programmieren ???
    Von Trollhammaren im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 19.04.2005, 18:04

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •