Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: Verbindung PG/SPS via Ethernet und unterschiedlichen SPSen

  1. #1
    Registriert seit
    18.04.2005
    Ort
    Fast an der Schweiz
    Beiträge
    856
    Danke
    208
    Erhielt 108 Danke für 76 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Leute,

    ich habe ein Projekt mit einer 400er erstellt und habe die Software im Büro getestet, ich habe die Verbindung PG/SPS via Ethernet gemacht und konnte immer verbinden etc.
    Nun muss ich die 400er ausliefern und kann sie im Büro nicht mehr benutzen.
    Im Büro habe ich eine 300 (317-2 PN/DP) ich habe die Hardware in der 300 entsprechend angepasst und möchte nun das 400er Programm (nur das Programm) auf die 300er laden. Aber die Schnittstelle will das nicht info ist "Kann über eingestellte schnittstelle bla bla usw... nicht erreicht werden..."
    Gibt es eine möglichkeit einfach zu sagen nehme die IP adresse ?? Das System motzt wahrscheinlich wegen 300<->400 ? Ich will nicht extra immer bausteine vom einem zum anderen Programm spielen.

    Merci vom Wälder
    Code:
     RTFM ! Read The F..ing Manual
    Arbeitet mit : Step7 V5.5 SPx / WinCC Flex 2008 SPx / Intouch / Winmod /TIA V14 (abgestürzt...Zitat der Hotline : "Sie dürfen nicht so viel rumdrücken....." TIA, so isses halt)

    ║▌║█║║▌║█║ Warnung! Falscher oder fehlender Kaffee - Benutzer angehalten --(◔̯◔)--
    1334566890111
    Zitieren Zitieren Verbindung PG/SPS via Ethernet und unterschiedlichen SPSen  

  2. #2
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.218
    Danke
    533
    Erhielt 2.696 Danke für 1.948 Beiträge

    Standard

    Du könntest den Programmordner, der ja unter "Hardware" residiert ganz hoch in den Projektordner kopieren oder auch ziehen. Danach fragt er beim Verbindungsaufbau, wohin er denn verbinden soll, denn es gibt ja keine mit dem Programm verbundene Hardware mehr. Mach aber vor dem Versuch eine Sicherungskopie des Projektes, WinCCFlex mag sowas nicht, wegen der symbolischen Verbindungen.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  3. #3
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.616
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard

    Ich kann mir vorstellen, das STEP7 der Ziel CPU Type überprüft.
    Ist der S7-400 CPU in Slot 2 ? Wenn es ist in Slot 3, dann versucht STEP7 ein CPU in Slot 3 zu finden, was nicht geht bei S7-300.

    Was gehen sollte:
    Der S7-300 CPU per "erreichbare Teilnahmer" zu öffnen, und dann per drag-and-drop die Bausteine von S7-400 Projekt zu kopieren.
    Ich glaube aber nicht das man die Bausteine dann online beobachten kann.

    Ich denke das PLCSIM wäre die bessere Lösung.
    Jesper M. Pedersen

  4. #4
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.616
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard

    Zitat Zitat von Ralle Beitrag anzeigen
    Du könntest den Programmordner, der ja unter "Hardware" residiert ganz hoch in den Projektordner kopieren oder auch ziehen. Danach fragt er beim Verbindungsaufbau, wohin er denn verbinden soll, denn es gibt ja keine mit dem Programm verbundene Hardware mehr.
    Oho, das wäre etwas neues für mich. Geht dann auch online beobachten ?
    Jesper M. Pedersen

  5. #5
    Avatar von Waelder
    Waelder ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    18.04.2005
    Ort
    Fast an der Schweiz
    Beiträge
    856
    Danke
    208
    Erhielt 108 Danke für 76 Beiträge

    Standard

    Muss nochmal aufgreifen... leider

    Die selbe problematik ist mit dem WinCCflex Panel
    Das mistding will auch die 400er cpu
    Kann man das nicht abstellen ? Trotz eindeutiger IP adresse keine Verbindung ?
    Code:
     RTFM ! Read The F..ing Manual
    Arbeitet mit : Step7 V5.5 SPx / WinCC Flex 2008 SPx / Intouch / Winmod /TIA V14 (abgestürzt...Zitat der Hotline : "Sie dürfen nicht so viel rumdrücken....." TIA, so isses halt)

    ║▌║█║║▌║█║ Warnung! Falscher oder fehlender Kaffee - Benutzer angehalten --(◔̯◔)--
    1334566890111

  6. #6
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.616
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard

    Anstatt die S7-400 CPU als Ziel Partner, ein "unspezifizierter" Partner.
    Dann muss man IP, rack und Slot manuell einstellen.
    Jesper M. Pedersen

  7. #7
    Registriert seit
    22.01.2009
    Beiträge
    288
    Danke
    61
    Erhielt 32 Danke für 25 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Im Projekt wo die 400er ist eine 300er Station erstellen.
    HW-Konfig einrichten, andere IP vergeben.
    Programm von der 400er in die 300er kopieren.
    400er löschen, IP der 300er ändern.
    In WinCCFlex Verbindung neu einstellen.
    Bausteing ggf. anpassen.
    Nicht alle Bausteine der 400er sind 300er kompatibel. z.B. FC5/FC6

    Gruß
    Klaus

Ähnliche Themen

  1. Verbindung PC-300 via Ethernet
    Von thomasgull im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 23.04.2010, 20:46
  2. Antworten: 33
    Letzter Beitrag: 10.02.2009, 21:14
  3. 315-2 PN/DP verbindung Ethernet / MPI / DP...
    Von erzteufele im Forum Simatic
    Antworten: 14
    Letzter Beitrag: 26.11.2008, 11:57
  4. AGLink-Verbindung zu meheren SPSen
    Von Raabun im Forum Hochsprachen - OPC
    Antworten: 10
    Letzter Beitrag: 07.10.2008, 06:25
  5. Ethernet Verbindung PC - S7 mit CP
    Von sali im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 31.08.2005, 02:12

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •