Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 7 ErsteErste 1234 ... LetzteLetzte
Ergebnis 11 bis 20 von 64

Thema: Gesamt Aufbau PanelPC

  1. #11
    Registriert seit
    20.10.2003
    Ort
    Biberach
    Beiträge
    5.068
    Danke
    959
    Erhielt 1.459 Danke für 922 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Helmut_von_der_Reparatur Beitrag anzeigen
    Deine ganze Fragestellung habe ich noch nicht wirklich verstanden, du
    hast einen IPC mit den du eine DP-Anschaltung betreiben möchtest,
    dann ist das ganze Netz halt Profibus DP und nicht in einen Teilsegment
    auf einmal MPI.
    Mit "unbenannt4" wird die Fragestellung klarer.

    Aber: kann den der PanelPC mit der WinLC so konfiguriert werden,
    dass er sich wie eine "normale" SPS verhält?
    Beste Grüße Gerhard Bäurle
    _________________________________________________________________
    Hardware: the parts of a computer that can be kicked. – Jeff Pesis

  2. #12
    Hiran ist offline Benutzer
    Themenstarter
    Registriert seit
    27.04.2011
    Beiträge
    41
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ja auf jedenfall. Noch steht der Aufbau in der Werkstatt. Aber solange ich keine Kommunikation zwischen der Klemme, dem IPC und der PG hinbekomme sollte es reichen. Ich hab eher das Problem, dass ich nicht weiß wie ich einen Profibus einrichte und wie genau die Kommunikation da läuft. Wie gesagt, bisher hab ich nur mit Simulierten SPS gearbeitet, da gabs keine Hardware die verschaltet werden wollte

    @ Gerhard Das weiß ich leider nicht. Ich hatte gehofft das es möglich ist.
    Geändert von Hiran (28.04.2011 um 10:37 Uhr)

  3. #13
    Registriert seit
    20.10.2003
    Ort
    Biberach
    Beiträge
    5.068
    Danke
    959
    Erhielt 1.459 Danke für 922 Beiträge

    Standard

    Der CP5711 kann doch Profibus, welchen Grund gibt es,
    hier mit MPI zu arbeiten?

    Hast Du den CP schon mal direkt mit dem PanelPC verbunden?

    Das würde ich als ersten Schritt mal zum Laufen bringen.
    Beste Grüße Gerhard Bäurle
    _________________________________________________________________
    Hardware: the parts of a computer that can be kicked. – Jeff Pesis

  4. #14
    Hiran ist offline Benutzer
    Themenstarter
    Registriert seit
    27.04.2011
    Beiträge
    41
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ja das hab ich und das läuft auch soweit. Zumindestens kann ich Bausteine erstellen und Übertragen. Er meckert zwar im Online Modus, das ihm Variablen fehlen aber die Kommunikation steht.

    Ich hab nur mit MPI angefangen weil mir das jemand im vorbei gehen eingerichtet hatte. Da der Buskoppler aber kein MPI kann muss ich ja alles auf PB umbauen. Ich schreib grad nur ne Bachelorarbeit und muss auf Hilfe immer seeehr lange warten

  5. #15
    Registriert seit
    13.10.2007
    Beiträge
    12.036
    Danke
    2.789
    Erhielt 3.269 Danke für 2.157 Beiträge

    Standard

    funktioniert den die Komunikation zum DP Teilnehmer (Beckhoff), bekommst
    du da irgendein lämpchen ans leuchte?

    Du kannst übrigens auch über Ethernet auf die Soft SPS zugreifen, wenn
    du in deiner Hardware Konfig einen "IE-Allgmein" einbindest. Diesen muß
    du natürlich im "KoKo" (Komponeten Konfigurator" auf PC Seite auch einstellen.
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  6. #16
    Hiran ist offline Benutzer
    Themenstarter
    Registriert seit
    27.04.2011
    Beiträge
    41
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Also den Laptop mit nem normalen Crossover Ethernet Kabel mit RJ45 Stecker auf den PanelPC? Dann brauch ich den CP5711 garnicht?

    Beim Kontroller leuchtet die Bus-Fehler LED und die I/O RUn led die normale RUN led und die über der 24V anzeige. Aber Sensoren oder ähnliches sind an den klemmen noch nicht angeschlossen.

    Ich hab grad versucht die einzelnen Klemmen einzugeben und die Hardware Konfiguration dann auf den IPC rübergeschoben. Als er dann wieder auf RUN gehen wollte kam die Fehlermeldung und bleibt mit BF in den Stop.

    WINLC
    Der DP-Treiber konnte nicht initialisiert werden.

    Sagt euch das was?
    Geändert von Hiran (28.04.2011 um 11:32 Uhr)

  7. #17
    Registriert seit
    02.02.2011
    Beiträge
    17
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo)) Wie ich gestern sagte: die Verbindung zw. Laptop und PanelPC über Ethernet (crossover oder patch+switch). Die Verbindung zw. PanelPC und Beckhoff mit Profibus-Kabel (die beide Stecker am Kabel müssen Terminatore, d.h. Endwiederständeschalter haben, dein MPI-Kabel passt nicht). Nach GSD-Dateie für die Beckhoffgruppen suchen (beim Glück passen auch die allgemeine Baugruppen). Überprüfe, ob im HW-Konfig dein Beckhoff als DP-Slave steht. Viel Erfolfg! ))

  8. #18
    Hiran ist offline Benutzer
    Themenstarter
    Registriert seit
    27.04.2011
    Beiträge
    41
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Grüß dich AOTAG

    Die GSD Datei habe ich bereits von Beckhoff runtergeladen und eingebunden und der Beckhoff ist auch als DP-Slave eingestellt. Allerdings kann ich im HW-Editor nicht genau meine Klemmen belegen. Die KL1408 z.B. wird nicht explizit aufgeführt, aber es gibt eine "8-Bit Eingang" die ich eingefügt habe.
    Die Kommunikation der einzelnen Elemente scheint ja zu funktionieren. Ich finde im Simatic Manager als Angeschlossene Baugruppen sowohl die Busklemme als auch den IPC. Also scheint das mit dem MPI kabel zu funktionieren. Es ist sicher keine tolle oder dauerhafte Lösung, aber für die erste Einrichtung und zum testen scheints zu reichen. Allerdings meldet mir die WINLCRTX eben diese Fehlermeldung wenn ich die HW-Konfiguration rüber schicke.
    "Der DP-Treiber konnte nicht initialisiert werden."
    Meinst du das der Fehler durch die Verbingungsart entsteht?

  9. #19
    Registriert seit
    02.02.2011
    Beiträge
    17
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Ah ja... Profibusadresse im HW-Konfig muss natürlich identisch sein mit der am Beckhoff eingestellte Adresse (2 kleine Drehschalter)

  10. #20
    Hiran ist offline Benutzer
    Themenstarter
    Registriert seit
    27.04.2011
    Beiträge
    41
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Rotes Gesicht


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Oha, da hab ich nicht drauf geachtet. Da muss ich mal eben zurück in die Werkstatt!

Ähnliche Themen

  1. PanelPC + WinCC flexible RT
    Von testuser im Forum HMI
    Antworten: 17
    Letzter Beitrag: 29.03.2010, 11:52
  2. Antworten: 13
    Letzter Beitrag: 26.02.2010, 11:54
  3. Panelpc IPC477C Bilder zu gross
    Von guenni im Forum HMI
    Antworten: 1
    Letzter Beitrag: 01.12.2009, 10:25
  4. PanelPC Arbeitsspeicher voll?
    Von bacardischmal im Forum HMI
    Antworten: 3
    Letzter Beitrag: 04.11.2009, 18:31
  5. PanelPC und WinAC RTX 2005
    Von lsr im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 21.08.2008, 21:22

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •