Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 3 ErsteErste 123
Ergebnis 21 bis 24 von 24

Thema: Zugriff auf falschen DB

  1. #21
    Registriert seit
    13.09.2010
    Beiträge
    2.292
    Danke
    178
    Erhielt 375 Danke für 355 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    vielleicht noch als Hinweis:

    Zitat Zitat von floh041183 Beitrag anzeigen
    Ich habe schon versucht an dieser Stelle erneut:

    AUF DB[DB_Nr] // DB_Nr wurde der INT-Wert 302 übergeben
    allerdings geht dann die SPS in STOP
    Die DB-Nr. solltest nicht als INT, sondern du als WORD übergeben ....


    Gruss

  2. #22
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.732
    Danke
    314
    Erhielt 1.520 Danke für 1.282 Beiträge

    Standard

    Zitat Zitat von SoftMachine Beitrag anzeigen
    Die DB-Nr. solltest nicht als INT, sondern du als WORD übergeben ....
    Und der Unterschied zwischen INT und WORD ist in dem Wertebereich was?
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  3. #23
    Registriert seit
    13.09.2010
    Beiträge
    2.292
    Danke
    178
    Erhielt 375 Danke für 355 Beiträge

    Standard

    Na, schau einfach hier:

    http://www.sps-forum.de/showthread.php?t=41114

    da wir ja wohl ein falscher Db aufgemacht ??

    vielleicht ist es hier die ursache ...?

    Gruss

  4. #24
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.732
    Danke
    314
    Erhielt 1.520 Danke für 1.282 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von SoftMachine Beitrag anzeigen
    Na, schau einfach hier:

    http://www.sps-forum.de/showthread.php?t=41114

    da wir ja wohl ein falscher Db aufgemacht ??

    vielleicht ist es hier die ursache ...?

    Gruss
    a) Die Ursache war schon vorher geklärt und hat damit nichts zu tun
    b) Wenn du den von dir hervorgeholten Thread gelesen und verstanden hättest,
    hätte sich dein Einwand auch hiermit erledigt
    (In dem Thread war das Problem, das die DB Nummer kein IN-Parameter sein kann,
    der Datentyp ist unerheblich).
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  5. Folgender Benutzer sagt Danke zu MSB für den nützlichen Beitrag:

    SoftMachine (06.06.2011)

Ähnliche Themen

  1. Micromaster 440 gibt falschen Sollwert an Motor aus
    Von extra im Forum Antriebstechnik
    Antworten: 8
    Letzter Beitrag: 15.09.2008, 20:09
  2. HMI / OPC Zugriff auf UDT
    Von Klomsi im Forum HMI
    Antworten: 7
    Letzter Beitrag: 08.01.2008, 16:36
  3. SPS Zugriff mit VB5
    Von Otto im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 16.03.2007, 11:22
  4. BOOL Ausgang am FC gibt falschen Wert aus..
    Von Jochen Kühner im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 23.12.2004, 12:26

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •