Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: Problem mit Weiterschaltung einer Schrittkette

  1. #1
    Registriert seit
    15.03.2011
    Ort
    Illingen
    Beiträge
    14
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo

    ich habe folgendes Problem beim Weiterschalten einer Schrittkette.

    Schritt 1 wird definitiv zurückgesetzt aber der nächste Schritt wird nicht bearbeitet.

    In der VAT wird der nächste Schritt als 1 angezeigt beim online beobachten des Bausteins habe ich aber keine 1 stehen.
    Vielleicht habt Ihr eine Idee an was das liegen könnte.

    Hier mal die AWL

    u db412.dbx0.1
    un E22.7
    s db412.dbx0.2
    r db412.dbx0.1


    u db412.dbx0.2
    u(
    L db215.dbw334
    L 30
    >=I
    )
    s db412.dbx0.3
    r db412.dbx0.2

    Ich habe auch schon die Datenbausteinbits gegen Merker getauscht und
    den Gleichen Efekt gehabt.

    Ich weiss gerade nicht weiter

    Gruss aus Riad

    Andy
    Zitieren Zitieren Problem mit Weiterschaltung einer Schrittkette  

  2. #2
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Zitat Zitat von Andy61 Beitrag anzeigen

    Hier mal die AWL

    u db412.dbx0.1
    un E22.7
    s db412.dbx0.2
    r db412.dbx0.1


    u db412.dbx0.2
    u(
    L db215.dbw334
    L 30
    >=I
    )
    s db412.dbx0.3
    r db412.dbx0.2
    Ich gehe davon aus, dass Doppelzuweisungen nicht vorliegen.

    Was steht im DB215.dbw334?
    Wenn dies größer oder gleich 30 ist, wird sofort in Db412.dbx0.3 gesetzt und der zweite Schritt wird beendet.

    Um zu prüfen wo und was klemmt, würde ich vor S DB412.dbx0.3 einen nicht benutzen Merker mit UND verknüpfen.
    Dann bleibt die Schrittkette definiert an dem Merker kleben.
    Wenn dennoch es weiter geht hast du an einer anderen Stelle ein Problem.
    Wenn nicht, dann vor dem nächsten Schritt usw, bis du siehst wo dein Problem ist.


    bike

  3. #3
    Andy61 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    15.03.2011
    Ort
    Illingen
    Beiträge
    14
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo bike

    das Problem liegt bei dem dbx0.2
    es wird in der VAT als true angezeigt und im Onlinestatus des Bausteins als 0
    Wenn ich dem dbx einen ausgang zuweise bleibt der ebenfalls auf 0
    Den gleichen Efekt habe ich auch wenn ich statt dem DBX einen freien Merker verwende.
    Das DBW ist auf jeden Fall <30

    Gruss

    Andy

  4. #4
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Wie ist der Status von DBX0.3?
    Ist es möglich eine Bremse vor dem 0.3 einbauen?
    Wenn nicht, dann einen unbenutzten Merker zusätzlich setzen.
    Den kannst du mit dem PG zurücksetzen.

    Aber, wenn im Status eine 0 und in der Vat eine 1 dann kann es eine Doppelzuweisung sein, über zuweisen oder transferieren.


    bike

  5. #5
    Andy61 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    15.03.2011
    Ort
    Illingen
    Beiträge
    14
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Der Status von dbx0.3 ist 0
    da ich das dbx0.2 schon durch einen freien Merker ersetzt habe kann ich eine Doppelzuweisung ausschließen.
    was mich sehr verwundert ist,dass die Schrittkette ein paar mal durchgelaufen ist
    und erst dann der Hänger auftrat.

    Gruss

    Andy

  6. #6
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Zitat Zitat von Andy61 Beitrag anzeigen
    Der Status von dbx0.3 ist 0
    da ich das dbx0.2 schon durch einen freien Merker ersetzt habe kann ich eine Doppelzuweisung ausschließen.
    was mich sehr verwundert ist,dass die Schrittkette ein paar mal durchgelaufen ist
    und erst dann der Hänger auftrat.

    Gruss

    Andy
    Nicht ersetzen, sondern zusätzlich einen Merker setzen.
    und am Ende der Schrittkette zurücksetzen.
    SO kannst du prüfen ob und welcher Schritt angefahren wurde.
    Dann bleibt dir die Kette auf Schritt 1 dbx 0.1 stehen, wenn ich es richtig verstehe?


    bike

  7. #7
    Andy61 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    15.03.2011
    Ort
    Illingen
    Beiträge
    14
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    So das Problem hat sich erledigt.
    Ich habe heut morgen die CPU urgelöscht und das Programm neu aufgespielt.
    Seither läuft die Schrittkette fehlerlos.

    Gruss

    Andy

  8. #8
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Andy61 Beitrag anzeigen
    So das Problem hat sich erledigt.
    Ich habe heut morgen die CPU urgelöscht und das Programm neu aufgespielt.
    Seither läuft die Schrittkette fehlerlos.

    Gruss

    Andy
    Schön, dass es funktioniert.
    Doch besser wäre es nach meiner Ansicht, den Fehler zu suchen, denn es muss ja eine Ursache sein.
    Es kommt uncool, wenn du in den Flieger willst du und dann steht das Ding wieder.
    Das hatte ich leider schon einmal auf dem Weg zurück aus Chile.


    bike

Ähnliche Themen

  1. PID-Regler in einer Schrittkette
    Von zloyduh im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 23.05.2009, 17:56
  2. Problem mit einer S7-200
    Von V.Meinhard im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 04.06.2008, 21:44
  3. Antworten: 10
    Letzter Beitrag: 26.11.2007, 16:34
  4. Transitionen einer Schrittkette
    Von neon im Forum Programmierstrategien
    Antworten: 7
    Letzter Beitrag: 28.11.2006, 11:00
  5. Timer in einer Schrittkette
    Von DirkKuhn im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 22.08.2005, 16:53

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •