Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Results 1 to 6 of 6

Thread: bin neu, brauche hilfe

  1. #1
    Maddi0406 Gast

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    hallo, eine frage..
    wenn ich in WIN SPS bausteine senden oder empfangen will, muss ich da bei der SPS irgend ein schatler besonders stellen, sprich auf RUN, STOP oder COPY..???

    achso, es handelt sich um eine S5-100U CPU 103
    Reply With Quote Reply With Quote Answered: bin neu, brauche hilfe  

  2. "ok..danke..

    aber irgendwie funzt es nicht..

    hab an meinemrs232 stecker nen usb wandler dran, hab auch den richtigen com port eingestellt (com2) aber das programm ssagt mir immer wieder "schnittstelle unklar" nachdem es einige zeit probiert hat was zu lesen...

    hatte früher sps in der schule, aber hab alles vergessen und wollt mich da mal wieder rein lernen, aber ich gebs glaub ich auf..."


  3. #2
    Join Date
    20.06.2003
    Location
    Sauerland.NRW.Deutschland
    Posts
    5,451
    Danke
    99
    Erhielt 923 Danke für 628 Beiträge

    Default

    nein. schalter muss auf run oder stop stehen
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download auf meiner HP
    zum Download im Internet (Backup nicht unbedingt aktuell)

  4. #3
    Maddi0406 Gast

    Default

    ok..danke..

    aber irgendwie funzt es nicht..

    hab an meinemrs232 stecker nen usb wandler dran, hab auch den richtigen com port eingestellt (com2) aber das programm ssagt mir immer wieder "schnittstelle unklar" nachdem es einige zeit probiert hat was zu lesen...

    hatte früher sps in der schule, aber hab alles vergessen und wollt mich da mal wieder rein lernen, aber ich gebs glaub ich auf...

  5. #4
    Join Date
    20.06.2003
    Location
    Sauerland.NRW.Deutschland
    Posts
    5,451
    Danke
    99
    Erhielt 923 Danke für 628 Beiträge

    Default

    liegt vermutlich am usb adapter. diese dinger machen oft ärger. leider.
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download auf meiner HP
    zum Download im Internet (Backup nicht unbedingt aktuell)

  6. #5
    Join Date
    19.06.2003
    Posts
    2,299
    Danke
    85
    Erhielt 274 Danke für 179 Beiträge

    Default

    Das Übertragungsprotokol der S5-Famillie ist recht zeitkritisch: kommen ein oder mehrere Zeichen nicht innerhalb einer gewissen Zeit, bricht die CPU die Kommunikation ab.
    Als das entworfen wurde, war CP/M ein gängiges Betriebsystem und die Software wurde dafür geschrieben und die PGs damit ausgestattet.
    Windows bringt Verzögerungen rein und USB nochmal.
    Helfen könnte (etwa in dieser Reihenfolge):
    - Ein "richtiger" COM-Port, auch als PCCard.
    - Kein anderes PCI-Gerät mit demselben IRQ betreiben.
    - Falls sich die Größe des FIFOs für den COM-Port einstellen läßt, so einstellen, daß bei jedem Zeichen sofort ein Interrupt generiert wird.
    - Anderen USB-Port probieren, vielleicht hat der Mainboard-Hersteller welche bevorzugt angebunden.
    - Ein schneller Rechner
    - Im Hintergrund laufende Prozesse stoppen

  7. #6
    Join Date
    13.09.2005
    Posts
    675
    Danke
    8
    Erhielt 8 Danke für 6 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    War ein Treiber bei dem Adapter dabei?

    Der Treiber muß unbedingt installiert werden, ggf. auch deinstalliert und neu installiert.

    Bei mir hat der USB/MPI Adapter für die S7 erst nach Neuinstallation des Treiber bei eingeschalteter SPS und angestecktem Adapter funktioniert.

    Evtl. mußt du je nach Treiber auch in der Systemsteuerung die Schnittstelle einstellen.

Similar Threads

  1. Replies: 8
    Last Post: 08.03.2012, 10:27
  2. Replies: 31
    Last Post: 09.09.2011, 23:02
  3. Bin neu hier...
    By Pro² in forum Stammtisch
    Replies: 10
    Last Post: 11.10.2009, 22:26
  4. Hi bin neu hier
    By woodimweb in forum Stammtisch
    Replies: 4
    Last Post: 05.09.2006, 14:28
  5. Hilfe, bin neu in der SPS-Szene
    By chicha in forum Stammtisch
    Replies: 3
    Last Post: 01.07.2005, 14:14

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •