Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 29

Thema: Kommunikation CP341

  1. #11
    Registriert seit
    04.02.2007
    Beiträge
    2.544
    Danke
    167
    Erhielt 731 Danke für 528 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von husox81 Beitrag anzeigen
    Kann mir jemand dabei helfen? Wäre sehr wichtig!

    LG
    Sone kacke kenne ich nur von den Junkies die sich hier die Hausaufgaben machen lassen wollen, aber hier geht es ja um eine Reelle Anlage.
    Was Soll die Hektik ??
    Erst mal die Handbücher von Siemens laden, dann die Forumssuche benutzen, dann erst mal die Bausteine usw installieren und Handbücher lesen. ....

    Und wenn dann eine Frage kommt , kann man sich hier melden.

    Also so ein Scheiß von wegen "ich hab ein Problem aber weiss nicht welches" geht mir echt auch den Senkel.

    Einsetzen zu 100%, warum ? wenn du nur 50% benötigst . Warum willst du Funktionen haben und verwenden deren Tragweite du gar nicht ersehen kannst.

    Also: Detaillierte Aufgabenbeschreibung und Detaillierte Angabe wo das Problem ist.
    „Wenn du ein Problem hast, versuche es zu lösen. Kannst du es nicht lösen, dann mache kein Problem daraus.“
    Siddhartha Gautama

  2. Folgende 4 Benutzer sagen Danke zu jabba für den nützlichen Beitrag:

    bike (21.06.2011),Paul (22.06.2011),uncle_tom (23.06.2011),Verpolt (21.06.2011)

  3. #12
    Registriert seit
    08.09.2008
    Beiträge
    57
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo, habe folgendes programmiert und es funktioniert nicht!

    Für das senden:
    Code:
    CALL  FB     8 , DB50
           SF      :=
           REQ     :=M120.0
           R       :=M120.1
           LADDR   :=5
           DB_NO   :=42
           DBB_NO  :=16898
           LEN     :=52
           R_CPU_NO:=
           R_TYP   :='X'
           R_NO    :=
           R_OFFSET:=
           R_CF_BYT:=
           R_CF_BIT:=
           DONE    :=M120.6
           ERROR   :=M120.7
           STATUS  :=MW122
    Für das Empfangen:
    Code:
    CALL  FB     7 , DB70
           EN_R    :=M121.0
           R       :=M121.1
           LADDR   :=5
           DB_NO   :=43
           DBB_NO  :=16981
           L_TYP   :=
           L_NO    :=
           L_OFFSET:=
           L_CF_BYT:=
           L_CF_BIT:=
           NDR     :=M121.6
           ERROR   :=M121.7
           LEN     :=
           STATUS  :=MW124
    Laut der Dokumentation vom Waagehersteller musst es doch passen oder?

  4. #13
    Registriert seit
    13.09.2010
    Beiträge
    2.292
    Danke
    178
    Erhielt 375 Danke für 355 Beiträge

    Standard

    Hallo....


    Zitat Zitat von SoftMachine Beitrag anzeigen
    Hallo !
    Na, erstmal hier im Forum suchen (hab´da schon mal was rausgesucht) :
    http://www.sps-forum.de/showthread.p...ighlight=cp341
    http://www.sps-forum.de/showthread.p...ighlight=cp341

    und auch die Suchfunktion (Schlüsselwort MODBUS + CP341) bei S. gibt einiges her wie hier z.B.:
    http://support.automation.siemens.co...csQuery0=cp341 modbus&subtype=130000
    Hoffe, es hilft erstmal weiter..
    Gruss

    Zitat Zitat von jabba Beitrag anzeigen
    Erst mal die Handbücher von Siemens laden, dann die Forumssuche benutzen, dann erst mal die Bausteine usw installieren und Handbücher lesen (und Forumsbeiträge). ....

    Und wenn dann eine Frage kommt , kann man sich hier melden.
    Also: Detaillierte Aufgabenbeschreibung und Detaillierte Angabe wo das Problem ist.
    Hast du dich also erstmal überhaupt schlau gemacht ...?

    Gruss
    kind regards
    SoftMachine

  5. #14
    Registriert seit
    08.09.2008
    Beiträge
    57
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    ja das habe ich!

    Man braucht doch eigentlich nur die Bibliotheksbausteine FB8 "P_SND_RK" und FB7 "P_RCV_RK". Diese beschalten wie ich es hier gezeigt habe!

    Trotzdem kriege ich keine Information von der Waage bzw. ich kann keine senden!

  6. #15
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.222
    Danke
    533
    Erhielt 2.697 Danke für 1.949 Beiträge

    Standard

    Du hast wirklich als Ladeadresse 5 in der Hardwarekonfig ????

    In der Hilfe zum FB7 steht

    REQ INPUT BOOL Auftragsanstoß bei positiver Flanke
    R INPUT BOOL Auftragsabbruch Laufender Auftrag wird abgebrochen,
    Senden gesperrt.
    LADDR INPUT INT Basisadresse des CP*341 Adresse wird aus STEP 7 entnommen.
    DB_NO INPUT INT Datenbausteinnummer CPU-spezifisch (nicht 0), Sende-DB
    DBB_NO INPUT INT Datenbytenummer 0 <= DBB_NO <= 8190, Sendedaten ab Datenbyte
    LEN INPUT INT Datenlänge 1 <= LEN <= 1024, Angabe in Anzahl Byte
    DONE* OUTPUT BOOL Auftrag fertig ohne Fehler Parameter STATUS == 16#00
    ERROR* OUTPUT BOOL Auftrag fertig mit Fehler Parameter STATUS enthält die Fehlerinformation.
    STATUS* OUTPUT WORD Spezifikation des Fehlers Bei ERROR == 1 steht im Parameter STATUS die Fehlerinformation.
    * Parameter stehen nur einen CPU-Zyklus lang zur Verfügung.
    Das wäre mal zu prüfen.

    Was steht im Status der FB, MW122 und MW124?

    Achtung, beachte Bitte die Sternchen an DONE, ERROR und STATUS!
    Geändert von Ralle (23.06.2011 um 08:55 Uhr)
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  7. #16
    Registriert seit
    08.09.2008
    Beiträge
    57
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    also ich habe Screenshots bezüglich der Hardwarekonfig gemacht!
    Angehängte Dateien Angehängte Dateien

  8. #17
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.222
    Danke
    533
    Erhielt 2.697 Danke für 1.949 Beiträge

    Standard

    Zitat Zitat von husox81 Beitrag anzeigen
    Hallo,

    also ich habe Screenshots bezüglich der Hardwarekonfig gemacht!
    Die LADDR ist schon mal 2064, bitte ändern.
    Hast du mal im 2. Bild deiner PDF auf Parameter geklickt, da ist evtl. noch etwas zum Protokoll einzustellen.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  9. #18
    Registriert seit
    08.09.2008
    Beiträge
    57
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Die Einstellungen bei Parameter habe ich doch in PDF dargestellt oder meinst du was anderes?

  10. #19
    Registriert seit
    06.01.2005
    Ort
    im schönen Lipperland
    Beiträge
    4.472
    Danke
    498
    Erhielt 1.143 Danke für 736 Beiträge

    Standard

    Zitat Zitat von Ralle Beitrag anzeigen
    Die LADDR ist schon mal 2064, bitte ändern.
    Hast du mal im 2. Bild deiner PDF auf Parameter geklickt, da ist evtl. noch etwas zum Protokoll einzustellen.

    Hast du das gemacht ? Ohne die Änderung wird es gar nicht gehen... dann den Status auswerten wenn es immer noch nicht geht und hier reinstellen
    Früher gab es Peitschen .... heute Terminkalender

  11. #20
    Registriert seit
    08.09.2008
    Beiträge
    57
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    ja habe ich!

    In beiden Statuswörtern steht 16#0!

Ähnliche Themen

  1. Antworten: 2
    Letzter Beitrag: 02.02.2011, 14:17
  2. CP341 Kommunikation RK512
    Von mertens2 im Forum Simatic
    Antworten: 24
    Letzter Beitrag: 26.08.2006, 14:01
  3. S7 Cp341
    Von Lars Weiß im Forum Suche - Biete
    Antworten: 8
    Letzter Beitrag: 30.05.2006, 13:10
  4. CP341
    Von Hamster im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 30.07.2004, 16:20
  5. Antworten: 9
    Letzter Beitrag: 14.09.2003, 20:35

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •