Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 3 ErsteErste 123
Ergebnis 21 bis 29 von 29

Thema: Kommunikation CP341

  1. #21
    Registriert seit
    06.01.2005
    Ort
    im schönen Lipperland
    Beiträge
    4.472
    Danke
    498
    Erhielt 1.143 Danke für 736 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Dann sollte doch alles funktionieren..........
    Früher gab es Peitschen .... heute Terminkalender

  2. #22
    Registriert seit
    08.09.2008
    Beiträge
    57
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    An der CP341 Karte leuchten mir die TXD und RXD nicht.

    Ich habe Screenshots von dem SEND-DB und RECEIVE-DB gemacht!
    Da erhalte ich nichts!

    Vom Herstellerdokument von der Waage, wird auf HEX Adressen hingewiesen!

    Irgendwo ist der Haken aber ich weiss nicht wo!

  3. #23
    Registriert seit
    08.09.2008
    Beiträge
    57
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Den Anhang habe ich vergessen!
    Angehängte Dateien Angehängte Dateien

  4. #24
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.220
    Danke
    533
    Erhielt 2.696 Danke für 1.948 Beiträge

    Standard

    Zitat Zitat von husox81 Beitrag anzeigen
    ja habe ich!

    In beiden Statuswörtern steht 16#0!
    Die Parameterfenster hatte ich nicht gesehen, das sieht ja ok aus.
    Sendet die Waage überhaupt etwas, also ist sie korrekt parametriert
    Es kommt also auch kein Error-Bit am FB, wenn du z.Bsp. Senden auf True schaltest?
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  5. #25
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.220
    Danke
    533
    Erhielt 2.696 Danke für 1.948 Beiträge

    Standard

    Noch etwas, du mußt bei DBB_No jeweils 0 eingeben, dies bezieht sich auf die Lage des Datenfachs im Empfangs- bzw. Sende-DB.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  6. #26
    Registriert seit
    08.09.2008
    Beiträge
    57
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    So habe jetzt die Screenshots von den beiden FC´s mit senden und empfangen gemacht!
    Angehängte Dateien Angehängte Dateien

  7. #27
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.220
    Danke
    533
    Erhielt 2.696 Danke für 1.948 Beiträge

    Standard

    Zitat Zitat von husox81 Beitrag anzeigen
    So habe jetzt die Screenshots von den beiden FC´s mit senden und empfangen gemacht!
    Der Auftragsanstoß erfolgt für Send, bei Flanke an REQ. Der Empfangs-FB muß enabled werden und sollte dann Daten empfangen und im Empfangsfach ablegen, so auch welche gesendet werden!
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  8. #28
    Registriert seit
    07.06.2006
    Ort
    Bayern
    Beiträge
    623
    Danke
    27
    Erhielt 156 Danke für 139 Beiträge

    Standard

    Hallo allerseits,

    also ich hab mir jetzt mal aufmerksam den kompletten Thread durchgelesen und bin zu der Erkenntniss gekommen, dass ich "jabba" 100%ig zustimmen kann.

    Entweder bist du zu faul und willst dir keine Mühe machen, dich vernünftig in die Dokumentationen einzuarbeiten, oder bei dir ist generell Hopfen und Malz verloren - Sorry.

    Laut den PDF´s und den Threads auf der 1. Seite bist du dabei eine Modbus-Kommunikation mittels CP341 aufzubauen. Ich geh mal davon auss, dass du hierzu den ladbaren Siemens-Treiber verwendest.
    Ist der Treiber überhaupt im CP341 geladen bzw. steckt der Hardwaredongle ?
    Weiterhin wird die Waage von selber nichts senden, da sie vermutlich als Modbus-Slave arbeitet. D.h. du musst der Waage mitteilen, welche Daten du haben möchtest bzw. du must einen Modbus Request zur Waage schicken.
    Hierzu müsste in deinem Sende-DB aber ein Modbus-Auftrag hinterlegt sein - bei dir sind aber alle Bytes 0. Weiterhin gibst du als Länge für den Sende-DB43 beim FB8 64 Byte an - dein DB43 hat aber nur 4 Byte ???

    Vielleicht solltest du dich erstmal in die Modbus-Grundlagen einarbeiten - sonst wird das garantiert nichts. Die Modbus-Spezifikationen findest Du hier Link
    Wenn du das begriffen hast, dann schau dir mal gründlich die Doku zum ladbaren Siemens Modbus-Treiber an Link

  9. Folgende 3 Benutzer sagen Danke zu uncle_tom für den nützlichen Beitrag:

    jabba (23.06.2011),Ralle (23.06.2011),SoftMachine (23.06.2011)

  10. #29
    Registriert seit
    13.09.2010
    Beiträge
    2.292
    Danke
    178
    Erhielt 375 Danke für 355 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    ... zustimmung..
    kind regards
    SoftMachine

Ähnliche Themen

  1. Antworten: 2
    Letzter Beitrag: 02.02.2011, 14:17
  2. CP341 Kommunikation RK512
    Von mertens2 im Forum Simatic
    Antworten: 24
    Letzter Beitrag: 26.08.2006, 14:01
  3. S7 Cp341
    Von Lars Weiß im Forum Suche - Biete
    Antworten: 8
    Letzter Beitrag: 30.05.2006, 13:10
  4. CP341
    Von Hamster im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 30.07.2004, 16:20
  5. Antworten: 9
    Letzter Beitrag: 14.09.2003, 20:35

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •