Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 4 ErsteErste 1234 LetzteLetzte
Ergebnis 11 bis 20 von 38

Thema: Umschaltung zwischen Hand- Automatikbetrieb

  1. #11
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von pinolino Beitrag anzeigen
    Hm, habe da noch ein Problem wo ich den Befehl SAVE zu programmieren habe.

    Normalerweise muss doch der Befehl SAVE am Ende eines Bausteins programmiert werden, um das BIE-Bit auf den Signalzustand des aktuellen VKE des Bausteins zu setzen.

    Kann ich dann den Befehl SAVE einfach an den ENO-Ausgang der FC1 setzen?

    Danke...
    save wird im baustein programmiert und je nachdem ob aktiv oder inaktive kannst du mit set oder clr das vke vorgeben
    die weiterverarbeitung erfolgt dann außerhalb am ENO
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  2. #12
    pinolino ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.10.2007
    Beiträge
    261
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ok, vielen Dank vierlagig.

    D.h. also, dass ich in der FC1 im letzten Netzwerk einfach eine FUP-Box mit dem Befehl SAVE einfüge, richtig?

    Dann muss ich mir noch überlegen, wie ich

    Code:
    UN BIE
    R  "M_Betriebsart"
    im OB1 in FUP umsetzen kann...

  3. #13
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    Zitat Zitat von pinolino Beitrag anzeigen
    Ok, vielen Dank vierlagig.

    D.h. also, dass ich in der FC1 im letzten Netzwerk einfach eine FUP-Box mit dem Befehl SAVE einfüge, richtig?
    und ein sinnvolles VKE vorher bildest, ja

    Zitat Zitat von pinolino Beitrag anzeigen
    Dann muss ich mir noch überlegen, wie ich

    Code:
    UN BIE
    R  "M_Betriebsart"
    im OB1 in FUP umsetzen kann...
    siehe anhang
    Angehängte Grafiken Angehängte Grafiken
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  4. #14
    pinolino ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.10.2007
    Beiträge
    261
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Sorry für die vielen Fragen vierlagig... habe das noch nicht gemacht.

    Soweit ich das jetzt verstanden habe:

    Ist das BIE am Bausteinende 1, so ist ENO 1

    Ist das BIE am Bausteinende 0, so ist ENO 0


    So, wenn ich nun an den ENO-Ausgang der FC1 die FUP-Box (mit Rücksetze "M_Betriebsart") setze, so wird der Merker immer dann rückgesetzt, sobald der ENO-Ausgang den Status 1 hat; also das BIE-Bit = 1 ist, oder?

    Wenn das so stimmt, dann muss ja der Befehl SAVE in der FC1 so verknüpft werden, dass während der gesamten Bearbeitung des Automatikbetriebs der ENO-Ausgang den Status 0 hat... ist das richtig?


    Vielen Dank!
    Geändert von pinolino (29.06.2011 um 10:48 Uhr)

  5. #15
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    F1

    save
    beschreibung

    save speichert das vke im bie-bit. Das erstabfragebit /er wird dabei nicht zurückgesetzt.
    Aus diesem grund wird bei einer und-verknüpfung im nächsten netzwerk der zustand des bie-bits mitverknüpft.

    Die verwendung von save und eine nachfolgende abfrage des bie-bits im gleichen baustein oder in unterlagerten bausteinen wird nicht empfohlen, da das bie-bit durch zahlreiche dazwischen liegende operationen verändert werden kann. Sinnvoll ist der einsatz der operation save vor verlassen eines baustein, da damit der eno-ausgang (=bie-bit) auf den wert des vke-bits gesetzt wird und sie daran eine fehlerbehandlung des bausteins anschließen können.
    set
    set setzt das vke auf den signalzustand "1".
    clr
    CLR setzt das VKE auf den Signalzustand "0".
    So, wenn ich nun an den ENO-Ausgang der FC1 die FUP-Box mit Rücksetze "M_Betriebsart" setze, so wird der Merker immer dann rückgesetzt, sobald der ENO-Ausgang den Status 1 hat; also das BIE-Bit = 1 ist, oder?
    Ja

    Wenn das so stimmt, dann muss ja der Befehl SAVE so verknüpft werden, dass während der gesamten Bearbeitung des Automatikbetriebs der ENO-Ausgang den Status 0 hat... ist das richtig?
    Nicht ganz.

    ..Sinnvoll ist der einsatz der operation save vor verlassen eines baustein, da damit der eno-ausgang (=bie-bit) auf den wert des vke-bits gesetzt wird und sie daran eine fehlerbehandlung des bausteins anschließen können.

  6. #16
    pinolino ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.10.2007
    Beiträge
    261
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke verpolt!

    Aber ich muss doch nun im Grunde eine sinnvolle Verknüpfung für den Befehl SAVE finden, die mir, solange die FC1 aufgerufen ist, den ENO-Ausgang auf Status 0 setzt.

    Soll auf Handbetrieb umgeschaltet werden, so müsste ja dann der ENO-Ausgang über SAVE auf den Status 1 gesetzt werden.

    Stimmt das so und wie könnte dann die Verknüpfung vor SAVE aussehen?

  7. #17
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Zitat Zitat von pinolino Beitrag anzeigen
    Danke verpolt!

    Aber ich muss doch nun im Grunde eine sinnvolle Verknüpfung für den Befehl SAVE finden, die mir, solange die FC1 aufgerufen ist, den ENO-Ausgang auf Status 0 setzt.

    Soll auf Handbetrieb umgeschaltet werden, so müsste ja dann der ENO-Ausgang über SAVE auf den Status 1 gesetzt werden.

    Stimmt das so und wie könnte dann die Verknüpfung vor SAVE aussehen?
    ganz ehrlich...?

    lass das mit den EN/ENO im Bezug auf Betriebsarten.

    Ist ein Baustein fehlerfrei durchlaufen, wird ENO=1 gesetzt.

    Deine Betriebsart/Hand/Auto läßt sich doch einfach mit 2-3 Netzwerken in FUP "erschlagen".

    Dann kannst in jedem Baustein den "MerkerAutobetrieb" oder "Handbetrieb" in deine Bedingungen einfließen lassen.

  8. #18
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    Zitat Zitat von Verpolt Beitrag anzeigen
    ganz ehrlich...?

    lass das mit den EN/ENO im Bezug auf Betriebsarten.

    Ist ein Baustein fehlerfrei durchlaufen, wird ENO=1 gesetzt.

    Deine Betriebsart/Hand/Auto läßt sich doch einfach mit 2-3 Netzwerken in FUP "erschlagen".

    Dann kannst in jedem Baustein den "MerkerAutobetrieb" oder "Handbetrieb" in deine Bedingungen einfließen lassen.
    och menno
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  9. #19
    pinolino ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.10.2007
    Beiträge
    261
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von Verpolt Beitrag anzeigen
    ganz ehrlich...?

    Deine Betriebsart/Hand/Auto läßt sich doch einfach mit 2-3 Netzwerken in FUP "erschlagen".

    Dann kannst in jedem Baustein den "MerkerAutobetrieb" oder "Handbetrieb" in deine Bedingungen einfließen lassen.
    Danke verpolt, aber ich verstehe leider nicht was du meinst...

    Du meinst, es gibt zwei Merker - einen für Automatikbetrieb und einen für Handbetrieb?

    Soweit so gut, aber mein Problem war ja, dass eine Umschaltung zwischen den Betriebsarten nur dann möglich sein soll, wenn vorher der Aus-Taster betätigt wurde - und das ist ein Problem für mich!

  10. #20
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von pinolino Beitrag anzeigen
    Danke verpolt, aber ich verstehe leider nicht was du meinst...

    Du meinst, es gibt zwei Merker - einen für Automatikbetrieb und einen für Handbetrieb?

    Soweit so gut, aber mein Problem war ja, dass eine Umschaltung zwischen den Betriebsarten nur dann möglich sein soll, wenn vorher der Aus-Taster betätigt wurde - und das ist ein Problem für mich!
    Sollte es nicht auch einen Ein-Taster geben?
    Angehängte Grafiken Angehängte Grafiken
    • Dateityp: jpg bta.jpg (141,6 KB, 33x aufgerufen)

Ähnliche Themen

  1. Programm Hand-/Automatik
    Von gita07 im Forum Simatic
    Antworten: 35
    Letzter Beitrag: 11.02.2011, 18:19
  2. Automatikbetrieb
    Von luke89 im Forum Programmierstrategien
    Antworten: 26
    Letzter Beitrag: 16.05.2009, 19:59
  3. Einzelnen Wert in DB per Hand überschreiben
    Von Wassermann im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 18.09.2007, 16:43
  4. Funktionsplan für Automatikbetrieb wie???
    Von Kante85 im Forum Programmierstrategien
    Antworten: 24
    Letzter Beitrag: 10.09.2007, 10:14
  5. Umschaltung Hand/Auto: Auswirkung auf die Anlage
    Von Anonymous im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 02.01.2006, 19:41

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •