Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 4 ErsteErste 1234 LetzteLetzte
Ergebnis 11 bis 20 von 31

Thema: Remotezugriff mit Versuchsanlage im Büro

  1. #11
    Cutty ist offline Benutzer
    Themenstarter
    Registriert seit
    14.04.2011
    Beiträge
    51
    Danke
    13
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Alles klar, es ist der Ältere . Er hat auch nicht die zusätzliche LAN-Schnittstelle, da hab ich mich verguckt. Ich dachte es sei diese Schnittstelle, wo "RJ45/Line" dran steht. Das hätten wir also geklärt ^^.

    Ich habe den Router jetzt erstmal ins Firmennetzwerk gesteckt. Wenn ich jetzt den Befehl "netstat" in die Kommandozeile eingebe, bekomme ich eine IP-Adresse aus dem Firmennetzwerk, die auf jeden Fall nicht die vom PG ist. Ist das jetzt meine öffentliche IP-Adresse vom Router? Anpingen kann ich die schonmal. Oder wie bekomme ich die raus?
    Falls es diese ist, kann ich die aber nicht als Router-Adresse bei der SPS eingeben...da kommt eine Fehlermeldung, dass die Subnetzadressen nicht übereinstimmen.

    Ich hoffe, es ist nicht Hopfen und Malz verloren ...
    Gruß Cutty

  2. #12
    Registriert seit
    10.03.2009
    Ort
    Verl
    Beiträge
    604
    Danke
    269
    Erhielt 137 Danke für 116 Beiträge

    Standard

    Ich glaube wir kommen hier nicht wirklich weiter... Hast du das Handbuch vom MoRoS da, bzw. schon mit dem Insys Support gesprochen?
    Viele Grüße

    Sven Rothenpieler


    Es gibt 3 Arten von Menschen - die, die zählen können und die, die es nicht können!


  3. #13
    Cutty ist offline Benutzer
    Themenstarter
    Registriert seit
    14.04.2011
    Beiträge
    51
    Danke
    13
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Danke für die Hilfe .

    Manchmal liegt das Nächste doch so fern und man steht auf der Leitung. Natürlich habe ich mich gleich an den Insys Support gewendet und herausgefunden, dass diese Version der Einwahlrouter die Allerallerallererste ist, die ausgeliefert wurde...sprich mit Version 1.0.1 (!)
    Also erstmal ein Firmwareupdate zuschicken lassen und noch ein paar Informationen zur Realisierung mit Siemenssteuerungen bequatscht (super freundlich der Support...dickes Lob) und jetzt kanns losgehen .
    Falls dennoch Fragen auftreten, bin ich natürlich hier wieder zur Stelle...

    Gruß Cutty

  4. #14
    Cutty ist offline Benutzer
    Themenstarter
    Registriert seit
    14.04.2011
    Beiträge
    51
    Danke
    13
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo, ich nehme das Thema nochmal auf

    So ist nun der Stand:

    ich habe einen Insys Einwahlrouter 56k mit integriertem Analogmodem. Ich habe mein Netzwerk folgendermaßen konfiguriert: mein Router liegt zusammen mit der Steuerung im Adressbereich 192.168.122.xxx. Für einen Zugriff sollte sich mein Laptop laut Support von Insys nicht im gleichen IP-Bereich befinden, also liegt dieser im Bereich 192.168.120.xxx. Ich habe außerdem eine DFÜ-Verbindung eingerichtet, mit der ich eine Verbindung über die analoge Telefonleitung zum Einwahlrouter herstelle.
    Laut meinen Netzwerkverbindungen ist die Verbindung auch erfolgreich gewesen. Nur wie komm ich jetzt auf meine Steuerung? Ich habe in der Steuerung als Gateway die IP-Adresse des Einwahlrouters angegeben. Als PC/PG-Schnittstelle wähle ich die "Ndis WanIp" aus. Ich bekomme jedoch keinen Zugriff. Was muss ich anders machen? Vielen Dank im Voraus.

    Gruß Cutty
    Zitieren Zitieren Verbindung eingerichtet  

  5. #15
    Registriert seit
    10.03.2009
    Ort
    Verl
    Beiträge
    604
    Danke
    269
    Erhielt 137 Danke für 116 Beiträge

    Standard

    Zitat Zitat von Cutty Beitrag anzeigen
    Ich habe in der Steuerung als Gateway die IP-Adresse des Einwahlrouters angegeben. Als PC/PG-Schnittstelle wähle ich die "Ndis WanIp" aus. Ich bekomme jedoch keinen Zugriff. Was muss ich anders machen? Vielen Dank im Voraus.

    Gruß Cutty
    Du hast also deiner SPS die IP-Adresse des Routers gegeben? Das darfst du nicht machen, jetzt hat ja der Router und die Steuerung die gleiche IP-Adresse. Das geht so nicht.

    Also auf den Router kommst du drauf, sprich aufs Webinterface? Du darfst die HW-Config nicht auf die SPS übertragen.

    Probier mal folgendes. In der HW-Config bzw. im gesamten Projekt, wo die IP-Adresse der SPS vorkommt, setzt du die IP-Adresse des Routers. ACHTUNG: HW-Config nicht übertragen. Im Router selbst muss eine Port Forwarding Regel eingestellt werden. Somit werden alle Daten, die beim Router auf Port 102 (Standard bei Siemens) ankommen auf die interne IP der SPS auf Port 102 (je nach Einstellung) weitergeleitet. Damit sollte es dann eigentlich gehen...

    Gruß, Sven
    Viele Grüße

    Sven Rothenpieler


    Es gibt 3 Arten von Menschen - die, die zählen können und die, die es nicht können!


  6. #16
    Cutty ist offline Benutzer
    Themenstarter
    Registriert seit
    14.04.2011
    Beiträge
    51
    Danke
    13
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Nein, meine Steuerung hat eine andere IP-Adresse als der Router. Sie liegen aber im gleichen Adressbereich. Ich habe nur bei den Etherneteinstellungen in der CPU das Häkchen bei "Router verwenden" gemacht und dort die IP-Adresse des Einwahlrouters eingegeben.

    Laut Support muss das mit dem Port Forwarding nicht gemacht werden, da ich ja eine DFÜ-Verbindung eingerichtet habe.
    Ich habe jetzt mal ipconfig in die Kommandozeile eingegeben und da befindet sich eine neue IP-Adresse von der DFÜ-Verbindung 154.0.0.0. Wo kommt die her?
    Wie meinst du das, dass ich überall die IP-Adresse des Routers statt der IP-Adresse der SPS angeben soll? Was bewirkt das?
    Danke schonmal im Voraus

    Gruß Cutty

  7. #17
    Registriert seit
    10.03.2009
    Ort
    Verl
    Beiträge
    604
    Danke
    269
    Erhielt 137 Danke für 116 Beiträge

    Standard

    Die Idee ging dahin, dass die SPS ja nicht mehr unter ihrer eigentlich IP erreichbar ist, sondern über die des Routers. Und m.W.n. geht es da nicht ohne Port Forwarding.

    Das mit der Änderung der IP im Projekt sollte dazu führen, weil eben das Projekt auf eine IP-Adresse zugreift, die überhaupt nicht angesprochen werden kann, weil eben der Router noch dazwischen hängt. Also ist die SPS nur über die IP des Routers erreichbar. Ergo, muss ich im Router irgendeine Weiterleitung aktivieren. Ob das jetzt NAT, PAT oder Port Forwarding in Kombination ist bin ich überfragt. Aber irgendeine Weiterleitung muss konfiguriert sein.

    Wo die neue IP herkommt weiß ich nicht Aber da es als Host die "0" hat, ist damit kein Teilnehmer, sondern lediglich ein Netzbereich gemeint.
    Viele Grüße

    Sven Rothenpieler


    Es gibt 3 Arten von Menschen - die, die zählen können und die, die es nicht können!


  8. #18
    Registriert seit
    14.10.2010
    Ort
    Franken
    Beiträge
    116
    Danke
    47
    Erhielt 40 Danke für 32 Beiträge

    Standard

    Hallo,

    normalerweise solltest du bei einer DFÜ-Verbindung vom Einwahlrouter eine IP-Adresse aus dem Segment des Einwahlrouters zugewiesen bekommen, also im Segment 192.168.122.xxx. Deswegen sollten ja das lokale Netz in einem anderen Segment sein. Im S7-Projekt muß die IP-Adresse der SPS eingestellt werden.

    Ich bin mir nicht sicher, ich glaube aber das kann man im Menue des Routers einstellen. Nächste Woche bekomm ich auch einen zur Inbetriebnahme, dann kann ich es genauer sagen.

    Viele Grüße
    Klaus

  9. Folgender Benutzer sagt Danke zu NikolausL für den nützlichen Beitrag:

    Cutty (21.07.2011)

  10. #19
    Cutty ist offline Benutzer
    Themenstarter
    Registriert seit
    14.04.2011
    Beiträge
    51
    Danke
    13
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo, danke für eure Antworten

    ich habe es jetzt geschafft, dass ich den Router und die Steuerung anpingen kann. Ich habe in den Eigenschaften meiner DFÜ-Verbindung in den Netzwerkeinstellungen eine IP-Adresse des Adressbereiches meines Routers gegeben. Das Problem ist jetzt aber, dass ich im Step7-Projekt nicht auf meine Steuerung zugreifen kann. Habe auch schon Siemens kontaktiert...hatten aber grade keinen Fachmann zur Verfügung, der mir helfen könnte. Wisst ihr vielleicht, welche Einstellungen ich im Simatic Manager noch vornehmen könnte? Danke schonmal
    Achja, die 154.0.0.0 kommt von dem Server, zu dem ich die DFÜ-Verbindung aufbaue .

    Gruß Cutty

  11. #20
    Registriert seit
    10.03.2009
    Ort
    Verl
    Beiträge
    604
    Danke
    269
    Erhielt 137 Danke für 116 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Cutty Beitrag anzeigen
    Wisst ihr vielleicht, welche Einstellungen ich im Simatic Manager noch vornehmen könnte?
    Wie sind denn deine bisherigen Einstellung in der PG/PC-Schnittstelle? Welche Netzwerkkarte ausgewählt? Welche IP? Statisch oder über DHCP?
    Viele Grüße

    Sven Rothenpieler


    Es gibt 3 Arten von Menschen - die, die zählen können und die, die es nicht können!


Ähnliche Themen

  1. Remotezugriff auf Beckhoff PLC
    Von MarkusP im Forum CODESYS und IEC61131
    Antworten: 6
    Letzter Beitrag: 31.07.2009, 20:46
  2. Remotezugriff auf SPS
    Von Farinin im Forum Simatic
    Antworten: 20
    Letzter Beitrag: 07.02.2008, 07:29
  3. SPS Büro / Existenz zu verkaufen
    Von SPS Franky im Forum Suche - Biete
    Antworten: 3
    Letzter Beitrag: 16.09.2007, 10:17
  4. Kaffenautomat fürs büro
    Von Markus im Forum Stammtisch
    Antworten: 10
    Letzter Beitrag: 24.04.2007, 15:37
  5. TwinCat Remotezugriff
    Von compy im Forum Sonstige Steuerungen
    Antworten: 3
    Letzter Beitrag: 12.03.2007, 10:42

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •