Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: s7-1200 und ET200S Profinet

  1. #1
    Registriert seit
    16.09.2007
    Beiträge
    19
    Danke
    0
    Erhielt 5 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Forum Nutzer,

    vorhanden :
    TIA V11 Basic , S7-1200 CPU Firmware V2 , ET200S Profinet Baugruppe IM153 mit ein paar Digital I/Os

    Wenn ich über das neue Profibus Master Modul für S7-1200 einen IM153-Profibus -Slave anspreche kommuniziert die CPU nach erfolgter HW-Konfiguration automatisch mit der IM153-Profibus. Ich brauche in meinem Anwenderprogramm nichts mehr zu machen.

    Ich dachte das funktioniert bei Profinet genauso ?
    Das scheint jedoch nicht so zu sein.Nach erfolgter HW-Konfiguration meckert die IM 153PN daß kein Datenaustausch stattfindet.
    (rote LED blinkt)

    Muß ich mit den Befehlen T-Send u.s.w. die Kommunikation in meinem Anwenderprogramm erst erstellen ?

    Weiß jemand genaueres ?
    Gibt es Beispiele oder Beschreibungen hierzu ?

    Gruß

    Xetni
    Zitieren Zitieren s7-1200 und ET200S Profinet  

  2. #2
    Registriert seit
    11.12.2009
    Beiträge
    2.113
    Danke
    388
    Erhielt 390 Danke für 271 Beiträge

    Standard

    Kann die S7-1200 eigentlich Profinet-Master sein?
    Da bin ich mir nicht so sicher.

    Grüße

    Marcel

  3. #3
    Registriert seit
    19.06.2005
    Ort
    in Bayern ganz oben
    Beiträge
    1.360
    Danke
    188
    Erhielt 372 Danke für 290 Beiträge

    Standard

    Hi,

    Zitat Zitat von Matze001 Beitrag anzeigen
    Kann die S7-1200 eigentlich Profinet-Master sein?
    Da bin ich mir nicht so sicher...
    nein, soll aber noch kommen.

    Gruss Daniel
    Erfahrung ist eine nützliche Sache. Leider macht man sie immer erst kurz nachdem man sie brauchte...

    OSCAT.lib Step 7

    Open Source Community for Automation Technolgy

    SPS-Forum Chat (Mibbit) | SPS-Forum Chat (MIRC)

  4. #4
    Registriert seit
    11.12.2009
    Beiträge
    2.113
    Danke
    388
    Erhielt 390 Danke für 271 Beiträge

    Standard

    Danke Daniel!

    Somit die Antwort: Es kann (noch) nicht klappen!

    Grüße

    Marcel

  5. #5
    Registriert seit
    19.06.2005
    Ort
    in Bayern ganz oben
    Beiträge
    1.360
    Danke
    188
    Erhielt 372 Danke für 290 Beiträge

    Standard

    Erfahrung ist eine nützliche Sache. Leider macht man sie immer erst kurz nachdem man sie brauchte...

    OSCAT.lib Step 7

    Open Source Community for Automation Technolgy

    SPS-Forum Chat (Mibbit) | SPS-Forum Chat (MIRC)

  6. #6
    Registriert seit
    24.02.2009
    Ort
    Garrel
    Beiträge
    36
    Danke
    2
    Erhielt 3 Danke für 3 Beiträge

    Standard

    Hallo,

    bei mir läuft die 1200 als PROFINET-Controller (Master) problemlos!
    Man kann die E/A direkt ansprechen!

    Michael

  7. #7
    Registriert seit
    21.08.2006
    Ort
    Schweiz
    Beiträge
    82
    Danke
    9
    Erhielt 6 Danke für 4 Beiträge

    Standard

    Hall Xetni
    Hast du am Profinet-Slave den Profinetnamen zugewissen? Sonst findet keine Kommunikation statt.

    Grüsse aus der Schweiz

  8. #8
    xetni ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    16.09.2007
    Beiträge
    19
    Danke
    0
    Erhielt 5 Danke für 2 Beiträge

    Standard

    Das war der richtige Tip !
    Vielen Dank für den Hinweis.
    Der Slave Station wird in der Hardwarekonfig. ein Namen gegeben.
    Diesen Namen muß man über "Online und Diagnose" der Unterstation gleichschalten.
    Jetzt funktioniert die PN-Device an der S7-1200 einwandfrei.

    Gruß
    Xetni

  9. #9
    Registriert seit
    15.06.2009
    Beiträge
    12
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Und dafür ist nur die Basic V11 notwendig?

    Kann man auch ein PN-Device anderer Hersteller über eine GSDML Datei einbinden?

    Gruß
    didik

  10. #10
    xetni ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    16.09.2007
    Beiträge
    19
    Danke
    0
    Erhielt 5 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Die Basic Version reicht aus. Die einzige Begrenzung dieser Version ist dass man nur CPUs ders S7-1200 Serie verwenden kann.Also keine S7-300 oder 400.
    Diese kann man nur mit der Professinal Version programmieren.

    Bei den Profinet-Devices gibt es keinerlei Beschränkung. man kann z.B. eine Festo Ventilinselstation einbinden. Oder auch eine Siemens ET200M Baugruppe mit den Karten der S7-300 Serie u.s.w.

    Gruß

    Xetni
    Zitieren Zitieren Device anderer Hersteller  

Ähnliche Themen

  1. S7 1200 als PROFINET Master
    Von didik im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 25.07.2011, 10:04
  2. GSD Datei für ET200S Profinet CPU
    Von rossirossirossi im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 04.07.2011, 12:28
  3. Antworten: 22
    Letzter Beitrag: 25.03.2008, 22:08
  4. Profinet-Kommunikation mit einer ET200S
    Von rkoe1 im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 06.03.2008, 12:55
  5. Profinet ET200s
    Von FKJ im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 19.01.2008, 17:36

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •