Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 11

Thema: Inbetriebnahme hydr Achse Technology Cpu

  1. #1
    Registriert seit
    18.05.2007
    Beiträge
    71
    Danke
    17
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich bin gerade dabei, eine hydraulische Achse an einer Technology-Cpu 317T durchzuführen und scheitere dabei kläglich.

    Hier zunächst ein paar Eckdaten:
    CPU 317 T mit IM 174 als Anschlussgruppe. Diese soll einen Gleichgangzylinder mit Längenmessstab positionieren.
    Ich bekomme die Achse einfach nicht in den Griff.
    Hatte das Programm in der Werkstatt getestet und dafür einen FU mit +-10V Eingang und Drehstrommotor genutzt, war relativ einfach.
    Also wollte ich jetzt auf der Baustelle umstellen auf hydraulische Achse und das Servoventil mit +- 10V ansteuern.
    Die Achse schwingt, ich kann machen, wass ich will.

    Wie geht ihr vor, wenn ihr Regelparameter sucht. Habt ihr Bauchgefühl oder rechnet ihr euch Werte aus.
    Wie kann ich mich den richtigen kp, ki und kd Werten näher. Und was ist mit den ganzen Filtern und Zeiten.


    Ich habe noch Zeit und kann viel spielen, nur bin ich im Moment überfordert und auch mit den Nerven runter.
    Die Achse schwingt, sobald ich ihr die Freigabe über das Sperrventil gebe. Nur wenn die Achse mech. blockiert ist, bekomme ich sie dann in die Lageregelung. Gebe ich dann einen Fahrauftrag, fährt sie schwingend in die richtige Richtung.

    Bin froh für jeden Tipp.

    Grüße
    Harri
    Zitieren Zitieren Inbetriebnahme hydr Achse Technology Cpu  

  2. #2
    Registriert seit
    17.07.2009
    Ort
    Am Rande der Ostalb
    Beiträge
    5.480
    Danke
    1.141
    Erhielt 1.240 Danke für 973 Beiträge

    Standard

    Zitat Zitat von GS-Harri Beitrag anzeigen
    Also wollte ich jetzt auf der Baustelle umstellen auf hydraulische Achse und das Servoventil mit +- 10V ansteuern.
    Die Achse schwingt, ich kann machen, wass ich will.
    Schau dir mal dein Servo-Ventil genauer an.
    "Einfache" Servo-Ventile haben eine große Überdeckung in der Mittelstellung. Das bedeutet, dass du erst eine gewisse Spannung drauf geben musst, bevor sich der Zylinder überhaupt in eine Richtung bewegt.
    Damit kommt ein "normaler" Regler nur schwer zurecht.

    Gruß
    Dieter

  3. #3
    Registriert seit
    04.02.2007
    Beiträge
    2.544
    Danke
    167
    Erhielt 731 Danke für 528 Beiträge

    Standard

    Zitat Zitat von Blockmove Beitrag anzeigen
    Schau dir mal dein Servo-Ventil genauer an.
    "Einfache" Servo-Ventile haben eine große Überdeckung in der Mittelstellung. Das bedeutet, dass du erst eine gewisse Spannung drauf geben musst, bevor sich der Zylinder überhaupt in eine Richtung bewegt.
    Damit kommt ein "normaler" Regler nur schwer zurecht.

    Gruß
    Dieter


    Ich habe mir immer von Hand den Stellgrad erhöht um die Überdeckung zu ermitteln, und diesen auf den Ausgabewert aufgeschaltet.
    Wenn das die einzigste Funktion auf der T-Cpu ist, wäre dafür eine HNC Steuerung von rexroth besser gewesen. Hydraulische Steuerung sind mit Siemens nicht das gelbe vom EI.
    „Wenn du ein Problem hast, versuche es zu lösen. Kannst du es nicht lösen, dann mache kein Problem daraus.“
    Siddhartha Gautama

  4. #4
    Registriert seit
    17.07.2009
    Ort
    Am Rande der Ostalb
    Beiträge
    5.480
    Danke
    1.141
    Erhielt 1.240 Danke für 973 Beiträge

    Standard

    Zitat Zitat von jabba Beitrag anzeigen
    Wenn das die einzigste Funktion auf der T-Cpu ist, wäre dafür eine HNC Steuerung von rexroth besser gewesen. Hydraulische Steuerung sind mit Siemens nicht das gelbe vom EI.


    Die HNC haben wir auch mehrfach im Einsatz.

    Gruß
    Dieter

  5. #5
    Registriert seit
    18.05.2007
    Beiträge
    71
    Danke
    17
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Ok, hnc wäre besser gewesen, aber dafür ist es jetzt zu spät.
    Wie schon gesagt, bin ich bei der Inbetriebnahme.

    Hat schon mal jemand eine hydraulische Achse mit Tech-CPU in Betrieb genommen?

  6. #6
    Registriert seit
    11.03.2011
    Beiträge
    384
    Danke
    32
    Erhielt 80 Danke für 69 Beiträge

    Standard

    Hallo,

    Du musst auch die Ventilkennlinie definieren, damit das richtig läuft.
    Damit wird eine Linearisierung der hydraulische Achse vorgenommen.

    Schau dir dies mal an: http://support.automation.siemens.co...ew/de/27731588
    Geändert von miami (15.08.2011 um 10:52 Uhr) Grund: Rechtschreibung

  7. #7
    Registriert seit
    21.12.2006
    Beiträge
    61
    Danke
    2
    Erhielt 18 Danke für 16 Beiträge

    Standard

    Hallo,

    wenn Dir die Grundlagen bzgl. Lageregelung oder hydraulischen Strecken fehlen wird es mit jeder Steuerung schwer, egal ob T-CPU, HNC oder Sonstige...
    Habe schon einige hydr. Achsen gemacht, unter anderem Anlagen die ehemals mit HNC und dann mit der T-CPU realisiert wurden.
    Kann Dich beruhigen, das Ergebnis mit der T-CPU war genauso gut wie mit der HNC.

    Die T-CPU ist auch für hydraulische Achsen geeignet und hat dafür speziell Mechanismen im Bauch um hydraulische Strecken z.B. Propventile mit Überlappungsbereich gut regeln zu können (z.B. Kennlinienliniarisierung!)

    Ich gehe davon aus das Du die Normierung des Lageregeler noch gar nicht gemacht hast (100% Stellgröße ist welches Vmax.), der eingestellte Kv ist deshalb wahrscheinlich viel zu hoch und die Achse schwingt sobald sie in Lageregelung geht(auch im Sillstand)

    Auf die Schnelle kannst Du schnell einfach mal den KV sehr klein machen(I und D Anteil aus) bis nichts mehr schwingt, um die Achse wenn auch nicht optimal, aber zumindest am Laufen zu haben.

    Für eine richtige Optimierung verwende aber am einfachsten den Link von "MIAMI", dieser FB ermittelt automatisch die Streckencharateristic, die Überlappung und auch die richtige Normierung wird damit automatisch hergestellt.

    Etwas Verständniss für dass was da passiert mußt Du dir naturlich trotzdem erarbeiten.

    Danach solltest Du den Lageregler optimieren.
    Den I-Anteil und D-Anteil würde ich komplett abschalten.
    Der Kv bei hydraulischen Achsen, liegt je nach Qualität der Stecke zwischen 1-8 (1/s) (stimmt nur wenn die Normierung stimmt!)

    Viel Erfolg!

    Gruß
    Watchdog

  8. Folgender Benutzer sagt Danke zu Watchdog für den nützlichen Beitrag:

    GS-Harri (21.08.2011)

  9. #8
    Registriert seit
    17.07.2006
    Beiträge
    351
    Danke
    0
    Erhielt 79 Danke für 70 Beiträge

    Standard

    Zitat Zitat von jabba Beitrag anzeigen
    Wenn das die einzigste Funktion auf der T-Cpu ist, wäre dafür eine HNC Steuerung von rexroth besser gewesen. Hydraulische Steuerung sind mit Siemens nicht das gelbe vom EI.
    Ich kenne diverse Anlagen, in der eine T-CPU mit Hydraulik verbaut ist (auch mit dynamischen Gleichläufen). Auch als Ablösung einer HNC, weil günstiger. Das A und O ist es, die Normierung der Achse richtig einzustellen. Wenn das nicht passt, bekommst Du die Achse nie vernünftig ans Laufen. Wichtig, wenn das Ventil keine lineare Kennlinie enthält, ist es, eine Ventilkennlinie anzulegen, um den zur Geschwindigkeit passenden Sollwert auszugeben ! Normierung für den Sollwert ist max. Geschwindigkeit unter Begrenzungen. Bei diesem Wert gibt die IM174 10V aus.

  10. Folgender Benutzer sagt Danke zu offliner für den nützlichen Beitrag:

    GS-Harri (21.08.2011)

  11. #9
    Registriert seit
    04.02.2007
    Beiträge
    2.544
    Danke
    167
    Erhielt 731 Danke für 528 Beiträge

    Standard

    Ich weiss das ich das auch mit einer T-CPU hinkriegen kann, aber bei einer HNC habe ich maximal die Überdeckung als Vorspannung eintragen müßen und gut wars.

    Ist zwar teurer, aber bei schnellen dynamischen Pressvorgängen habe ich gute Erfahrungen mit der HNC gemacht. Aber vorher habe ich die gleiche Maschine ohne T-CPU und HNC auch hinbekommen, was aber einiges an Arbeit war.

    Die T-CPU Kann zwar viel, man muß aber auch sehr sehr viel nachlesen, also von alleine erklären einem sich die Dinger nicht. Ich fand die HNC einfacher zum Inbetriebnehmen (obwohl komplett fremd); einfacher als das Technologyfunktionshandbuch zu den Funktionsbausteinen der Technologiefunktionen
    „Wenn du ein Problem hast, versuche es zu lösen. Kannst du es nicht lösen, dann mache kein Problem daraus.“
    Siddhartha Gautama

  12. Folgender Benutzer sagt Danke zu jabba für den nützlichen Beitrag:

    GS-Harri (21.08.2011)

  13. #10
    Registriert seit
    18.05.2007
    Beiträge
    71
    Danke
    17
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    So,

    zuerst mal Danke für die guten Tipps.
    Letzlich wars nur das Servoventil, das mir Probleme gemacht hat. Neues Servoventil rein. Achse regelt sich ein. Parameter etwas nachjustiert, sieht schon ganz gut aus.

    Habe jetzt einen Kp von 8, mit dem Ki hab ich noch meine Probleme.
    Die Achse regelt zwar sehr genau ein (ki 15), allerdings zu langsam. Ohne Ki steht die Achse schnell auf Position, allerdings fast einen Millimeter Differenz zwischen Soll und Istposition.
    Wenn dazu noch jemand ne Idee hat.........
    Zitieren Zitieren Achse läuft  

Ähnliche Themen

  1. Antworten: 6
    Letzter Beitrag: 06.04.2010, 18:06
  2. BoschRexroth Regler als SPS-Achse fahren, nicht als NC-Achse.
    Von Tuxi im Forum CODESYS und IEC61131
    Antworten: 4
    Letzter Beitrag: 23.10.2009, 14:13
  3. Probleme mit Technology V2.0 SP1
    Von Bensen83 im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 14.09.2009, 20:33
  4. Technology CPU
    Von Tommy1981 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 20.03.2009, 20:02
  5. Antworten: 15
    Letzter Beitrag: 03.08.2007, 07:32

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •