Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 3 ErsteErste 123
Ergebnis 21 bis 24 von 24

Thema: Probleme mit Betriebsartwahl

  1. #21
    Registriert seit
    17.05.2010
    Ort
    Paderborn
    Beiträge
    824
    Danke
    84
    Erhielt 125 Danke für 94 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo anne,

    so hab ich das im OB1 realisiert:

    Code:
      L     #OB1_SCAN_1
          T     "OB1 Anlaufüberwachung" // ==> MB3
    
          L     "OB1 Anlaufnummer"  // ==> MW2
          L     W#16#1                      // 1 = Warmstart
          ==I   
          S     "Programm-Neustart"
    
          L     "OB1 Anlaufnummer"
          L     W#16#2                      // 2 = Wiederanlauf
          ==I   
          S     "Programm-Neustart"
    
          L     "OB1 Anlaufnummer"
          L     W#16#4                      // 4 = Kaltstart
          ==I   
          S     "Programm-Neustart"
    
          U     "SPS <--> TP Allgemein".Anlage.Master_Reset
          S     "Programm-Neustart"
    
          U     "Programm-Neustart"
          L     S5T#5S
          SE    "Anl. Neuanlauf Timer"
    
          U     "Anl. Neuanlauf Timer"
          R     "Programm-Neustart"
    Geändert von MCerv (18.08.2011 um 22:36 Uhr) Grund: ergänzende Erklärung
    Grüße
    Michael

    1001101110110100... Das ist meine Welt

  2. #22
    anne ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    01.02.2010
    Beiträge
    345
    Danke
    0
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Lieben Dank für den Code Michael,

    was mir noch nicht ganz klar ist:


    1) Für was ist "SPS <--> TP Allgemein".Anlage.Master_Reset"?

    2) Wie verhindert der Verzögerungstimer nun, dass nicht zu früh gestartet wird?

    Sorry für die dummen Fragen - habe sowas noch nicht gemacht...
    Grüße
    anne

  3. #23
    Registriert seit
    17.05.2010
    Ort
    Paderborn
    Beiträge
    824
    Danke
    84
    Erhielt 125 Danke für 94 Beiträge

    Standard

    Hallo anne,

    zu 1)
    ich hab an anderer Stelle in Programm einen Reset-Taster, der bei "1" einen Timer (>20s) ablaufen lässt für einen Reset ala SPS-Neustart. (muss man nicht unbedingt nutzen).

    zu 2)
    den Timer bindest Du mit "UN Anl. Neuanlauf Timer" als Sperre in Deine zuvor genannten Verknüpfungen ein. Jetzt kann z. B. die Analge erst gestartet werden, wenn die Anlage vollständig hochgefahren und bereit ist.
    Grüße
    Michael

    1001101110110100... Das ist meine Welt

  4. #24
    anne ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    01.02.2010
    Beiträge
    345
    Danke
    0
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Aja ok, vielen Dank Michael für deine Erläuterungen... denke das ist jetzt soweit klar.

    Werde das mal ausprobieren...
    Grüße
    anne

Ähnliche Themen

  1. Probleme mit CPU
    Von Elmi im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 27.10.2010, 12:16
  2. CPU 315 F 2PN/DP DI Probleme
    Von Joke im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 12.05.2009, 21:10
  3. Probleme über Probleme!
    Von tom_2802 im Forum Simatic
    Antworten: 25
    Letzter Beitrag: 12.06.2008, 22:19
  4. Probleme mit FB
    Von Regeldas im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 05.10.2006, 21:19
  5. Probleme OP 27
    Von Maddin2006 im Forum HMI
    Antworten: 1
    Letzter Beitrag: 24.02.2006, 12:57

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •