Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 13

Thema: Schrittkette bei Wiederanlauf zurücksetzen

  1. #1
    Registriert seit
    17.08.2011
    Beiträge
    12
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    so servus bin neu hier
    ich habe mir schon etliche threads von euch durchgelesen und gegooglet, aber ich bin zu keiner antwort gekommen

    ich habe eine schrittkette programmiert und diese soll bei "stromausfall" zurückgesetzt werden!
    ich habe dafür den OB100 (habs auch schon mit OB101 probiert - ohne erfolg) genommen und einen merker beim anlauf auf 1 gesetzt, welcher am Ende des OB1 (also nach dem ersten zyklus) wieder zurückgesetzt wird.
    diesen merker habe ich auf den "RESET" eingang der schrittkette gehängt.

    nun zum problem:
    wenn ich die stromversorgung der SPS ausschalte, klappt alles und bei einschalten der stromversorgung wird die schrittkette wieder auf 1 gesetzt!
    doch wenn ich die radikaltour mache und die sicherung rausschmeisse, wird mir die schrittkette bei wiedereinschalten nicht wieder auf 1 zurückgesetzt!!!

    kurz noch zur schrittkette:
    ich muss die schrittkette "freigeben" über den ENABLE-eingang
    ich habe natürlich "freigeben" mit dem merker verodert, damit ich den RESET eingang bei dem anlauf einlesen kann!!

    schonmal von so einem problem gehört??

    danke im voraus

    LÖSUNG:

    ich hatte die Netzwerke in dem Schrittkettenbaustein in einer Reihenfolge, in der das Rücksetzen in den Initialschritt aus dem 2ten und 3ten Schritt nicht möglich war!
    Zuerst: 1,2,3,4,5,6

    Da Schritt 2 und 3 Rücksetzbedingungen vom Initialschritt waren, konnte ich diesen mit dem Merker nicht setzen, da Schritt 2 und 3 noch gespeichert waren und den Initialschritt sofort wieder rücksetzten!
    Lösung von "Verpolt": einfach Reihenfolge umdrehen! 6,5,4,3,2,1

    warum es zuvor einmal funktiniert hat und einmal nicht, weiss ich nicht! aber feststeht, dass es nach dieser Änderung bei mir immer funktioniert hat!

    danke nochmals
    Geändert von patti_9000 (17.08.2011 um 15:00 Uhr) Grund: formulierung, lösung hinzugefügt
    Zitieren Zitieren Schrittkette bei Wiederanlauf zurücksetzen  

  2. #2
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Zitat Zitat von patti_9000 Beitrag anzeigen
    nun zum problem:
    wenn ich die stromversorgung der SPS ausschalte, klappt alles und bei einschalten der stromversorgung wird die schrittkette wieder auf 1 gesetzt!
    doch wenn ich die radikaltour mache und die sicherung rausschmeisse, wird mir die schrittkette bei wiedereinschalten nicht zurückgesetzt!!!
    Wo ist der Unterschied der Versorgung?

    Soll jetzt die kette 1 oder 0 haben?

  3. #3
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Zitat Zitat von patti_9000 Beitrag anzeigen
    kurz noch zur schrittkette:
    ich muss die schrittkette "freigeben" über den ENABLE-eingang
    ich habe natürlich "freigeben" mit dem merker verodert, damit ich den RESET eingang bei dem anlauf einlesen kann!!

    schonmal von so einem problem gehört??
    Der enable ist nach einem Zyklus=0. Damit wird zum Beispiel eine Flankenauswertung problematisch. Reset über Flanke?

  4. #4
    patti_9000 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    17.08.2011
    Beiträge
    12
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von Verpolt Beitrag anzeigen
    Wo ist der Unterschied der Versorgung?

    Soll jetzt die kette 1 oder 0 haben?
    sorry etwas unglücklich beschrieben! die kette soll immer in den Initialschritt zurückgesetzt werden - sprich auf 1!

    unterschied der versorgung: KEINE AHNUNG!! spannungsfrei ist gleich spannungsfrei oder?? oder macht das einen unterschied, ob ich allpolig abschalte? weil die sicherung kappt nur die Phase L, welche zur stromversorgung der SPS geht

    EDIT:

    Zitat Zitat von Verpolt Beitrag anzeigen
    Der enable ist nach einem Zyklus=0. Damit wird zum Beispiel eine Flankenauswertung problematisch. Reset über Flanke?
    nein der RESET wird nicht über eine Flanke eingelesen - ganz normale IN Variable

  5. #5
    Registriert seit
    06.10.2009
    Ort
    NRW
    Beiträge
    1.572
    Danke
    63
    Erhielt 259 Danke für 219 Beiträge

    Standard

    Ich mache meine Schrittketten immer so, dass sie aus dem Schritt 0 erst mit der Betriebsart "Automatik" (Automatikmerker) in den nächsten Schritt gehen. Wenn die Schrittkette nach Wiederanlauf nicht gespeichert werden soll, mache ich die Schrittkettenmerker alle aus, wenn der Automatikmerker nicht da ist. Der Automatikmerker darf natürlich auch nicht beim Wiederanlauf an sein. Aber dafür sollte man immer sorgen...
    Meine Motivation läuft nackig mit einem Cocktail über eine Wiese.

  6. Folgender Benutzer sagt Danke zu Tigerente1974 für den nützlichen Beitrag:

    patti_9000 (17.08.2011)

  7. #6
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Zitat Zitat von patti_9000 Beitrag anzeigen
    nein der RESET wird nicht über eine Flanke eingelesen - ganz normale IN Variable
    kannst mal deinen CODE hier posten?

  8. #7
    patti_9000 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    17.08.2011
    Beiträge
    12
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von Verpolt Beitrag anzeigen
    kannst mal deinen CODE hier posten?
    welchen genau? oder das ganze projekt (ist ein kleines)

    Zitat Zitat von Tigerente1974 Beitrag anzeigen
    Ich mache meine Schrittketten immer so, dass sie aus dem Schritt 0 erst mit der Betriebsart "Automatik" (Automatikmerker) in den nächsten Schritt gehen. Wenn die Schrittkette nach Wiederanlauf nicht gespeichert werden soll, mache ich die Schrittkettenmerker alle aus, wenn der Automatikmerker nicht da ist. Der Automatikmerker darf natürlich auch nicht beim Wiederanlauf an sein. Aber dafür sollte man immer sorgen...
    das mit dem schritt 0 wäre eine idee - mal schauen

  9. #8
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    welchen genau? oder das ganze projekt (ist ein kleines)
    Vielleicht die Kette +OB1 +OB100

  10. #9
    patti_9000 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    17.08.2011
    Beiträge
    12
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    hab die schrittkette mit FB gemacht und alles in FUP -> das wären ein paar screenshots

    hier das ganze projekt

    EDIT: hab noch eine den ablaufplan von der schrittkette angehängt (das rote ist nur gerade die überlegung vom schritt 0)
    Angehängte Grafiken Angehängte Grafiken
    Angehängte Dateien Angehängte Dateien
    Geändert von patti_9000 (17.08.2011 um 10:03 Uhr)

  11. #10
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Wenn der 2. oder 3. Schritt beim Neustart gesetzt war, dann wird dein "Setzen" des Init-Schritts nicht durchgeführt, da Reset und Enable nur einen Zyklus lang aktiv sind. Wenn du die Reihenfolge der Netzwerke umdrehst (6..5..4..3..2..1), dann werden erst alle Schritte rückgesetzt, zum Schluß der Init gesetzt.

    Oder den Reset+enable länger anstehen lassen.

  12. Folgender Benutzer sagt Danke zu Verpolt für den nützlichen Beitrag:

    patti_9000 (17.08.2011)

Ähnliche Themen

  1. mm420 wiederanlauf
    Von ladychaos im Forum Antriebstechnik
    Antworten: 10
    Letzter Beitrag: 14.10.2011, 10:15
  2. Wiederanlauf nach Störung
    Von mueller-m im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 13.10.2011, 10:55
  3. Wiederanlauf der Anlage
    Von DJ78 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 19.11.2010, 12:23
  4. Wiederanlauf 315 CPU (OB 122)
    Von röhrengertl im Forum Simatic
    Antworten: 26
    Letzter Beitrag: 24.02.2009, 17:17
  5. Automatischer Wiederanlauf der CPU?
    Von kiestumpe im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 31.08.2007, 10:30

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •