Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 14 von 14

Thema: Datenbaustein aufrufen ?

  1. #11
    Registriert seit
    05.11.2004
    Ort
    Schweiz
    Beiträge
    1.137
    Danke
    224
    Erhielt 127 Danke für 85 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von fuss Beitrag anzeigen
    Ich glaube immer noch 1. ist das Problem!!!
    -> Das spielt beim Testen in der PLC Sim keine Rolle, da die HW-Konfig nicht
    übertragen wird!
    Kommt Zeit.... Kommt Rat.... In der Tat.
    Gartenlampe mit Windenergie anstelle von Solar? Bei Interesse -> PN

  2. #12
    Registriert seit
    13.08.2011
    Beiträge
    341
    Danke
    21
    Erhielt 47 Danke für 42 Beiträge

    Standard

    Zitat Zitat von Krumnix Beitrag anzeigen
    -> Das spielt beim Testen in der PLC Sim keine Rolle, da die HW-Konfig nicht
    übertragen wird!
    Habe es eben selber nochmal ausprobiert:

    - PLC Sim gestartet und fehlerfreies Programm geladen (PLC Sim = RUN)
    - dann im OB1:
    L PEW752
    T MW2
    - sofort nach dem erneuten Laden des OB1 Systemfehler auf PLC Sim (SF)
    - Auruf Baugruppenzustand --> Diagnosepuffer (Ereignis 3 von 10 Peripheriezugriffsfehler lesend):

    Diagnosepuffer der Baugruppe CPU 315-2PN/DP

    Bestell-Nr./ Bezeichn. Komponente Ausgabestand
    6ES7 841-0CC05-0YA5 Firmware V 5.4.1

    Baugruppenträger: 0
    Steckplatz: 2
    Ereignis 1 von 10: Ereignis-ID 16# 530D
    Neue Anlaufinformation im Betriebszustand STOP
    Anlaufhindernisse:
    - STOP-Anforderung liegt vor
    - Kaltstart oder Neustart (Warmstart) erforderlich
    Anlaufinformation:
    - Uhr für Zeitstempel bei letztem NETZ-EIN nicht gepuffert
    - Einprozessorbetrieb
    Aktuelle/letzte durchgeführte Anlaufart:
    - Neustart (Warmstart) durch MPI-Bedienung; letzter NETZ-EIN ungepuffert
    Zulässigkeit bestimmter Anlaufarten:
    - manueller Neustart (Warmstart) zulässig
    - automatischer Neustart (Warmstart) zulässig
    Letzte gültige Bedienung oder Einstellung der automatischen Anlaufart bei NETZ-EIN:
    - Neustart (Warmstart) durch MPI-Bedienung; letzter NETZ-EIN ungepuffert
    Betriebszustand: STOP (intern)
    kommendes Ereignis
    19:49:34.208 24.08.2011


    Ereignis 2 von 10: Ereignis-ID 16# 4563
    STOP durch Peripheriezugriffsfehler (OB nicht geladen oder nicht möglich, bzw. kein FRB vorhanden)
    Unterbrechungstelle im Anwenderprogramm: Zyklisches Programm (OB 1)
    Prioritätsklasse: 1
    OB-Nummer: 1
    Bausteinadresse: 166
    Bisheriger Betriebszustand: RUN
    Angeforderter Betriebszustand: STOP (intern)
    interner Fehler, kommendes Ereignis
    19:49:34.208 24.08.2011


    Ereignis 3 von 10: Ereignis-ID 16# 2942
    Peripherie-Zugriffsfehler, lesend
    P-Bereich , Wortzugriff, Zugriffsadresse: 752
    OB-Nummer: 1
    Bausteinadresse: 166
    Angeforderter OB: Peripheriezugriffsfehler-OB (OB 122)
    OB nicht vorhanden oder gesperrt oder nicht startbar im aktuellen Betriebszustand
    externer Fehler, kommendes Ereignis
    19:49:34.208 24.08.2011
    Gruss der Fuss!!!

    +|----,,----:
    ------R----| Widerstand ist zwecklos!!!
    -|----''----:

  3. #13
    Registriert seit
    05.11.2004
    Ort
    Schweiz
    Beiträge
    1.137
    Danke
    224
    Erhielt 127 Danke für 85 Beiträge

    Standard

    Also ich weiß nicht, was ihr macht

    Habe PLC Sim V5.4 + SP3 installiert.
    Simatic S7 V5.4 + SP5

    Sim gestartet, "Schalter" auf RUN-P gestellt.
    Schnittstellt im Manager auf PLCSim(TCP/IP) gestellt.

    OB1 erstellt, geöffnet und mit
    Code:
    L PEW752
    L 10
    >I
    = M1.0
    Beschrieben.
    Übertragen und keine Probleme.

    Ansonst habe ich nix gemacht. Keine Hardware-Konfig übertragen, keine
    Systemdaten übertragen.

    Funktioniert einwandfrei
    Kommt Zeit.... Kommt Rat.... In der Tat.
    Gartenlampe mit Windenergie anstelle von Solar? Bei Interesse -> PN

  4. #14
    Registriert seit
    13.08.2011
    Beiträge
    341
    Danke
    21
    Erhielt 47 Danke für 42 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    OK, wenn man nur den OB1 lädt dann funzt es, lädt man aber das komplette Programm aus dem Simatic Manager heraus dann werden auch die Systemdaten etc. mit übertragen und oben genannter Fehler tritt auf! Also Frage an Techniker1907 wie hast du es gemacht???
    Gruss der Fuss!!!

    +|----,,----:
    ------R----| Widerstand ist zwecklos!!!
    -|----''----:

Ähnliche Themen

  1. FB im FB Aufrufen mit SCL
    Von paula23 im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 08.02.2011, 12:33
  2. FB in einem FB aufrufen
    Von Woto im Forum Simatic
    Antworten: 27
    Letzter Beitrag: 16.07.2009, 08:33
  3. DB aufrufen
    Von Lipperlandstern im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 15.08.2008, 09:16
  4. FC Aufrufen in S5
    Von KallDall im Forum Programmierstrategien
    Antworten: 2
    Letzter Beitrag: 26.09.2007, 12:49
  5. Antworten: 4
    Letzter Beitrag: 23.08.2006, 15:02

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •