Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: 315-2 PN/DP Netzwerk? S7-Verbindung und TCP ?

  1. #1
    Registriert seit
    19.11.2008
    Ort
    Schweigen am Weintor
    Beiträge
    707
    Danke
    191
    Erhielt 161 Danke für 92 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Morgen,

    ich wollte gerade eine 315-2 PN/DP 2EH13 v2.6 auf der schon 6 S7-Verbindungen eingerichtet sind (Zu S7-200) eine Verbindung TCP zu einem LabView programm einrichten allerdings sagt mir NetPro "Kein entsprechender CP in der lokalen Station vorhanden" ?? Die Steuerung kann doch stink normal TCP Verbindung oder etwa nich? in der beschreibung steht mal ja, oder geht s7-verbindung und tcp-verbindung nicht zusammen? muss ich nun noch einen cp dazuhängen? finde dies ein bissel unerklärlich, kann mich jemand aufklären danke

    grüßel erzi
    Zitieren Zitieren 315-2 PN/DP Netzwerk? S7-Verbindung und TCP ?  

  2. #2
    Registriert seit
    25.03.2009
    Beiträge
    6
    Danke
    0
    Erhielt 2 Danke für 2 Beiträge

    Standard

    um mit dem internen CP TCP-Verbindungen nutzen zu können musst
    Du die sogenannten "T"-Bausteine benutzen (TCON, TSEND, TRECV).
    Die Bausteine incl. Hilfe findest Du in der Standardbibliothek.

  3. Folgender Benutzer sagt Danke zu SWI für den nützlichen Beitrag:

    erzteufele (24.08.2011)

  4. #3
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.263
    Danke
    537
    Erhielt 2.708 Danke für 1.957 Beiträge

    Standard

    Wie SWI schon sagte, du mußt die TCP/IP-Verbindung komplett selbst über die Siemens-Bausteine konfigurieren und aufbauen. Es gibt ein Beispiel von Siemens dazu, siehe hier: http://www.sps-forum.de/showpost.php...47&postcount=2
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  5. Folgender Benutzer sagt Danke zu Ralle für den nützlichen Beitrag:

    erzteufele (24.08.2011)

  6. #4
    erzteufele ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.11.2008
    Ort
    Schweigen am Weintor
    Beiträge
    707
    Danke
    191
    Erhielt 161 Danke für 92 Beiträge

    Standard

    aha ok, auch wieder ein bisschen schlauer danke

  7. #5
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.639
    Danke
    377
    Erhielt 803 Danke für 644 Beiträge

    Standard

    Geht die Verbindung zum Labview über Simatic Net ?
    Wenn ja, dann kannst du ebenso gut eine S7 Verbidnug einrichten. Es ist wesentlich einfacher als die "T-Bausteine".
    Jesper M. Pedersen

  8. #6
    erzteufele ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.11.2008
    Ort
    Schweigen am Weintor
    Beiträge
    707
    Danke
    191
    Erhielt 161 Danke für 92 Beiträge

    Standard

    @JesperMP kann LabView überhaupt mit Simatic Net also dann ja quasi (berichtigt mich wenn ich was falsches sage) den opc von siemens reden?

    naja ist ja auch egal die LabView programm sind nicht von mir und ich mache normal immer eine TCP verbindung übern CP 341-lean dies funkioniert immer.

    habe mir die T bausteine schon zusammen gebaut nur probiert hab ich noch nicht

  9. #7
    Registriert seit
    13.09.2010
    Beiträge
    2.292
    Danke
    178
    Erhielt 375 Danke für 355 Beiträge

    Standard

    Hi zusammen,

    @Jesper:

    erzi hat doch gar keine CP, sondern nur die PN-Schnittstelle ...

    Zitat Zitat von JesperMP Beitrag anzeigen
    Geht die Verbindung zum Labview über Simatic Net ?
    Wenn ja, dann kannst du ebenso gut eine S7 Verbidnug einrichten. Es ist wesentlich einfacher als die "T-Bausteine".
    kann denn über PN eine S7-Verbindung wie in NetPro projektiert werden

    Denke nicht, es müssen also zwingend die T-Bausteine benutzt werden !

    Gruss
    kind regards
    SoftMachine

  10. #8
    Registriert seit
    11.05.2005
    Ort
    Baden-Württemberg
    Beiträge
    673
    Danke
    113
    Erhielt 153 Danke für 124 Beiträge

    Standard

    Zitat Zitat von SoftMachine Beitrag anzeigen
    Hi zusammen,

    @Jesper:

    erzi hat doch gar keine CP, sondern nur die PN-Schnittstelle ...



    kann denn über PN eine S7-Verbindung wie in NetPro projektiert werden

    Denke nicht, es müssen also zwingend die T-Bausteine benutzt werden !

    Gruss
    Klar werden die S7 Verbindungen im Netpro projektiert.
    Wo denn sonst?
    Das geht auch mit PN CPUs...

    Micha
    "arbeite klug, nicht hart" - deutsches Sprichwort

  11. #9
    erzteufele ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.11.2008
    Ort
    Schweigen am Weintor
    Beiträge
    707
    Danke
    191
    Erhielt 161 Danke für 92 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    richtig,


    ich habe ja schon 6 S7-Verbindungen im NetPro projektiert und nun eine tcp-verbindung mit den t-bausteinen nur noch nicht getestet

Ähnliche Themen

  1. Profinet, IM151-3 im Netzwerk keine Verbindung
    Von bra_elo im Forum Feldbusse
    Antworten: 8
    Letzter Beitrag: 01.03.2011, 08:28
  2. PCU 50.3 Netzwerk
    Von RobertG im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 29.07.2009, 12:28
  3. AWL-Netzwerk in FUP-FB
    Von Schnick und Schnack im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 25.03.2009, 09:46
  4. Verbindung zur S7 über Netzwerk
    Von s.leuschke im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 25.08.2008, 23:14
  5. MP 370 Keine Verbindung über Netzwerk
    Von Computerliebe im Forum HMI
    Antworten: 0
    Letzter Beitrag: 06.09.2007, 21:43

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •