Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: Analogwertverarbeitung mit S95U

  1. #1
    Registriert seit
    13.09.2010
    Beiträge
    53
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    Ich möchte eine kleine Maschine bauen (privat) und will dazu ein Verhältnis über einen Poti regeln. Zur verfügung habe ich eine S95U (soll ohne Erweiterungen eingesetzt werden). Nur bekomme ich es nicht hin, diese Analogwerte zu verarbeiten.
    http://www.s5-treff.de/Downloads/s5_95U.pdf
    Dort findet ihr auf Seite 69 das Anschlussschema für die Analogein- bzw. Ausgänge.
    Zwischen den Kontakten 14 und 15 ist ein Drehpoti (hatte leider nur 100Ohm zur verfügung) geschaltet. Der Schleifkontakt geht auf Pin 1 (also EW 40).
    Ich will meinen Analogausgang auf 10V stellen und den Poti als Spannungsteiler an den Eingang anschließen.
    Damit das funktioniert muss doch nun eine Brücke zwischen 11 und 15 oder sehe ich das falsch?
    Das Problem ist aber, dass ich den Analogausgang nicht steuern kann.
    Ich schreibe testweise
    L KM 1111111111111111
    T AW 40
    kann jedoch bei laufendem programm keine Spannung zwischen PIN 14 und 15 messen. Was mache ich falsch?

    Vielen Dank im Vorraus!
    Zitieren Zitieren Analogwertverarbeitung mit S95U  

  2. #2
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.718
    Danke
    729
    Erhielt 1.158 Danke für 969 Beiträge

    Standard

    Lade mal einen kleineren Wert als
    KM 1111111111111111
    Du kannst Werte von 0 - 1024 ausgeben (entspricht 0 - 10 Volt)

  3. #3
    Registriert seit
    13.09.2010
    Beiträge
    53
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Das werde ich im Laufe des Tages mal austesten. Danke!

  4. #4
    Registriert seit
    23.04.2009
    Ort
    Allgäu
    Beiträge
    3.042
    Danke
    241
    Erhielt 863 Danke für 617 Beiträge

    Standard

    Zitat Zitat von nikilouder Beitrag anzeigen
    Nur bekomme ich es nicht hin, diese Analogwerte zu verarbeiten.
    Du musst den Analogeingang auch im DB1 aktivieren:
    Default steht im DB1 AI 0 (Null Analogeingänge)
    Gruß
    Paule
    ----------------------------------------------------------------------------
    > manchmal verliert man und manchmal gewinnen die anderen <

  5. #5
    Registriert seit
    13.09.2010
    Beiträge
    53
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Paule, das habe ich auch mittlerweile herausgefunden man sollte auch mal weiterlesen :P

    Nun klappt alles. Danke für die schnelle Hilfe

Ähnliche Themen

  1. Absturz S95U
    Von crislll im Forum Simatic
    Antworten: 15
    Letzter Beitrag: 19.01.2011, 10:09
  2. S95U richtig urlöschen
    Von huggy im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 03.03.2009, 15:42
  3. S95U verbinden mit welcher S7??
    Von NeuerSIMATICNutzer im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 23.01.2008, 13:16
  4. S95U-Adapter gesucht
    Von Ralle im Forum Suche - Biete
    Antworten: 2
    Letzter Beitrag: 19.12.2007, 14:58
  5. Sinec L2 - S95U
    Von Winnie im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 27.12.2004, 19:25

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •