Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: Daten aus einen Datenbaustein werden akzeptiert, obwohl DB nicht mehr vorhanden

  1. #1
    Registriert seit
    13.10.2007
    Beiträge
    12.065
    Danke
    2.794
    Erhielt 3.288 Danke für 2.168 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    ich habe folgendes Problemm, ich habe in einen Instanz eines FB ein wenig
    rumgespielt. Irgendwann ist mir aufgefallen das Daten von einen Array nicht
    mehr Referenziert wird, siehe Bild:
    Datenbaustein nicht da.JPG

    Bei den Rot eingekreisten kann der Editor folgende Variabel "002-DB".Stoermeldungen._1013
    nicht mehr finden, ich schaue in den DB und sehe das Array wo die Variabel
    drin steht ist weg, aber im FB ist dieses Array noch Deklariert.
    Naja also suche ich die Aufrufumgebung und scrolle mal eben einmal drüber
    das die Instanz neu erzeugt wird.....wird Sie aber nicht. Den Instanzgeber
    (FB) noch mal neu speichern hilft auch nicht. Also Step 7 mal einfach neu
    gestartet DB gelöscht und obwohl der DB2 nicht mehr vorhanden ist, lässt
    der Editor es zu das die Variabel "002-DB".Quit_OP_SM._1003 nicht als
    Fehler gekennzeichnet wird. Kennt jemand das Problemm?
    Step 7 ist die Version 5.5
    Angehängte Grafiken Angehängte Grafiken
    Geändert von dariyos (09.09.2015 um 11:47 Uhr)
    Zitieren Zitieren Daten aus einen Datenbaustein werden akzeptiert, obwohl DB nicht mehr vorhanden  

  2. #2
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Was passiert, wenn Bausteinkonsistenzprüfung angestossen wird?

  3. #3
    Registriert seit
    19.12.2008
    Beiträge
    336
    Danke
    19
    Erhielt 28 Danke für 28 Beiträge

    Standard

    Es würde mich mal interessieren wie du es hinbekommen hast in einem Instanz-DB Datenzeilen zu löschen. Ich kriege das bei mir nicht hin !?
    Oder hast du im Stat-Bereich des FB etwas gelöscht ?

  4. #4
    Avatar von rostiger Nagel
    rostiger Nagel ist offline Super-Moderator
    Themenstarter
    Registriert seit
    13.10.2007
    Beiträge
    12.065
    Danke
    2.794
    Erhielt 3.288 Danke für 2.168 Beiträge

    Standard

    kann ich jetzt nicht mehr nachvollziehen, da ich den Baustein komplett neu
    eingefügt habe. Aber trotzdem hätte der Editor meckern müssen wenn eine
    Globalvariabel nicht mehr vorhanden ist.

  5. #5
    Registriert seit
    04.02.2007
    Beiträge
    2.544
    Danke
    167
    Erhielt 731 Danke für 528 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    So in der Art hatte ich das auch, hatte den DB dann im Offline gelöscht und Referenzdaten neu erzeugt. Der DB war noch nicht angelegt, also hab ich den Baustein geöffnet und den Aufruf überprüft, war alles OK.
    Dann auf den iDB am Aufruf geklickt und Enter , auch nix.
    Erst als ich den DBxxx eingegeben hab (Gleicher DB aber absolut nicht symblisch eingegeben), hat er gefragt ob er den DB neu anlegen soll.

    Step7 5.5
    Symbolische Adressierung
    „Wenn du ein Problem hast, versuche es zu lösen. Kannst du es nicht lösen, dann mache kein Problem daraus.“
    Siddhartha Gautama

Ähnliche Themen

  1. Antworten: 2
    Letzter Beitrag: 26.01.2011, 16:45
  2. Antworten: 1
    Letzter Beitrag: 16.02.2010, 17:12
  3. Profibusteilnehmer nicht mehr vorhanden
    Von kpeter im Forum Feldbusse
    Antworten: 0
    Letzter Beitrag: 22.01.2010, 15:10
  4. LIN_TRAFO in den neuen Bibliotheken nicht mehr vorhanden.
    Von mike55 im Forum CODESYS und IEC61131
    Antworten: 1
    Letzter Beitrag: 21.09.2009, 07:57
  5. Antworten: 2
    Letzter Beitrag: 18.07.2005, 10:42

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •