Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 4 123 ... LetzteLetzte
Ergebnis 1 bis 10 von 33

Thema: Fehlersicherer Ausgang schaltet CPU in Stopp

  1. #1
    Registriert seit
    03.09.2007
    Ort
    Saarland
    Beiträge
    79
    Danke
    4
    Erhielt 7 Danke für 7 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen, hab da mal folgendes Problem, bei dem ich nicht mehr weiter weiß:

    Ich habe ne S7-315F-2DP mit sicheren EAs in einer Anlage drin.

    Versuche ich nun einen sicheren Ausgang zu schalten, dann schaltet die CPU direkt in Stopp mit der Meldung:

    Datenverfälschung im sicherheitsprogramm vor Ausgabe an F-Peripherie.


    Die Siemens Hilfe gibt mir da zwar Anhaltspunkte aber die hab ich mitlerweile schon alle durch.

    Ausgang wird direkt im FC mit F-FUP zugewiesen.

    Also ungefähr:

    U DB300.DBX.X
    U DB300.DBX.y
    = A32.1

    Der FC und der DB sind jeweils sichere Bausteine. Woran kann das noch liegen? Bin im Moment echt ein wenig ratlos.

    Darf ich sichere Ausgänge überhaupt so ansprechen? Hab da in der Hilfe was gelesen, dass es über die sicheren EA-DBs laufen soll ???


    Wenn ich den Sicherheitsbetrieb deaktiviere funktioniert alles ohne Probleme. Wen wunderts auch?

    Die F-Ablaufgruppe wird im OB35 aufgerufen.

    Andere Ausgänge verhalten sich genauso. Also denke ich mal es liegt an der Art der Ansteuerung selbiger.

    Wäre toll, wenn mir da jemand mal auf die Sprünge helfen könnte. Ist echt dringend.
    Zitieren Zitieren Fehlersicherer Ausgang schaltet CPU in Stopp  

  2. #2
    Registriert seit
    30.04.2005
    Beiträge
    922
    Danke
    58
    Erhielt 164 Danke für 150 Beiträge

    Standard

    Kann es sein, dass du einen Ausgang ansprichst den du gar nicht ansprechen darfst?
    Nicht alle Ausgänge der DO dürfen benutzt werden.
    Krieg ist Gottes Art den Amerikanern Geographie beizubringen

  3. #3
    Registriert seit
    21.07.2008
    Beiträge
    1.066
    Danke
    51
    Erhielt 140 Danke für 136 Beiträge

    Standard

    z.B. eine 4 DO Baugruppe die mit 32 Addressiert ist, kannste schon mit A32.1 ansprechen..

    Biste dir ganz sicher das nirgens sonst etwas auf A32.1 schreibt? z.B. über ein AW oder so?

  4. #4
    Registriert seit
    03.09.2007
    Ort
    Saarland
    Beiträge
    79
    Danke
    4
    Erhielt 7 Danke für 7 Beiträge

    Standard

    Als Karte ist eine FDO10xDC24V/2A (6ES7 326-2BF10-0AB0) verbaut.

    A-Adresse: 32-37
    E-Adresse: 32-37

    Wo liegen da jetzt die Ausgänge?

    Ab A32.0 oder irre ich da?

    Ist der A32.1 dann überhaupt richtig adressiert im Programm?

    Doppelte Zugriffe gibt es keine. Das hab ich schon kontrolliert. War auch meine erste Vermutung.


    Oder kann es vielleicht sein, dass es nicht geht, weil die Karte nicht direkt an der CPU hängt sondern über Profibus an einer IM153-2?

  5. #5
    Registriert seit
    21.07.2008
    Beiträge
    1.066
    Danke
    51
    Erhielt 140 Danke für 136 Beiträge

    Standard

    Haste mal versucht das auf den A32.0 zu legen?

    Wenn du den Ausgang nicht ansteuerst, dann läuft alles?


    -> der FC wird über den F-Call aufgerufen?

    Kannst mal versuchen alles ausm OB1 zu nehmen und nur den F-FC zu benutzen.

  6. #6
    Registriert seit
    03.04.2008
    Beiträge
    6.206
    Danke
    237
    Erhielt 818 Danke für 692 Beiträge

    Standard

    Hast du schon versucht mit einem F_Baustein aus der F-Bibliothek den Ausgang anzusprechen?
    Hast du das Programm nach dem Programmieren übersetzt?
    Hast du einen F-Baustein angelegt in dem du den Ausgang beschreibst?


    bike

  7. #7
    Registriert seit
    03.09.2007
    Ort
    Saarland
    Beiträge
    79
    Danke
    4
    Erhielt 7 Danke für 7 Beiträge

    Standard

    @Deltal: Umlegen der Ausgänge bringt nichts. Egal welchen Ausgang ich beschreibe, bei allen tritt der gleich Fehler auf.

    Der A32.1 kommt nur als erste, da er im Programm als erster Ausgang beschrieben wird. Zumindest der erste sichere Ausgang.

    Wenn der Ausgang nicht angesteuert wird, dann haut mir der nächste Ausgang die CPU in Stopp.

    Ich hab einen FC1000 (F-CALL).
    Dann gibts noch einen FC1001 (F_OB1). In diesem F_OB1 wird der Baustein aufgerufen, der mir den Ausgang schreiben soll.


    @Bike: Welchen Baustein benutze ich da? Hab nur welche für CFC gefunden.

    Ja, Programm wurde nach dem Programmieren übersetzt und neu übertragen.

    Ja, der Ausgang wird in einem F-Baustein (erstellt mit F-FUP) geschrieben.

  8. #8
    Registriert seit
    03.04.2008
    Beiträge
    6.206
    Danke
    237
    Erhielt 818 Danke für 692 Beiträge

    Standard

    Zitat Zitat von Hardy81 Beitrag anzeigen

    @Bike: Welchen Baustein benutze ich da? Hab nur welche für CFC gefunden.
    Wenn du Distributed Safety installiert6 hast, hast du doch unter Bibliothekenauch die für F-Steuerungen.
    Da würde ich zum Test eine FB nehmen, z.B FB216, den beschalten und dann schauen ob die CPU auf stopp geht.


    bike

  9. #9
    Registriert seit
    13.10.2007
    Beiträge
    12.067
    Danke
    2.797
    Erhielt 3.288 Danke für 2.168 Beiträge

    Standard

    Wenn der F_Ausgang sich nicht mit Standard Zuweisungen
    ansprechen lässt brauchst du es erst garnicht mit
    irgendwelchen Bausteinen aus der F-Biblothek versuchen,
    die helfen da auch nicht.
    Eine direkte Zuweisung muss auch so Funktionären,
    selbst mit einen nicht sicheren merker.

  10. #10
    Registriert seit
    03.04.2008
    Beiträge
    6.206
    Danke
    237
    Erhielt 818 Danke für 692 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Irgendwie muss man den Fehler einkreisen.

    Wenn es Fehler in der Konfiguration ist und ein Standardbaustein verwendet wird, wird schon beim Parametrieren aangezeigt was falsch ist.
    Spätestens beim Übersetzen wird ein genauerer Fehler angezeigt.


    bike

Ähnliche Themen

  1. CPU-Stopp
    Von thomasgull im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 30.03.2009, 10:18
  2. F-Ausgabe, Ausgang schaltet nicht an Baugruppe
    Von Krumnix im Forum Simatic
    Antworten: 29
    Letzter Beitrag: 08.10.2008, 10:08
  3. Ungwollter Runtime Stopp
    Von Golden Egg im Forum HMI
    Antworten: 3
    Letzter Beitrag: 17.09.2008, 09:15
  4. CPU Stopp nach DP Ausfall
    Von Dummy im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 15.02.2007, 17:57
  5. ENO-Ausgang oder eigener OK-Ausgang?
    Von MSP im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 02.11.2005, 19:32

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •