Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: Tia s7-1200

  1. #1
    Registriert seit
    12.05.2010
    Ort
    Dortmund
    Beiträge
    889
    Danke
    57
    Erhielt 121 Danke für 89 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    ich habe ein Problem mit dem einzelnen ansteuern eines Bits von einem UINT.
    Ich möchte Meldungen im HMI anzeigen lassen. Dazu habe ich die Variable Meldungen (UINT) angelegt und im HMI entsprechend die Variable den einzelnen Bits zugeordnet.

    Was nicht klappt, ist das zuweisen im PLC-Programm, d.h. z.B. Und nicht Not-Aus = Meldung.0
    Weiß jemand Rat..

    anbei auch mal ein Screenshot zur besseren Veranschaulichung
    Zitieren Zitieren Tia s7-1200  

  2. #2
    Avatar von rheumakay
    rheumakay ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    12.05.2010
    Ort
    Dortmund
    Beiträge
    889
    Danke
    57
    Erhielt 121 Danke für 89 Beiträge

    Standard

    habs gefunden..
    muß ein X vor das entsprechende Bit

  3. #3
    Registriert seit
    08.12.2011
    Beiträge
    18
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi,

    ich habe gesehen du hast schon mehrer Beiträge zum Thema TIA und Meldungen abgegeben.
    Ich bekomme es einfach nicht hin.

    Gibts da so ne Art Schritt für Schritt Anleitung oder ein fertiges Programmbeispiel?
    Die meisten Programme auf der Siemens Seite bekomme ich mit meiner Basic TIA Version nicht auf.
    Wäre für Hilfe dankbar.

    Gruß
    Zitieren Zitieren Meldungen TIA  

  4. #4
    Avatar von rheumakay
    rheumakay ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    12.05.2010
    Ort
    Dortmund
    Beiträge
    889
    Danke
    57
    Erhielt 121 Danke für 89 Beiträge

    Standard

    Hallo,
    schau doch mal unter
    http://support.automation.siemens.co...805384&x=0&y=0
    dort ist das Handbuch zu finden. Darin sind auch erste Schritte erläutert.
    Wo hakt es denn bei dir?
    Welche Version hast du?
    Weil Denken die schwerste Arbeit ist, die es gibt, beschäftigen sich auch nur wenige damit.

  5. #5
    Registriert seit
    08.12.2011
    Beiträge
    18
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi,
    vielen Dank für den Link. Schaue ich mir heute Abend mal in Ruhe an.
    Wenn ich heute Abend vor dem Laptop sitze, werde ich Dir mal genau meine bisherige Vorgehensweise und die
    TIA Version mitteilen.
    Vielen Dank schonmal. Grüße...

  6. #6
    Registriert seit
    08.12.2011
    Beiträge
    18
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi,

    also hier die Beschreibung meiner Vorgehensweise:
    Zuerst habe ich eine DB Meldungen angelegt und unter Static Meldungen und als Datentyp UInt eingetragen.
    Danach habe ich eine HMI Meldung angelegt und als Triggervariable die HMI Variable DB_Meldungen_Meldungen eingegeben mitTriggerbit 1.
    Die HMI Variable hat den Datentyp UInt.
    Danach habe ich eine FC Meldungen angelegt und lasse eine Ausgangszuweisung direkt vom Eingang E0.7 ansprechen.
    Der FC wurde im OB1 eingefügt
    Die Ausgangszuweisung wollte ich mit "DB_Meldungen".Meldungen.x1 beschriften.
    Hier kommt allerdings dann die Fehlermeldung der Operant "DB_Meldungen".Meldungen.x1 ist nicht definiert.
    Keine Ahnung was ich hier falsch mache.

    Die Version die ich verwende ist Step 7 Basic V10.5 inkl. SP2
    Ich könnte auch Step 7 Basic V11 SP1 zur Verfügung das könnte ich drüber laufen lassen.

    Ich hoffe Du hast eine Idee. Vielen Dank schonmal. Gruß elibastian

Ähnliche Themen

  1. Datenaustausch zwischen S7-1200 und S7-1200
    Von baschan im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 09.12.2011, 00:27
  2. S7 1200 Hub
    Von oliverlorenz im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 28.12.2010, 08:33
  3. S7 1200
    Von Rollilli im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 15.07.2010, 11:22
  4. S7 1200
    Von Joey im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 14.05.2010, 13:44
  5. S7-1200 ISO on TCP
    Von mst im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 28.01.2010, 09:26

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •