Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 15

Thema: S7 1200 + KTP400 TIA V11: Warnmeldung bei Bitmeldung

  1. #1
    Registriert seit
    30.01.2006
    Beiträge
    115
    Danke
    2
    Erhielt 10 Danke für 5 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Leute

    Habe mein Projekt von Tia 10.5 auf 11 migriert.
    Nun erhalte ich immer folgende Warnmeldung:
    Die Adresse im Datenbaustein wird nicht durch eine Variable belegt.

    Im DB wurde ein Word für die Kommunikation zwischen PLC und KTP angelegt.

    Wie kann ich die Warnmeldung loswerden?
    Zitieren Zitieren S7 1200 + KTP400 TIA V11: Warnmeldung bei Bitmeldung  

  2. #2
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Hallo,

    Hab kein 'TIA. Aber sowas wie "Projekt reorganisieren" müßte es doch noch geben?

    Und Bausteinkonsistenzprüfung....

  3. #3
    Nethacks ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    30.01.2006
    Beiträge
    115
    Danke
    2
    Erhielt 10 Danke für 5 Beiträge

    Standard

    Nein gibt es beim TIA nicht mehr.

  4. #4
    Registriert seit
    25.06.2007
    Ort
    Dresden
    Beiträge
    3.930
    Danke
    465
    Erhielt 878 Danke für 634 Beiträge

    Standard

    Zitat Zitat von Nethacks Beitrag anzeigen
    Nein gibt es beim TIA nicht mehr.
    ..oder noch nicht wieder

    Frank
    Grüße Frank

  5. #5
    Registriert seit
    12.05.2010
    Ort
    Dortmund
    Beiträge
    889
    Danke
    57
    Erhielt 121 Danke für 89 Beiträge

    Standard

    schicke doch mal einen screenshot vom db sowie der fehlermeldung

  6. #6
    Nethacks ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    30.01.2006
    Beiträge
    115
    Danke
    2
    Erhielt 10 Danke für 5 Beiträge

    Standard

    Anbei die Fehlermeldung und der DB.

    Zugegriffen wird darauf zb über DB5.dbx0.1
    Angehängte Grafiken Angehängte Grafiken

  7. #7
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Kann es sein, daß die ganzen Störungspointer hinter dem "Static" im DB eingetragen sein müssen?

    S7 beginnt immer mit Struct. TIA bestimmt bei Static

    Also den Pfeil in der obersten Zeile öffnen und dort die Pointer reinkopieren

    PS: Oder ist das schon offen?

  8. #8
    Nethacks ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    30.01.2006
    Beiträge
    115
    Danke
    2
    Erhielt 10 Danke für 5 Beiträge

    Standard

    Ähhm. Wenn ich darauf klicke, schliest sich die static Deklaration, und es können danach keine anderen Deklarationen angelegt werden.
    Angehängte Grafiken Angehängte Grafiken
    Geändert von Nethacks (19.10.2011 um 15:24 Uhr)

  9. #9
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Wie gesagt, das war mal das Prob in einem anderen Fred.

    Ist schon offen - ok.

    Was hindert dich daran, den DB neu anzulegen.

    Ist das ein Migrationsproblem, dann müsste die Warnung danach weg sein.

  10. #10
    Registriert seit
    28.05.2008
    Beiträge
    103
    Danke
    9
    Erhielt 18 Danke für 17 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich würde mal die Word-Variable(n) löschen, Übersetzen (ergibt dann Warnungen), Speichern, Projekt schliessen, Projekt neu öffnen, Variable(n) bei den Meldungen neu reinziehen.
    ev. hilft's.
    Habe auf diese Weise schon etliche Migrationsprobleme gelöst.
    ==>zuerst Projekt sichern !
    Gruss aus CH

Ähnliche Themen

  1. Antworten: 4
    Letzter Beitrag: 03.11.2011, 14:59
  2. Antworten: 6
    Letzter Beitrag: 23.05.2011, 20:30
  3. S7 1200 + ktp400
    Von Joseppe im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 21.11.2010, 15:28
  4. Bitmeldungen s7-1200/KTP400
    Von McMeta im Forum HMI
    Antworten: 0
    Letzter Beitrag: 18.11.2010, 15:25
  5. Antworten: 10
    Letzter Beitrag: 05.07.2007, 20:26

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •