Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 28

Thema: Siemens S5 mit PG740 - Anlaufprobleme

  1. #1
    Registriert seit
    07.08.2009
    Beiträge
    109
    Danke
    86
    Erhielt 0 Danke für 0 Beiträge

    Idee


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich bin gerade dabei eine S5 zum laufen zu bekommen. Es steckt bisher nur Netzteil und CPU945.

    Nach dem Urgelöschen kann ich problemlos in den RUN gehen. Jetzt habe ich ein fertiges, lauffähiges S5 programm bekommen. Soweit haben mit Handbücher und Dokus geholfen das Programm zu laden und in die S5 zu übertragen. Das Programm ist ein ganz einfaches, was nur Daten über einen CP an eine S7 schicken soll.

    CP steckt aber noch nicht.

    Wenn ich das Programm lade und in den RUN will, leuchtet die RUN LED kurz auf und erlischt wieder. Wenn ich dasselbe mit dem CP versuche leuchtet die RUN LED ca 5 Sekunden lang und geht wieder aus. Die STOP LED leuchtet die ganze Zeit.

    Das Handbuch sagt dass ein Fehler beim Anlaufen in den Systemdatenwörtern BS 3 und BS 4 zu finden sind und ich diese über die Online Funktion "Auskunft ADRESSE" auslesen soll.

    Einige Online Funktionen wie USTACK, BSTACK habe ich gefunden, aber ich find nirgends das "Auskunft ADRESSE" Menü.

    Weiß da jemand Rat wie ich das BS 3 und BS 4 auslesen kann? Oder vielleicht kennt jemand ein üblichen Fehler wieso mein Programm nicht läuft. Ich selbst schlag mich mit der S5 und dem Windows 3.11 erst seit letzter Woche rum :P

    Danke schonmal
    Zitieren Zitieren Siemens S5 mit PG740 - Anlaufprobleme  

  2. #2
    Registriert seit
    08.04.2008
    Ort
    Köln
    Beiträge
    844
    Danke
    39
    Erhielt 244 Danke für 199 Beiträge

    Standard

    Hallo win98!

    Hast Du den CP parametriert?
    In den Anlauf-OBs wird normalerweise der CP synchronisiert. Schau doch mal nach,
    ob die bei der Synchronisation angegebene SSNR mit der im CP übereinstimmt.

    Grüße
    Gebs

  3. Folgender Benutzer sagt Danke zu Gebs für den nützlichen Beitrag:

    win98 (04.11.2011)

  4. #3
    win98 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.08.2009
    Beiträge
    109
    Danke
    86
    Erhielt 0 Danke für 0 Beiträge

    Standard

    was ist denn SSNR? Wo im Programm sollte die stehen?

    ich kenn mich bisher nur mit S7 aus. Sowas wie ne HW konfig hab ich in step 5 noch nich gefunden.

    Ich hab den CP erstmal nicht angesteckt, weil ich nich wusste wie ich den parametrieren soll. Müsste das Programm nicht auch ohne CP in den Run gehen?

    Und noch ne kleine Frage, ich hab kein Speichermodul drin, brauch ich zwingend eins?

    edit: bei der CP leuchten auch die beiden roten LEDs IF1 und 2. Kann sein dass das Programm mit einem anderen CP erstellt wurde. werd mal ein paar bausteine durchforsten ob ich da ne SSNR finde, bin grad hier drauf gestoßen: http://support.automation.siemens.com/WW/llisapi.dll?func=cslib.csinfo&objId=28770729&load=treecontent⟨=de&siteid=cseus&a ktprim=0&objaction=csview&extranet=standard&viewreg=WW
    Geändert von win98 (28.10.2011 um 10:08 Uhr) Grund: edit:

  5. #4
    Registriert seit
    08.04.2008
    Ort
    Köln
    Beiträge
    844
    Danke
    39
    Erhielt 244 Danke für 199 Beiträge

    Standard

    was ist denn SSNR?
    Das ist sowas wie die LADDR in der S7

    Sowas wie ne HW konfig hab ich noch nich gefunden.
    Gibt es in der S5 auch nicht (Abgesehen vom Profibus). Die S5 erkennt selbst, welche HW vorhanden ist.

    Ich hab den CP erstmal nicht angesteckt, weil ich nich wusste wie ich den parametrieren soll. Müsste das Programm nicht auch ohne CP in den Run gehen?
    Wenn der CP in den Anlauf-OBs (20,21,22) aufgerufen wird und nicht vorhanden ist,
    geht die CPU in STOP. (Ausser Du hast die entsprechenden Fehler-OBs eingespielt.

    Und noch ne kleine Frage, ich hab kein Speichermodul drin, brauch ich zwingend eins?
    Bin mir nicht ganz sicher! (Ist schon solange her) Aber ich glaube die 945 kommt ohne aus.

    Grüße
    Gebs

  6. Folgender Benutzer sagt Danke zu Gebs für den nützlichen Beitrag:

    win98 (04.11.2011)

  7. #5
    win98 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.08.2009
    Beiträge
    109
    Danke
    86
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ah, hab im OB21 die stelle gefunden. Da stehn 2 SSNR. so wie hier auf dem Bild: http://cache.automation.siemens.com/...P5431_02_d.gif

    nur ich hab dort FB 249
    erste SSNR: 0,0
    zweite SSNR: 0,8

    Im OB22 steht dasselbe, glaub das ist einmal für manuellen und einmal für automatischen Neustart

    hat das was mit diesen DIP Schaltern in der CP zu tun? Die oberen stehen alle auf 1, die unteren stehen alle auf 0.

    In der Speicherinfo der CPU seh ich beim Urlöschen dass der Speicher leer ist und nach dem Laden ist der Speicher halbvoll. Also wird sie wohl doch ohne auskommen. Hat mich nur gewundert weil das im Handbuch steht als Ausgangszustand um ein Programm zu starten.

    Vielen Dank

  8. #6
    Registriert seit
    08.04.2008
    Ort
    Köln
    Beiträge
    844
    Danke
    39
    Erhielt 244 Danke für 199 Beiträge

    Standard

    nur ich hab dort FB 249
    Die Hantierungsbausteine haben bei den unterschiedlichen CPUs verschiedene Nummern. FB 249 passt schon
    erste SSNR: 0,0
    zweite SSNR: 0,8
    Dann hast Du 2 CPs in dem Programm!

    Im OB22 steht dasselbe, glaub das ist einmal für manuellen und einmal für automatischen Neustart
    richtig

    hat das was mit diesen DIP Schaltern in der CP zu tun? Die oberen stehen alle auf 1, die unteren stehen alle auf 0.
    Welchen CP hast Du denn? Die genaue Bestell-Nummer.

    Grüße
    Gebs

  9. Folgender Benutzer sagt Danke zu Gebs für den nützlichen Beitrag:

    win98 (04.11.2011)

  10. #7
    win98 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.08.2009
    Beiträge
    109
    Danke
    86
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Habe den CP: 6ES5524-3UA15
    http://support.automation.siemens.com/WW/llisapi.dll?func=cslib.csinfo&objid=4043988&prodLstObjId=4043988&nodeid0=1080513 9⟨=en&siteid=cseus&aktprim=0&objaction=csopen&extranet=standard&viewreg=WW

    Der hat oben und unten einen Slot. Oben ist frei und unten steckt eine TTY Schnittstelle. Das erklärt glaub ich auch die beiden SSNR.

  11. #8
    Registriert seit
    08.04.2008
    Ort
    Köln
    Beiträge
    844
    Danke
    39
    Erhielt 244 Danke für 199 Beiträge

    Standard

    Zitat Zitat von win98 Beitrag anzeigen
    Habe den CP: 6ES5524-3UA15
    http://support.automation.siemens.com/WW/llisapi.dll?func=cslib.csinfo&objid=4043988&prodLstObjId=4043988&nodeid0=1080513 9⟨=en&siteid=cseus&aktprim=0&objaction=csopen&extranet=standard&viewreg=WW

    Der hat oben und unten einen Slot. Oben ist frei und unten steckt eine TTY Schnittstelle. Das erklärt glaub ich auch die beiden SSNR.
    Nein, denn der CP 524 hat nur eine Schnittstelle!
    Der obere Schacht ist für das Speichermodul, der untere ist die Geräteschnittstelle.

    Hier findest Du das Handbuch zum CP:
    http://support.automation.siemens.co...ew/de/15352689

    Da sind auch die DIP-Schalter etc. beschrieben.

    Grüße
    Gebs

  12. Folgender Benutzer sagt Danke zu Gebs für den nützlichen Beitrag:

    win98 (04.11.2011)

  13. #9
    Registriert seit
    15.04.2011
    Beiträge
    1.122
    Danke
    229
    Erhielt 208 Danke für 176 Beiträge

    Standard

    Muß der CP524 nicht parametriert werden, und zwar mit dem COM- Zusatzpaket COM524 und anschließend die Parametrierdatei mit der Endung 524 (Beispiel: Test.524) auf ein Eprom gebrannt werden?.
    Ist wirklich schon lange her ....
    Gruß
    190B

  14. Folgender Benutzer sagt Danke zu 190B für den nützlichen Beitrag:

    win98 (04.11.2011)

  15. #10
    win98 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.08.2009
    Beiträge
    109
    Danke
    86
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von 190B Beitrag anzeigen
    Muß der CP524 nicht parametriert werden, und zwar mit dem COM- Zusatzpaket COM524 und anschließend die Parametrierdatei mit der Endung 524 (Beispiel: Test.524) auf ein Eprom gebrannt werden?.
    Ist wirklich schon lange her ....
    ja das hab ich auch im Handbuch gelesen:
    Sie müssen mit Hilfe des Softwarepaketes COM 525 einen Auftragsblock
    parametrieren, wenn ihr CP 525 in Eigednitiative Daten
    - zu einem Partner senden, - von einem Partner holen soll.
    Dieser CP verhält sich -V. Ein CP wird als passiv bezeichnet,
    wenn er keine Eigeninitiative entwickelt. Daten können nur zu ilmi
    gesendet oder von ihm geholt werden. Für einen CP, der sich nur
    passiv verhält, sind im CP-525-Anwenderprogram nur Interpreter
    und Prozedur (kein Auftragsblock! ) erforderlich.
    Ich hab kein EPROM
    Aber ich versteh den Abschnitt so, dass wenn mein CP passiv ist ich kein EPROM brauche. Ich denk mal die CP der S7 wird aktiv sein.

    Im Handbuch hab ich gelesen dass das SSNR die Schnittstellennummer ist. Der CP ist bei mir gleich nach der CPU auf der Schnittstelle 0.

    Ich hab jetzt die zweite SSNR gelöscht und die erste mit 0 geladen. Leider immernoch dasselbe Problem

    edit:
    ich bin jetzt auf diesen SINEC NCM gestoßen, da kann ich einige CP einstellungen vornehmen.
    Unter "Editieren" steht "Art des CP" auf CP143.

    Da wollt ich jetzt CP524 hinschreiben aber ich kanns nicht übernehmen. Fehler: "Unzulässiger Dateiname : D : P". Das steht bei Datenbasis-Datei. Weiß damit leider nix anzufangen
    Geändert von win98 (28.10.2011 um 13:42 Uhr) Grund: edit:

Ähnliche Themen

  1. Siemens S5 mit PG740 - Anlaufprobleme
    Von win98 im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 28.10.2011, 09:12
  2. Tastatur PG740
    Von Uwe16 im Forum Simatic
    Antworten: 15
    Letzter Beitrag: 17.06.2010, 12:57
  3. Frage zum PG740
    Von AI-Networks im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 12.06.2006, 11:15
  4. Aufrüstung PG740
    Von ZwieBack im Forum PC- und Netzwerktechnik
    Antworten: 0
    Letzter Beitrag: 19.05.2006, 11:39
  5. Verbindungskabel 810-> PG740
    Von Anonymous im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 21.06.2005, 11:52

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •