Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 2 von 2

Thema: Probleme mit S7-Basiskommunikation

  1. #1
    Registriert seit
    13.02.2006
    Beiträge
    130
    Danke
    14
    Erhielt 9 Danke für 7 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich habe einen Testaufbau gemacht mit einer Kommunikation SFC65/66 X_SEND,RCV, zwischen zwei CPU'S über MPI verbunden. Funktioniert problemlos. Nun habe ich die Kommunikation über Teleservice auf die Anlage gespielt, doch sie funktioniert nicht.
    - SPSen sind baugleich, jeweils CPU314-1AF11
    - Software ist gleich wie beim Testaufbau, keine zusätzlichen Verbindungen
    - doch 1 CPU zeigt bei den genutzten Verbindungsressourcen 10 an, obwohl ich ja nur 1 (in beide Richtungen) zur Fremdstation habe...
    Ein Versuch die HW neu zu laden, mit einer neuen CPU (1AG13) die Systemdaten zu ändern bringt nichts, auch die Reduzierung der reservierten Verbindungen auf 1 und die Erhöhung der anderen (OP) auf 10 bringt nichts, es werden immer die 10 genutzten Verbindungen angezeigt.

    Was kann ich online tun? Ein Urlöschen ist nicht möglich, komm dan über VPN nimmer sicher drauf und das ist mir zu riskant...
    Stop/Start nützt auch nichts? Kann ich online die Verbindungen reseten (SFC69 hab' ich auch schon erfolglos probiert...

    Bitte um Hilfe!
    Zitieren Zitieren Probleme mit S7-Basiskommunikation  

  2. #2
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.326
    Danke
    932
    Erhielt 3.332 Danke für 2.690 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich hätte da nur eine Idee: kann vielleicht jemand vor Ort BEIDE CPU mal gleichzeitig ausschalten und wieder einschalten?
    Oder kannst Du BEIDE CPU gleichzeitig in Stop versetzen?

    Bei den X_Bausteinen kann es vorkommen, daß bei Änderungen an den Bausteinen, welche die X_Bausteine aufrufen, Verbindungsressourcen in der CPU "unbeendbar" belegt bleiben. Solche Bausteine sollen eigentlich nur im Stop der CPU geladen werden.

    Zitat aus dem Referenzhandbuch "System- und Standardfunktionen für S7-300/40":
    Durchführung von Programmänderungen
    Alle Teile Ihres Programms, die auf Aufrufe von SFCs der S7-Basiskommunikation unmittelbar
    Auswirkungen haben, dürfen Sie nur im Betriebszustand STOP verändern. Dazu gehört insbesondere
    das Löschen von FCs, FBs oder OBs, die Aufrufe von der S7-Basiskommunikation enthalten.
    Anschließend müssen Sie einen Neustart (Warmstart) oder Kaltstart durchführen.
    Falls Sie dies nicht beachten, können Verbindungsressourcen belegt bleiben, und das
    Automatisierungssystem befindet sich anschließend in einem nicht definierten Zustand.
    SFC69 "X_ABORT" könnte vielleicht helfen, sollte dann aber auf beiden CPU aufgerufen werden.
    Welche Firmware-Version haben Deine CPU?

    Statt X_SEND/X_RECV würde ich X_PUT (eventuell auch X_GET) benutzen und eine eigene Verbindungsüberwachung mit Lifebit programmieren.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

Ähnliche Themen

  1. Probleme AWL
    Von Geminon im Forum CODESYS und IEC61131
    Antworten: 9
    Letzter Beitrag: 14.07.2010, 09:53
  2. Probleme über Probleme!
    Von tom_2802 im Forum Simatic
    Antworten: 25
    Letzter Beitrag: 12.06.2008, 22:19
  3. Probleme mit CPU 315 2DP
    Von weißnix im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 13.09.2007, 12:51
  4. CPU 314-Probleme
    Von the bang 2 im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 30.01.2007, 15:59
  5. dp probleme
    Von Hitschkock im Forum Feldbusse
    Antworten: 6
    Letzter Beitrag: 31.07.2005, 13:14

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •