Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 4 ErsteErste 1234 LetzteLetzte
Ergebnis 11 bis 20 von 38

Thema: Sps fc106

  1. #11
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.726
    Danke
    314
    Erhielt 1.519 Danke für 1.282 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Leinad Beitrag anzeigen
    mal kurz ne andere frage, muss ich den FC106 direkt in den OB verschieben oder in einen anderen FC??
    Das bleibt dir im Sinne deiner Programmstrucktur überlassen, technisch ist es vollkommen egal.
    Sinnvoll wäre nur das das ganze im OB1-Zyklus, oder u.U. auch OB35 Zyklus stattfindet.

    Gezielt könnte man dir helfen durch den vollständigen Diagnose-Puffer.

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  2. Folgender Benutzer sagt Danke zu MSB für den nützlichen Beitrag:

    Leinad (07.11.2011)

  3. #12
    Registriert seit
    13.10.2007
    Beiträge
    12.030
    Danke
    2.784
    Erhielt 3.268 Danke für 2.156 Beiträge

    Standard

    Zitat Zitat von Leinad Beitrag anzeigen
    ja genau den mein ich =)

    inzwischen glaub ich das es gar nicht am FC106 liegt...

    mal kurz ne andere frage, muss ich den FC106 direkt in den OB verschieben oder in einen anderen FC??
    Du must ihn zur Steuerung übertragen, ich wiederhole meine Frage:
    "Befindet sich der FC106 in der Steuerung?"

  4. Folgender Benutzer sagt Danke zu rostiger Nagel für den nützlichen Beitrag:

    Leinad (07.11.2011)

  5. #13
    Leinad ist offline Benutzer
    Themenstarter
    Registriert seit
    07.11.2011
    Beiträge
    38
    Danke
    5
    Erhielt 0 Danke für 0 Beiträge

    Standard

    also ich probiere jetzt noch eimal alles genauer zu beschreiben...
    ich habe einen DB in den ich eine int zahl schreibe von einem Panel... diese zahl will ich nachher weiterleiten an eine Segment anzeige, mit einem 4-20 mA signal..
    ich habe jetzt den FC106 genommen und diesen direkt in den ob verschoben...sobald ich es aber lade ..kommt das problem wie schon beschrieben....

    Lies dir mal die Meldung vor dieser Meldung durch. Da sollte etwas mehr drinstehen.....
    die Meldung vorher:

    Bereichslängenfehler beim Lesen
    Global DB, Doppelwortzugriff, Zugriffsadresse: 0
    OB-Nummer: 1
    Bausteinadresse: 16
    Angeforderter OB: Programmierfehler-OB (OB121)

    vil. kann mir so jemand sagen was ich falsch mache...=/

  6. #14
    Leinad ist offline Benutzer
    Themenstarter
    Registriert seit
    07.11.2011
    Beiträge
    38
    Danke
    5
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Du must ihn zur Steuerung übertragen, ich wiederhole meine Frage:
    "Befindet sich der FC106 in der Steuerung?"
    ja, der Baustein befindet sich in der SPS, falls du das meinst...

  7. #15
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.218
    Danke
    533
    Erhielt 2.696 Danke für 1.948 Beiträge

    Standard

    @Tigerente1974
    Zu deiner Signatur, verweise ich mal auf die Dame in meiner Bildergalerie, meinst du die?

    @
    zu den Antworten des TE fällt mir wieder mal folgendes ein:

    Hallo, mein Computer funktioniert nicht! - Haben Sie Ihren Monitor eingeschaltet? - Ja, klar! - Schalten Sie Ihn doch mal aus! - Jetzt geht er!


    @TE

    Nochmal, zeig doch mal den Code!
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  8. Folgender Benutzer sagt Danke zu Ralle für den nützlichen Beitrag:

    Leinad (07.11.2011)

  9. #16
    Registriert seit
    15.04.2011
    Beiträge
    1.122
    Danke
    229
    Erhielt 208 Danke für 176 Beiträge

    Standard

    Zitat Zitat von Leinad Beitrag anzeigen
    also ich probiere jetzt noch eimal alles genauer zu beschreiben...
    ich habe einen DB in den ich eine int zahl schreibe von einem Panel... diese zahl will ich nachher weiterleiten an eine Segment anzeige, mit einem 4-20 mA signal..
    ich habe jetzt den FC106 genommen und diesen direkt in den ob verschoben...sobald ich es aber lade ..kommt das problem wie schon beschrieben....



    die Meldung vorher:

    Bereichslängenfehler beim Lesen
    Global DB, Doppelwortzugriff, Zugriffsadresse: 0
    OB-Nummer: 1
    Bausteinadresse: 16
    Angeforderter OB: Programmierfehler-OB (OB121)

    vil. kann mir so jemand sagen was ich falsch mache...=/
    Mit Deinem DB stimmt was nicht. Entweder ist er zu klein oder Dein Datenwort hat das verkehrte Format.

    Edit: Ich schließe mich dem Kollegen Ralle an: Poste doch mal Dein Programm...
    Geändert von 190B (07.11.2011 um 15:56 Uhr)
    Gruß
    190B

  10. Folgende 2 Benutzer sagen Danke zu 190B für den nützlichen Beitrag:

    Günni1977 (07.11.2011),Leinad (07.11.2011)

  11. #17
    Leinad ist offline Benutzer
    Themenstarter
    Registriert seit
    07.11.2011
    Beiträge
    38
    Danke
    5
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke für die Beiträge, das problem ist zwar immernoch nicht gelöst aber ich probier weiter

  12. #18
    Registriert seit
    31.03.2010
    Beiträge
    335
    Danke
    3
    Erhielt 33 Danke für 32 Beiträge

    Standard

    Zitat Zitat von Leinad Beitrag anzeigen
    Danke für die Beiträge, das problem ist zwar immernoch nicht gelöst aber ich probier weiter
    Hallo!
    Der FC 106 Arbeitet doch mit einer Real Zahl!
    Wandelst du das INT ind Real Format um in deinem OB?

    Code:
          CALL  "UNSCALE"
           IN     := //Was hast du hier angegeben????
           HI_LIM :=
           LO_LIM :=
           BIPOLAR:=
           RET_VAL:=
           OUT    := //Was hast du hier angegeben???

    Mfg
    Geändert von SCM (07.11.2011 um 16:39 Uhr)
    Wer aufhört, besser zu werden, hat aufgehört, gut zu sein!

  13. #19
    Registriert seit
    15.04.2011
    Beiträge
    1.122
    Danke
    229
    Erhielt 208 Danke für 176 Beiträge

    Standard

    Hallo Leinad,

    warum postet Du denn Dein Programm nicht? So geheim kann es ja wohl nicht sein.
    Es würde einiges an Rätselraten erübrigen und Dir wesentlich schneller geholfen werden.
    Du bist jetzt mehrfach dazu aufgefordert worden. Wenn Du Hilfe willst, solltest Du auch kooperativ sein.
    Sonst erhälts Du vielleicht keine Antworten mehr...
    Gruß
    190B

  14. #20
    Registriert seit
    22.09.2006
    Ort
    Bodenseeraum
    Beiträge
    1.022
    Danke
    61
    Erhielt 136 Danke für 122 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi Leinad,

    lösche in deiner CPU den OB121, dann geht die CPU in STOP bei Fehlern, und dann kannst du an der Stelle springen, wo der Fehler war.
    (CPU Diagnose)

    Gruss: V.
    ______________________________________
    relax, take it easy

Ähnliche Themen

  1. Analogwert ausgeben mit Fc106
    Von adi5 im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 08.11.2009, 17:59
  2. FC106 unscale problem
    Von Bitte_ein_Bit im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 01.12.2008, 00:28
  3. Antworten: 8
    Letzter Beitrag: 02.04.2007, 10:32
  4. FC106 und kleine Zähler Frage
    Von ElektronikJack im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 16.11.2006, 21:51

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •