Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 4 von 5 ErsteErste ... 2345 LetzteLetzte
Ergebnis 31 bis 40 von 43

Thema: Datenübergabe bei CPU als DP-Slave

  1. #31
    Registriert seit
    16.03.2006
    Ort
    Franken
    Beiträge
    3.843
    Danke
    30
    Erhielt 942 Danke für 819 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    in der Konfiguration erstmal nicht nein.
    Muss mir aber noch die Diagpuffer genauer anschauen.

  2. #32
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.316
    Danke
    932
    Erhielt 3.331 Danke für 2.689 Beiträge

    Standard

    Hast Du die HW Konfig in beide CPU geladen?
    Wenn Du Deinen Programmieradapter auf den Profibus aufsteckst, kannst Du dann beide CPU als erreichbare Teilnehmer sehen?
    "Ging" der Profibus schonmal oder ist das eine Erstinbetriebnahme? Kabel, Stecker, Abschlußwiderstände ist alles gecheckt?

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  3. #33
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.639
    Danke
    377
    Erhielt 803 Danke für 644 Beiträge

    Standard

    Zitat Zitat von ChristophD Beitrag anzeigen
    Ähm ich weiß nich wo ihr das gesehen habt.
    Bei mir ist da genau ein Slot konfiguriert
    Ausgang auf IM151-8 Seite (Adresse 2) zu Eingang auf IM151-7 Seite (Adresse 2041)
    Beim erneuten Blick darauf, da hast du recht.
    (es hat mir verwirrt, der Dialog ist etwas unterschiedlich zu I-Device Konfiguration).
    Jesper M. Pedersen

  4. #34
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.639
    Danke
    377
    Erhielt 803 Danke für 644 Beiträge

    Standard

    Zitat Zitat von PN/DP Beitrag anzeigen
    Wenn Du Deinen Programmieradapter auf den Profibus aufsteckst, kannst Du dann beide CPU als erreichbare Teilnehmer sehen?
    Muss dann auf der DP Slave "Test, Commisioning, Routing" gewählt werden ?
    Ich bin nicht der grosse Eksperte für CPUs als DP Slaves.
    Jesper M. Pedersen

  5. #35
    Registriert seit
    05.10.2012
    Ort
    Rahden
    Beiträge
    35
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von ChristophD Beitrag anzeigen
    in der Konfiguration erstmal nicht nein.
    Muss mir aber noch die Diagpuffer genauer anschauen.
    OK. Danke dir schon mal.



    Hast Du die HW Konfig in beide CPU geladen?
    Wenn Du Deinen Programmieradapter auf den Profibus aufsteckst, kannst Du dann beide CPU als erreichbare Teilnehmer sehen?
    "Ging" der Profibus schonmal oder ist das eine Erstinbetriebnahme? Kabel, Stecker, Abschlußwiderstände ist alles gecheckt?

    Harald
    Das ist ein neues Projekt, ich hab den Adapter auf das Profibuskabel der die beiden CPU´s verbindet gesteckt und es sind beide erreichbar, die BF-LED ist auch aus es leuchtet nur die SF-LED und es gehen beide CPU´s auf Stop.


    Muss dann auf der DP Slave "Test, Commisioning, Routing" gewählt werden ?
    Ich bin nicht der grosse Eksperte für CPUs als DP Slaves.
    Ich kann es mal versuchen
    Geändert von StefanW. (27.11.2014 um 16:58 Uhr)

  6. #36
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.316
    Danke
    932
    Erhielt 3.331 Danke für 2.689 Beiträge

    Standard

    Zitat Zitat von StefanW. Beitrag anzeigen
    die BF-LED ist auch aus es leuchtet nur die SF-LED und es gehen beide CPU´s auf Stop.
    Da tippe ich mal auf Peripherie-Zugriffsfehler auf falsche Adresse.

    Wenn die Master/Slave-konfig falsch wäre, dann würde noch BF blinken.

    EDIT:
    Doch ein Busfehler.
    In beiden Diagnosepuffern steht was von sehr kurzzeitigem Stationsausfall mit Wiederkehr der Station, nachdem der Profibus schon beinahe 10 Minuten lief.
    Ich würde die Profibusstecker nochmal überprüfen.
    Oder passsiert der Busausfall, wenn Du Deinen Programmieradapter aufsteckst oder eine online-Funktion vom PG aufrufst?

    Harald
    Geändert von PN/DP (27.11.2014 um 17:19 Uhr)
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  7. #37
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.316
    Danke
    932
    Erhielt 3.331 Danke für 2.689 Beiträge

    Standard

    Zitat Zitat von JesperMP Beitrag anzeigen
    Muss dann auf der DP Slave "Test, Commisioning, Routing" gewählt werden ?
    Da bin ich mir auch nicht sicher.
    Im Zweifelsfall würde ich dann in PG/PC-Schnittstelle die Profibus-Netz-Diagnose aufrufen und die gefundenen Busteilnehmer anzeigen lassen.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  8. #38
    Registriert seit
    01.11.2007
    Beiträge
    1.239
    Danke
    91
    Erhielt 407 Danke für 368 Beiträge

    Standard

    Die beiden Diagnosepufferabzüge sind ja mit Ausnahme der ersten Zeile identisch, da ist wohl was schief gelaufen ...

    Grüße von HaDi

  9. Folgender Benutzer sagt Danke zu HaDi für den nützlichen Beitrag:

    PN/DP (27.11.2014)

  10. #39
    Registriert seit
    05.10.2012
    Ort
    Rahden
    Beiträge
    35
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von HaDi Beitrag anzeigen
    Die beiden Diagnosepufferabzüge sind ja mit Ausnahme der ersten Zeile identisch, da ist wohl was schief gelaufen ...

    Grüße von HaDi
    Das soll jetzt was bedeuten?

  11. #40
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.316
    Danke
    932
    Erhielt 3.331 Danke für 2.689 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von HaDi Beitrag anzeigen
    Die beiden Diagnosepufferabzüge sind ja mit Ausnahme der ersten Zeile identisch, da ist wohl was schief gelaufen ...
    Hast recht. Das mir das nicht aufgefallen ist ...


    Zum Step7-Projekt aus #25: das sieht für mich eigentlich OK aus

    Was ich aber anders machen würde:
    • in der IM151-7 die DP-Slave-Schnittstelle "Test, Inbetriebnahme, Routing" aktivieren (dann kann man beide CPU über Ethernet programmieren, die IM151-7 wird dann per S7-Routing via IM151-8 erreicht)
    • die MS-E/A-Adressen bei Master und Slave nicht so hoch legen (aber >= 32) und auf einer geraden Adresse anfangen und am besten in das Prozessabbild legen, also nicht PEW2041 sondern z.B. EW100. Möglichst dem Partner die spiegelgleiche E(A)-Adresse zur eigenen A(E)-Adresse geben und E- und A-Bereich bei der gleichen Adresse anfangen lassen: A100 --> E100, E100 <-- A100


    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

Ähnliche Themen

  1. Datenübergabe von USB an M277 an SPS
    Von Andree Kuhlmann im Forum HMI
    Antworten: 1
    Letzter Beitrag: 03.09.2011, 10:56
  2. Datenübergabe Safety FB --> Standart FB
    Von iPDI im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 18.08.2011, 15:54
  3. Datenübergabe an eine Leitwarte (S7-PC)
    Von progmann im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 30.09.2010, 15:14
  4. Datenübergabe an Bosch-Rexroth Indradrive
    Von Nordischerjung im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 12.05.2009, 12:03
  5. Datenübergabe
    Von PG710 im Forum Simatic
    Antworten: 18
    Letzter Beitrag: 28.04.2009, 11:36

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •