Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 19

Thema: Merkerwort übernimmt Wert nicht

  1. #1
    Registriert seit
    15.11.2011
    Beiträge
    12
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich hab wohl ein recht banales Problem.

    Ich habe einen Zähler in meinem Programm. Den Zählwert greife ich am MW1 ab.

    Wenn ich diesen Wert, der sich ab und an ändert an einem Vergleicher im nächsten Netzwerk vergleichen will, nimmt der den Wert nicht an.
    Gemäß dem Fall das sich der Zähler von 0 auf 1 ändert, dann hat das MW1 im 1. Netzwerk den Wert 1 und im Netzwerk 2 ist er immer noch bei 0 (anfangswert), aber ich will das der sich dann auch ändert

    Woran liegt das?

    danke im Vorraus
    Angehängte Grafiken Angehängte Grafiken
    Zitieren Zitieren Merkerwort übernimmt Wert nicht  

  2. #2
    Registriert seit
    13.08.2011
    Beiträge
    341
    Danke
    21
    Erhielt 47 Danke für 42 Beiträge

    Standard

    Wieso sind die Eingänge am Zähler in deinem Screenshot nicht beschaltet? Wird das MW1 vielleicht noch irgendwo anders beschrieben?
    Geändert von fuss (15.11.2011 um 11:48 Uhr)
    Gruss der Fuss!!!

    +|----,,----:
    ------R----| Widerstand ist zwecklos!!!
    -|----''----:

  3. #3
    SPS-Neuling777 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    15.11.2011
    Beiträge
    12
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Klar bekommen die Signale, die hab ich nur im screenshot nicht belegt

  4. #4
    Registriert seit
    19.12.2008
    Beiträge
    336
    Danke
    19
    Erhielt 28 Danke für 28 Beiträge

    Standard

    Was wolltest du dann mit dem Screenshot demonstrieren ?
    Mach es doch vielleicht mal vollständig und beantworte dann vielleicht auch die Frage von Fuss !

  5. Folgender Benutzer sagt Danke zu Lupo für den nützlichen Beitrag:

    fuss (15.11.2011)

  6. #5
    Registriert seit
    11.04.2008
    Ort
    Bayern
    Beiträge
    523
    Danke
    26
    Erhielt 67 Danke für 67 Beiträge

    Standard

    Doppelte Belegung oder ähnliches im Programm?
    Nur als Tipp ich würde immer gerade Adressen verwenden.
    Schau dir mal den DB2 online an was in diesem steht?

  7. #6
    Registriert seit
    16.12.2004
    Ort
    Schleswig-Holstein
    Beiträge
    400
    Danke
    21
    Erhielt 24 Danke für 21 Beiträge

    Standard

    Benutzt Du MW2 irgendwo in Deinem Program. Wenn so, dann, unter Umständen, bügelst Du damit MW1 platt.

  8. #7
    SPS-Neuling777 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    15.11.2011
    Beiträge
    12
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    @ Fuss: Nein, der MW1 wird nirgendwo sonst benutzt,



    @ netmaster

    kann es sein, das die SPS vlt noch ein Programm gespeichert hat wo irgendwo ein MW1 steht???

    Warum nur gerade Adressen....als MW meinst du?

    Wie kann ich mir den DB 2 online anschauen???

    @ RMA

    Ja ich benutze noch einen MW2 , aber warum beeinträchtigt der dann den MW1

  9. #8
    Registriert seit
    30.10.2009
    Ort
    10 km vom Herzen der Natur
    Beiträge
    1.626
    Danke
    120
    Erhielt 340 Danke für 255 Beiträge

    Standard

    @SPS Neuling
    MD 0 = MW 0 + MW 2 = MB 0 + MB 1 + MB 2 + MB 3 = MB 0 + MW 1 + MB 3
    MW 1 = MB 1 + MB 2
    MW 2 = MB 2 + MB 3
    Merkst Du was?
    Gruß
    Michael

  10. #9
    SPS-Neuling777 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    15.11.2011
    Beiträge
    12
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ah....

    das heißt wenn ich dann unabhängige MW verwenden will, darf ich nur

    MW1

    MW3

    MW5.....usw verwenden.

  11. #10
    Registriert seit
    30.10.2009
    Ort
    10 km vom Herzen der Natur
    Beiträge
    1.626
    Danke
    120
    Erhielt 340 Danke für 255 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von SPS-Neuling777 Beitrag anzeigen
    Ah....

    das heißt wenn ich dann unabhängige MW verwenden will, darf ich nur

    MW1

    MW3

    MW5.....usw verwenden.
    Prinzipiell richtig, aber Du solltest gerade Startadressen vorziehen:
    MW0
    MW2
    MW4
    MW6
    ...
    Gruß
    Michael

Ähnliche Themen

  1. Wert in Schrittkette wird nicht gesetzt
    Von tymanis im Forum Simatic
    Antworten: 15
    Letzter Beitrag: 18.05.2010, 16:44
  2. PEW Wert 32767 ändert sich nicht (PT100)
    Von Seth_Gecko im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 09.04.2010, 16:50
  3. Wert im Merkerwort soll Ausgang schalten.
    Von lowbit im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 23.02.2009, 23:18
  4. Antworten: 26
    Letzter Beitrag: 18.09.2008, 13:11
  5. Datenbaustein übernimmt Anfangswerte nicht
    Von bluebird277 im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 05.09.2008, 11:40

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •