Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 14

Thema: Probleme mit CP352-5 und PG-Funktionen

  1. #1
    Registriert seit
    15.03.2007
    Beiträge
    11
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    Ich hoffe ihr könnt mir weiterhelfen...

    Es handelt sich um eine Anlage die aus 2 Hauptteilen besteht die jeweils eine
    Master-CPU und eine eigenes Netz von Slaves besitzen.
    Diese Anlage wurde verlagert und zeigt seither folgendes Problem.
    Die Schwirigkeit ist dass ich nicht vor Ort bin und ich auf die Infos eines
    Kollegen angewiesen bin der vor Ort ist und auf die Möglichkeiten der
    Ferndiagnose über Modem.

    Im Anhang eine txt-Datei mit der Skitze des Systems.
    Aufbau.txt

    Nun habe ich folgendes Problem.
    Mit dem PC (Adr.10) kann ich Bausteine in der CPU316-2DP beobachten und
    beeinflussen, aber nicht auf der CPU318-2DP!
    Vor dem Umzug der Anlage ging das jedoch, seitdem wurde nichts an der
    Konfiguration verändert.
    Die beiden CPU´s (2 Anlagenteile) kommunizieren auch miteinander über den CP.
    Diese Kommunikation funktioniert auch, nur die PG-Funktionen gehen nicht.

    Hoffe jemand hatt eine Idee, ich komme nicht mehr weiter.

    Dank im vorraus
    Zitieren Zitieren Probleme mit CP352-5 und PG-Funktionen  

  2. #2
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Zitat Zitat von Manuel Beitrag anzeigen
    Hallo zusammen,

    Ich hoffe ihr könnt mir weiterhelfen...

    Es handelt sich um eine Anlage die aus 2 Hauptteilen besteht die jeweils eine
    Master-CPU und eine eigenes Netz von Slaves besitzen.
    Diese Anlage wurde verlagert und zeigt seither folgendes Problem.
    Die Schwirigkeit ist dass ich nicht vor Ort bin und ich auf die Infos eines
    Kollegen angewiesen bin der vor Ort ist und auf die Möglichkeiten der
    Ferndiagnose über Modem.

    Im Anhang eine txt-Datei mit der Skitze des Systems.
    Aufbau.txt

    Nun habe ich folgendes Problem.
    Mit dem PC (Adr.10) kann ich Bausteine in der CPU316-2DP beobachten und
    beeinflussen, aber nicht auf der CPU318-2DP!
    Vor dem Umzug der Anlage ging das jedoch, seitdem wurde nichts an der
    Konfiguration verändert.
    Die beiden CPU´s (2 Anlagenteile) kommunizieren auch miteinander über den CP.
    Diese Kommunikation funktioniert auch, nur die PG-Funktionen gehen nicht.

    Hoffe jemand hatt eine Idee, ich komme nicht mehr weiter.

    Dank im vorraus
    Also so ganz verstehe ich deinen Aufbau nicht.
    Wo ist wer und wie angeschlossen?
    Ich sehe zweimal die Adresse 2 und einen Hinweis auf Profibus 1 und 2.
    Kannst du schreiben wo dein PC, wie angeschlossen ist?
    Hängt das Modem auf dem Profibus 1 oder 2?
    Wie unterhalten sich die beiden PLC? Über Bus Nummer 1?

    Mit etwas mehr Informationen kann vielleicht geholfen werden.


    bike


    btw: es ist immer doof eine Maschine oder Anlage umzusetzen ohne Programmiergerät.
    Sich auf Fernwartung zu verlassen ist meist teuer

    Außerdem kannst du mir die Bestellnummer von dem CP352-5 einmal zukommen lassen?

  3. #3
    Manuel ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    15.03.2007
    Beiträge
    11
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Mehr Infos.....

    Also, hier eine bessere Zeichnung.Unbenannt.jpg

    Die Maschiene besteht aus 2 unabhängigen Anlagenteilen (A und B)!
    Jede hatt eine CPU (im DP-Master Modus) die duzende dezentrale Slaves über Profibus-DP abfragt.

    Prinzipiell funktionieren die anlagenteile also eigenständig.
    Jedoch müssen sie auch zusammenarbeiten, das heist CPU A und B müssen Daten austauschen.

    Der PC/PG mit der Adresse 10 hängt am Profibus von Anlage A.
    Er fungiert als Visualisierung. Es ist en OPC-Server und ein Visual Basic Programm
    installiert das Werte darstellt und auch einstellmöglichkeiten bietet.
    Und zwar können beide Anlagenteile (A und B) auf die Visualisierung zugreifen.

    Damit mann nicht immer ein PG anstöpseln muss ist auf dem PC auch Step7 installiert.
    Mit ihm kommt man über Profibus auf beide CPUs, kann also Diagnostizieren, programmieren, usw...

    Es funktioniert alles, CPUs machen was sie sollen, Meldungen am PC kommen,
    Werte lassen sich ändern (von beiden CPUs). Die Komunikation funktioniert also.

    Das einzigste Problem ist das ich vom PC zwar Bausteine online betrachten kann von Anlage A,
    jedoch nicht auch Anlage B sehen kann.

    Als die Maschine lezte Woche noch bei uns im Werk stand ging das noch, und es wurde nichts
    verändert an der Konfiguration oder am Programm.


    Siemens Field-PG ist vor Ort Vorhanden und kommt via MPI auch auf CPU A und B drauf.
    Es sollte aber auch vom PC gehen, denn es ist ja gegangen, habe selbst damit gearbeitet.

    Modem gibts nicht, aber der PC hatt Internetanschluss und über Fernsteuerungsprogramm kann
    ich den PC also bedienen.

    Wie gesagt ich bin leider nicht vor Ort, das Problem gehört meinem Kollegen, den ich aber
    aus der Ferne unterstütze.

    Wir sind auch keine Maschinenhersteller.Wir sind Instandhaltungspersonal, kennen uns
    aber mit Step7 recht gut aus. Nur momentan komm ich nicht weiter...

    Hoffe das die Infos hilfreich sind.

    grusse Manuel

    PS: Bestellnummern der Komponenten stehen in der Zeichnung.

  4. #4
    Registriert seit
    27.05.2006
    Beiträge
    189
    Danke
    0
    Erhielt 9 Danke für 9 Beiträge

    Standard

    Hallo,

    Es sollte wohl CP 342-5 sein!

    Ich nehme an, dass Routing richtig projektiert und eingeschtellt ist. Wie Du schreibst, hat es ja funktioniert.
    Ich verstehe, dass die Kommunikation funktioniert(beide CPU's tauschen Daten aus) nur routing nicht.
    Das Problem habe ich auch gehabt. Es waren aber 342-5 FO CP's(LWL). Es war genauso wie bei Dir. Routing hat mal funktioniert und mal nicht.
    Ich habe die Firmware von 5.4 auf 5.7 hochgezogen und das Problem war weg.

    Prüfe ob Routing von CPU B nach A funktioniert. Bei mir war es so, dass Routing immer nur in eine Richtung nicht funktionierte.

    Mein Beitrag dazu siehe in Siemens Forum.

    Viele Grüße
    Geändert von Pikador (22.11.2011 um 07:39 Uhr)

  5. #5
    Manuel ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    15.03.2007
    Beiträge
    11
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    danke für den Tip Pikador

    Sobald mein Kollege Zeit hatt, probieren wir das mal.

    Er ist grad etwas im Stress...


    gruss Manuel

  6. #6
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Ich würde mich mit dem PG an dem Bus anschließen und dann in der Diagnose prüfen, welche Teilnehmer am Bus sind.
    Wenn dann die Adresse bekannt ist, würde ich versuchen über DP auf die CPU zu kommen.
    Nach diesen Tests weißt du dann mehr.


    bike

  7. #7
    Manuel ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    15.03.2007
    Beiträge
    11
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    hallo bike

    Das mit dem Pg auf DP und versuchen auf die CPU B zu kommen habe ich schon versucht.
    Geht leider nicht...
    Die CPU B mit der Adresse 25 sehe ich zwar kann aber nicht auf sie zugreifen bzw. finde keine bausteine darin.
    Bausteine sind aber geladen, has per MPI überprüft und die Anlge arbeitet ja auch.

    So wie Pikador schon geschrieben hatt geht das Routing zu CPU B offensichtlich nicht.

    Wobei die "Arbeits"-Kommunikation (weiss nicht wie ichs sonst ausdrücken soll) zwischen den CPUs funktioniert.


    gruss Manuel

  8. #8
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Zitat Zitat von Manuel Beitrag anzeigen
    hallo bike

    Das mit dem Pg auf DP und versuchen auf die CPU B zu kommen habe ich schon versucht.
    Ich dachte du bist nicht vor Ort?

    Im Ernst, hast du mit dem PG am Bus unter Schnittstelle geprüft?
    Siehst du die Adresse 25?

    Wenn du dich an dem Cp anhängst, was sagt dir die Diagnose?

    Also das wegen Routing klingt komisch, da ja die Visualisierung funktioniert.


    bike

    P.S: langsam wird es interessant

  9. #9
    Manuel ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    15.03.2007
    Beiträge
    11
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Guten Morgen,

    Bin auch nicht vor Ort, aber ein PG kann man über Teamviewer auch fernsteuern

    Bin momentan daheim mit Gips-Daumen.

    Adresse 25 ist vorhanden. (taucht über Erreichbare Teilnehmer auf)

    Aber über den Profibus 1 kann ich weder vom PG noch vom PC auf die Bausteine zugreifen.
    Über Profibus 2 (den eigenen der CPU) und MPI gehts natürlich.


    Das mit der Diagnose geht momentan nicht, da mein Kollege vor Ort keine Zeit hatt für mich.

    Momentan ist der Firma einfach wichtiger dass die Anlage generell anläuft.

    Das Proglem mit dem Routing ist für sie eher ein Schönheitsfehler.

    Ich denke dass ich KW-Woche 48 oder 49 wieder dazu komme weiter zu suchen.

    Ich werde eure Hinweise und Ideen ausprobieren,
    besonders das mit der Firmware und der Diagnose des CP direkt.

    gruss Manuel

  10. #10
    Manuel ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    15.03.2007
    Beiträge
    11
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Also die Sache ist so...
    Die Anlage wurde zu einem Tochterwerk in Rumänien verlagert, und wird dort wieder in Betrieb genommen.
    Da alles auser das Routing zu CPU B funktioniert, ist für die Leute die bei uns was zu sagen haben alles ok.
    Für mich wäre das eigentlich auch OK, wie gesagt bin selbst ja nicht dort sondern arbeite im Mutterwerk in DE.

    Nur wenn es dort grössere Probleme gibt, logge ich mich ab und zu in den PC ein und such den Fehler über S7.
    Dann ist es halt blöd wenn man nicht auf die alle CPUs kommt.

    Und ungeplant zu verreisen muss ja auch nicht immer sein, deshalb nutze ich die Fernsteuerung
    eigentlich sehr oft und hatt bis jetzt immer Funktioniert.

    Ihr kennt das sicherlich, solange die Anlage funktioniert interesierts niemand, aber wenn was passiert dann
    fragt jeder warum kann ich nicht wie sonst auch einfach Online gehen und nachgkuggen!
    Und diese Situation möchte ich eigentlich nicht haben.

    grüsse Manuel

Ähnliche Themen

  1. Funktionen (FU) in WinCat
    Von Bambam im Forum CODESYS und IEC61131
    Antworten: 11
    Letzter Beitrag: 06.08.2010, 13:32
  2. B&R Funktionsbausteine/Funktionen
    Von pec im Forum Sonstige Steuerungen
    Antworten: 9
    Letzter Beitrag: 23.11.2009, 07:43
  3. Funktionen in Funktionen aufrufen
    Von Baldaro im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 21.06.2009, 16:17
  4. Taste mit 2 Funktionen
    Von Phase im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 09.12.2008, 10:36
  5. Aufruf der Funktionen in OB1
    Von blume_mercan im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 16.01.2008, 18:59

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •