Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: Fehler S7-300 Analog Eingangskarte SM 331

  1. #1
    Anonymous Gast

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Leute,

    habe ein Problem mit einer S7-300 SM331 8 Kanal Analog-Eingangsk.

    Es sind drei Sensoren 4-20 mA angeschlossen 1 mal 4-Draht,
    2 mal 2-Draht. Lese PEW 288, PEW 290 frei (Kanal 0-1 4-Draht)
    PEW 292 + PEW 294 (Kanal 2-3 2-Draht).

    Immer wenn ich die Kanäle 2 oder 3 anschliesse verändert sich automatisch der Wert von Kanal 0 (PEW 288 4-Draht).
    Woran kann dass liegen.
    Habe die SM 331 Karte Hardware mässig auf 4-Draht Kanal 0-1 und
    2-Draht Kanal 2-3 umgesteckt, auch im Hardwarekonfigurator kontrolliert
    alles O.K.
    Danke für eure Antworten.

    Bis dann

    Martin L.
    Zitieren Zitieren Gelöst: Fehler S7-300 Analog Eingangskarte SM 331  

  2. "Hallo,

    @Onkel Dagobert:

    Dein Vierdrahtsensor bekommt über zwei Drähte eine 24V-Spannungsversorgung. Für die S7-Baugruppe ist dieser ein Zweidrahtmessumformer (Spannungsversorgung intersessiert nicht)!
    Bist Du da ganz sicher? Ich habe immer 4Drahtsensor eingestellt, wenn die Versorgung nicht von der SM331 erfolgt, in anderem Fall und nur dann 2Draht.
    Es gibt nämlich auch die Variante, eine Spannungsquelle, den AE und den Sensor in Reihe zu schalten (was ich für kritisch halte, besonders wenn die eine Spannungsquelle viele Sensoren versorgen soll). In diesem Fall darf die SM331 nicht noch zusätzlich versuchen den Sensor zu versorgen, das kann für die Baugruppe und/oder den Sensor tödlich enden. Genauso vertragen es offensichtlich nicht alle Vierdrahtmeßumformer, wenn plötzlich noch 24Volt am Stromausgang anliegen.

    Peter"


  3. #2
    Registriert seit
    30.01.2004
    Ort
    Erfurt
    Beiträge
    961
    Danke
    42
    Erhielt 109 Danke für 87 Beiträge

    Standard

    Hallo,

    ich glaube, Du verwechselst da was:

    -4-Drahtmeßumformer 4-20mA: 2 Drähte an SM331, 2 Drähte an Spannungsversorgung (z.B. 24 Volt) - auf keinen Fall 4 Drähte an SM331 oder aber Du hast keinen MU 4-20 mA sondern eine Vierleiter-Widerstandsmessung (z.B. PT100) -> dann aber Meßbereichsmodul anders einstellen!

    -2-Drahtmeßumformer 4-20mA: 2 Drähte an SM331, diese speist den Meßumformer mit 24V Betriebsspannung

    Ansonsten: hast Du den Anschluß Analogmasse (M_Ana) mit M verbunden?
    Sind alle unbenutzten Eingänge mit einem Widerstand beschaltet oder auf Masse gelegt oder kurzgeschlossen?

    Viel Erfolg, Peter

  4. #3
    Anonymous Gast

    Standard

    Hallo Peter,

    danke für die schnelle Antwort.
    logisch habe keine 4-Drähte am Eingang angelegt!!
    Klemme 1 = 24 V DC +
    K0 2 + 3 = Drucksensor 1 4-Draht (extern mit 24 V DC versorgt)
    K1 4 + 5 = unbelegt (Keine Brücke etc.)
    K2 6 + 7 = Drucksensor 2 2-Draht
    K3 7 + 8 = Drucksensor 3 2-Draht
    10 + 11 = M_Ana auf Masse
    K4 12 + 13 = unbelegt (Keine Brücke etc.)
    K5 14 + 15 = unbelegt (Keine Brücke etc.)
    K6 16 + 17 = unbelegt (Keine Brücke etc.)
    K7 18 + 19 = unbelegt (Keine Brücke etc.)
    20 = Masse

    Habe leider nicht alle unbenutzten Eingänge mit einem Widerstand beschaltet oder auf Masse gelegt oder kurzgeschlossen?
    Muss dass wirklich gemacht werden??

    Danke

    Bis dann

    Martin L.

  5. #4
    Registriert seit
    06.02.2005
    Beiträge
    120
    Danke
    1
    Erhielt 10 Danke für 10 Beiträge

    Standard

    Hallo Tritec 100,

    da die Analogerfassungskarte von Siemens leider immer zwei Eingänge über ein Messbereichsmodul führen müssen diese Kanäle zueinander passen. Brücke die Klemmen 3 und 4 mit einem Draht und Deinen Drucksensor klemme an Klemme 2 und 5 an. So sollte es lt. Siemenshandbuch funktionieren.

    Gruß IFATD

  6. #5
    Registriert seit
    06.02.2005
    Beiträge
    120
    Danke
    1
    Erhielt 10 Danke für 10 Beiträge

    Standard

    Hallo Tritec 100,

    da die Analogerfassungskarte von Siemens leider immer zwei Eingänge über ein Messbereichsmodul führen müssen diese Kanäle zueinander passen. Brücke die Klemmen 3 und 4 mit einem Draht und Deinen Drucksensor klemme an Klemme 2 und 5 an. So sollte es lt. Siemenshandbuch funktionieren.

    Gruß IFATD

  7. #6
    Registriert seit
    06.10.2003
    Beiträge
    3.412
    Danke
    451
    Erhielt 506 Danke für 408 Beiträge

    Standard

    Beitrag zum Schutze der Allgemeinheit gelöscht.
    Ich war von Standard-Analogeingängen ausgegangen.

    Gruß, Onkel
    Es gibt viel mehr Leute, die freiwillig aufgeben, als solche, die echt scheitern.
    Henry Ford

  8. #7
    Registriert seit
    30.01.2004
    Ort
    Erfurt
    Beiträge
    961
    Danke
    42
    Erhielt 109 Danke für 87 Beiträge

    Standard

    Hallo,

    @Onkel Dagobert:

    Dein Vierdrahtsensor bekommt über zwei Drähte eine 24V-Spannungsversorgung. Für die S7-Baugruppe ist dieser ein Zweidrahtmessumformer (Spannungsversorgung intersessiert nicht)!
    Bist Du da ganz sicher? Ich habe immer 4Drahtsensor eingestellt, wenn die Versorgung nicht von der SM331 erfolgt, in anderem Fall und nur dann 2Draht.
    Es gibt nämlich auch die Variante, eine Spannungsquelle, den AE und den Sensor in Reihe zu schalten (was ich für kritisch halte, besonders wenn die eine Spannungsquelle viele Sensoren versorgen soll). In diesem Fall darf die SM331 nicht noch zusätzlich versuchen den Sensor zu versorgen, das kann für die Baugruppe und/oder den Sensor tödlich enden. Genauso vertragen es offensichtlich nicht alle Vierdrahtmeßumformer, wenn plötzlich noch 24Volt am Stromausgang anliegen.

    Peter

  9. #8
    Registriert seit
    06.10.2003
    Beiträge
    3.412
    Danke
    451
    Erhielt 506 Danke für 408 Beiträge

    Standard

    Hallo Peter,

    nein, ich bin mir nicht sicher, habe wohl etwas mit Standardeingängen verwechselt. Ich werd's wahrscheinlich löschen, um nicht noch mehr Unsicherheit zu verbreiten.
    Bei Siemens habe ich inzwischen ein Anschlussbild für die KF02 gefunden, welches recht eindeutig ist (besser als im Baugruppen-HB). Ich hänge es mal als Attachment an. Der Vollständigkeit halber auch eins für dir KF01.


    Gruß, Onkel
    Angehängte Grafiken Angehängte Grafiken
    Es gibt viel mehr Leute, die freiwillig aufgeben, als solche, die echt scheitern.
    Henry Ford

  10. #9
    Registriert seit
    25.09.2005
    Ort
    Neuss
    Beiträge
    278
    Danke
    11
    Erhielt 31 Danke für 29 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ein 4-Draht- Messumformer hat 4 Anschlussdrähte (nicht an der analogen Eingangskarte). 2 Drähte dienen der Spannungsversorgung des Sensors. Diese kann, muss aber nicht zwingend 24V haben. Der Sensor erzeugt mit dieser Hilfsenergie den benötigten Strom (0-20 / 4-20 mA) für den analog/digital-Wandler des analogen Einganges.

    Beim 2 Draht wird der Sensor direkt aus der analogen Eingangskarte mit Hilfsenergie versorgt (nämlich mind. 4 mA - darum gibt es auch bei 2-Draht- Geräten keinen 0-20 mA Bereich). Der Sensor begrenzt den Strom aus der analogen Eingangskarte (in der Regel 30-60 mA bei Kurzschluss) so, dass es dem gewünschten Messsignal entspricht (4-20 mA).

    Kurz gefasst: der wichtigste Unterschied ist der, dass bei einem 4-Draht Sensor der entsprechende Kanal Strom vom (fremdgespeisten) Sensor erwartet,

    bei 2-Draht liefert der analoge Eingang einen Stom, der vom Sensor auf 4-20 mA begrenzt wird.

    Am analogen Eingang werden bei beiden Varianten immer nur 2 Drähte angeschlossen.
    Angehängte Grafiken Angehängte Grafiken

Ähnliche Themen

  1. Analog Eingang mit Fehler < 0,1%
    Von Casimyr im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 09.08.2011, 09:00
  2. Eingangskarte +-10V Sensor +-4V ?
    Von Gluttony im Forum CODESYS und IEC61131
    Antworten: 16
    Letzter Beitrag: 22.03.2011, 09:49
  3. 315 2DP Problem mit Eingangskarte
    Von Dany_the_kid im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 26.05.2010, 16:17
  4. PT100 an Analog Eingangskarte
    Von Ray_k1 im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 10.11.2009, 04:49
  5. Analog In Baugruppe Fehler abfangen
    Von LukeSkywalker im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 10.07.2009, 07:38

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •