Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 10 ErsteErste 12345 ... LetzteLetzte
Ergebnis 21 bis 30 von 100

Thema: PT100 Programmieren!

  1. #21
    Krma1985 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.04.2007
    Beiträge
    223
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zur Zeit mache ich alles hier am PC also nichts mit SPS aber Danke.Den DB130 hatte ich noch nicht.Hab ich erstellt und leer abgespeichert aber es kommt immernoch die Meldung.

  2. #22
    Registriert seit
    13.04.2008
    Ort
    Großraum KA
    Beiträge
    963
    Danke
    52
    Erhielt 128 Danke für 112 Beiträge

    Standard

    Machst du das am Simulator ?

    peter(R)

  3. #23
    Registriert seit
    13.04.2008
    Ort
    Großraum KA
    Beiträge
    963
    Danke
    52
    Erhielt 128 Danke für 112 Beiträge

    Standard

    ist der FB auch in der SPS ??

    peter(R)

  4. #24
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Zitat Zitat von Krma1985 Beitrag anzeigen
    Hab jetzt mal den oben genannten Code im Programm so umgeändert das ich es speichern kann also so das es keine Fehlermeldungen mehr bringt.

    ;
    NAME: TEST
    AWL
    A DB 130
    L EW 88
    UN E 88.7
    SPB =M001
    KZW
    M001:
    SRW 4
    UN E 88.7
    SPB =M002
    KZW
    M002:
    T DW 61
    L KF +10
    T DW 64
    : SPA FB 242
    NAME: MUL:16
    L Z 1
    L Z 2
    L Z 3
    L Z 32
    L Z 31
    L KF +0
    UN E 89.3
    SPB =M003
    L DW 62
    L KF +0
    >F
    SPB =M004
    SPA =M005
    M004: L KF +5
    SPA =M003
    M005: L KF -5
    SPA =M003
    M003: L DW 62
    +F
    T DW 62
    L DW 73
    +F
    T DW 62
    BE


    Also das heißt fast alle : weggemacht und vor die Z noch ein Lade gemacht. Konnte es aber noch nicht versuchen an die SPS zu schicken.ist gerade nicht in meiner Nähe.
    Also etwas Kommentar wäre gut.
    Auch bei der S5 gibt es Netzwerke.
    Wenn ich mir recht erinnere gab es auch bei S5 Instanzdatenbausteine.
    Deine Ladeoperationen verstehe ich nicht.


    bike

  5. #25
    Registriert seit
    13.04.2008
    Ort
    Großraum KA
    Beiträge
    963
    Danke
    52
    Erhielt 128 Danke für 112 Beiträge

    Standard

    Das hat er aus einem anderen Thred abkopiert da gabs auch keine Kommentare.
    Aber ich bin mir zB auch ziemlich sicher dass die 100 U den Befehl +F NICHT kennt.

    peter(R)

  6. #26
    Krma1985 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.04.2007
    Beiträge
    223
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Es ist zur Zeit garnichts in der SPS.wenn ich den oben genannten Code in AWL in den FB72 schreibe und es abspeichern will bringt der mir die Anweisungsfehler.
    Bike: wie gesagt ich habe den AWL Code nur von der Seite http://www.sps-forum.de/showthread.p...U%20Analogwert kopiert.

  7. #27
    Registriert seit
    13.04.2008
    Ort
    Großraum KA
    Beiträge
    963
    Danke
    52
    Erhielt 128 Danke für 112 Beiträge

    Standard

    Genauso ist L DW 73 recht schräg !!

    peter(R)

  8. #28
    Krma1985 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.04.2007
    Beiträge
    223
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    wie rechts schräg?

  9. #29
    Registriert seit
    13.04.2008
    Ort
    Großraum KA
    Beiträge
    963
    Danke
    52
    Erhielt 128 Danke für 112 Beiträge

    Standard

    Nehme alles zurück bei S5 waren es ja noch einfache Sprünge DW 0 ... DW1 ... usw.

    peter(R)

  10. #30
    Registriert seit
    05.01.2009
    Ort
    69198 Schriesheim
    Beiträge
    236
    Danke
    54
    Erhielt 34 Danke für 33 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Der Code ist verständlicherweise aus dem o.g. Link herauskopiert, so gibt das aber nichts.
    Das fängt ja schon beim Aufruf des FB´s an der noch gar nicht existiert.
    Ich denke du solltest dich zunächst auf das einlesen der Analogkarte fixieren, mit einer Funktion
    desssen könntest du mal anfangen etwas effektiver zu arbeiten, mit dem Code wird das zuviel.
    Also

    L EW xxx

    erst wenn du da mal Einheiten bekommst macht es Sinn darauf aufzubauen.

    gruß Thomas

    @Peter : Sorry zu spät gelesen, bzw. zu lange zum tippen gebraucht

Ähnliche Themen

  1. Pt100
    Von c.wehn im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 20.07.2010, 10:50
  2. Antworten: 10
    Letzter Beitrag: 04.04.2010, 15:47
  3. Antworten: 39
    Letzter Beitrag: 04.05.2008, 08:38
  4. PT100 an die SPS
    Von MiniYvonne im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 07.04.2007, 18:28
  5. Pt100
    Von Much2k im Forum Sonstige Steuerungen
    Antworten: 5
    Letzter Beitrag: 07.06.2006, 21:39

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •