Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: Bereichszeiger für OP77 Problem mit Länge

  1. #1
    Registriert seit
    20.04.2008
    Ort
    Schaffhausen
    Beiträge
    87
    Danke
    10
    Erhielt 0 Danke für 0 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo an alle.

    Habe es nun ausgiebig versucht den Fehler zu beheben.

    Habe einen bestehendes Projekt abgeändert.
    Bis jetzt musste ich mich leider nicht um das funktionieren des Bereichszeigers bemühen, es hat immer funktioniert.
    Nun musste ich für die Eichprozedur des Kran's den AWL Baustein erweitern.
    Dabei geht es darum das wir am OP77 im Eich-Menü die jeweiligen Bilder aufrufen, und der AWL Baustein anhand des aktiven Bildes und Bestätigung via Taste
    dann den jeweiligen Wert abspeichert.

    Dies funktioniert jedoch nur bis zu einem bestimmten Punkt.
    Leider ist bei NW11 fertig.

    Habe bereits versucht mit dem Eintrag der Bildnummer zur arbeiten, bringt jedoch auch keinen Erfolg.
    Wenn ich im FC jedoch NW11 mit NW12 austausche speichert es mir den nächsten Wert ab.

    Somit kann es nicht am OP77 liegen.

    Ich bin leider kein AWL Guru.
    Und mit dem Bereichszeiger habe ich leider auch nicht viel am Hut.
    Aus den Anleitungen werde ich nicht schlau.

    Kann mir jemand sagen was ich wo länger machen muss.
    Aus den Daten des DB Bereichszeiger werde ich auch nicht schlau.
    Angehängte Dateien Angehängte Dateien
    Zitieren Zitieren Bereichszeiger für OP77 Problem mit Länge  

  2. #2
    Registriert seit
    06.10.2009
    Ort
    NRW
    Beiträge
    1.569
    Danke
    63
    Erhielt 258 Danke für 218 Beiträge

    Standard

    Das sieht etwas wüst aus. Hab grad keine Zeit genauer hineinzusehen, aber ein Tipp noch: Versuch mal die Ansicht auf Kop oder FUP umzustellen. Die ganzen Sprünge deuten darauf hin, dass die Netzwerke in Kop oder FUP erzeugt wurden. Vielleicht sieht der Code dann auch für Dich lesbarer aus...

    Edit: Hab doch noch kurz draufgeguckt. Da sind ja "böse" Zugriffe auf den Lokaldatenbereich. Wenn Du an der Bausteinschnittstelle warst, stimmen die Adressen jetzt nicht mehr. Hier schon mal ein "PFUI" für das
    Code:
    L 8.0
    Geändert von Tigerente1974 (12.12.2011 um 16:05 Uhr) Grund: Nachtrag
    Meine Motivation läuft nackig mit einem Cocktail über eine Wiese.

  3. #3
    Registriert seit
    20.04.2008
    Ort
    Schaffhausen
    Beiträge
    87
    Danke
    10
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke.

    Habe ich auch schon versucht.
    Er lässt sich nicht in FUP darstellen.

  4. #4
    Registriert seit
    20.04.2008
    Ort
    Schaffhausen
    Beiträge
    87
    Danke
    10
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich habe es anderweitig gelösst.
    Habe einen neuen FC geschrieben.
    Etwas einfacher und verständlicher.
    Falls jemand Lust hat den geposteten zu übersetzen nur zu.

  5. #5
    Registriert seit
    06.10.2009
    Ort
    NRW
    Beiträge
    1.569
    Danke
    63
    Erhielt 258 Danke für 218 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Nö...

    Das L8.0 war übrigens ein Ergebnis der Konvertierung von KOP/FUP --> AWL. Nehme meine Beschimpfung also zurück.
    Wenn es jetzt klappt, dann ist ja gut.
    Meine Motivation läuft nackig mit einem Cocktail über eine Wiese.

Ähnliche Themen

  1. Bereichszeiger ProTool für OP7
    Von rumpelix im Forum HMI
    Antworten: 1
    Letzter Beitrag: 12.05.2009, 19:25
  2. Antworten: 0
    Letzter Beitrag: 12.12.2008, 14:03
  3. AktiviereBild problem mit OP77
    Von Tiansen im Forum HMI
    Antworten: 1
    Letzter Beitrag: 05.06.2008, 14:42
  4. Frage zum Bereichszeiger und OP7
    Von linuxluder im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 27.11.2007, 15:19
  5. bereichszeiger...
    Von Jochen Kühner im Forum HMI
    Antworten: 0
    Letzter Beitrag: 09.08.2004, 15:38

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •