Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: Uhrzeit von CP343-1 in Step7-Programm verwenden

  1. #1
    Registriert seit
    21.09.2011
    Beiträge
    9
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Zusammen,
    ich habe folgendes Problem: Ich würde gerne die Uhrzeit von der CP zur CPU senden lassen, leider funktioniert dies nicht. Die CP bekommt die Uhrzeit von unserem NTP-Server. Diese
    synchronisiert sich auch zuverlässig. Jedoch wird die aktuelle Uhrzeit nicht zur CPU gesendet. In der CPU habe ich bei "Diagnose/Uhr" die Synchronisation im AS auf "Slave" gesetzt.

    Folgende Hardware verwende ich:
    CP343-1 Lean: 1EX30
    CPU 315F-2DP: 6FF01

    Falls dafür keine Lösung gibt:
    Wäre es auch möglich, die CP-Zeit direkt im Step 7 Programm zu verwenden?
    Das ist eigentlich sowieso die wirkliche Funktion, die ich benötige!
    Vielen Dank für Eure Hilfe!!
    Zitieren Zitieren Uhrzeit von CP343-1 in Step7-Programm verwenden  

  2. #2
    Registriert seit
    08.04.2008
    Ort
    Köln
    Beiträge
    844
    Danke
    39
    Erhielt 244 Danke für 199 Beiträge

    Standard

    Hallo MrFisch,

    Hast Du auf dem CP bei Uhrzeitsynchronisation im Simatic-Verfahren "Uhrzeit weiterleiten" eingestellt?

    Grüße
    Gebs

    PS.: Bestellnr. 1EX30 gehört nicht zu einer Lean-Baugruppe.

  3. Folgender Benutzer sagt Danke zu Gebs für den nützlichen Beitrag:

    MrFisch (14.12.2011)

  4. #3
    MrFisch ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    21.09.2011
    Beiträge
    9
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo Gebs,
    vielen Dank für deine Antwort. Ich nutze bei der CP für die Uhrzeitsynchronisation das NTP Verfahren, damit ist die Möglichkeit "Uhrzeit weiterleiten" im Simatic-Verfahren gesperrt.
    Dafür hab ich den Haken bei: "Uhrzeit an Station weiterleiten" im NTP-Verfahren gesetzt.

    Du hast natürlich recht, 1EX30 ist keine Lean Baugruppe!

    Weißt du zufällig, ob man die CP-Zeit im S7 Programm verwenden kann? Ähnlich wie die CPU-Zeit?

  5. #4
    Registriert seit
    08.04.2008
    Ort
    Köln
    Beiträge
    844
    Danke
    39
    Erhielt 244 Danke für 199 Beiträge

    Standard

    Hallo MrFisch,

    Du musst bei der CPU die Synchronisation bei MPI auf Slave setzen.
    Dann sollte es funktionieren:
    http://support.automation.siemens.co...ew/de/42687075


    Grüße
    Gebs



  6. #5
    MrFisch ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    21.09.2011
    Beiträge
    9
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Das habe ich auch schon versucht, (hab genau dieses Supportdokument gefunden), jedoch kommt folgende Fehlermeldung beim Übersetzen: "Für die Uhrzeitsynchronisation darf die CPU nur einmal als Uhrzeit-Slave projektiert sein. Es darf auch nur ein Teilnehmer in der Station die Uhrzeit weiterleiten".... Diese Fehlermeldung macht überhaupt keinen Sinn: Die CPU ist nur einmal als Slave projektiert (Bei AS: Keine / Bei MPI: Slave), Aktuell ist auch nur die CP als Teilnehmer projektiert, welcher die Uhrzeit weiterleitet.

    Noch eine Idee?

  7. #6
    Registriert seit
    01.11.2007
    Beiträge
    1.237
    Danke
    91
    Erhielt 407 Danke für 368 Beiträge

    Standard

    Nimm mal die Synchronisation bei der CPU raus, das Weiterleiten vom CP genügt.

    Grüße von HaDi

  8. #7
    Registriert seit
    08.04.2008
    Ort
    Köln
    Beiträge
    844
    Danke
    39
    Erhielt 244 Danke für 199 Beiträge

    Standard

    Hallo MrFisch,

    ich hab' noch mal nachgesehen. Bei manchen Beiträgen wird die 315 als "große CPU" (=> Synch im AS) und bei Manchen als "kleine CPU" (=> Synch mit MPI) beschrieben. Deshalb weiß ich jetzt nicht was bei Dir eingestellt werden muss.
    Was Deine Fehlermeldung betrifft: Diese tritt bei mir nicht auf (V5.4 SP5).
    Auf den Seiten vom Siemens-Support, ist auch von einem Bug (Feature) die Rede, die dieses Problem beschreiben. Da heisst es dann, man soll nicht
    den aktuellen CP projektieren, sondern die Version 2.0.
    http://www.automation.siemens.com/WW...09&language=de

    Im Handbuch zum CP hab ich noch was gefunden:
    Code:
    Achtung
    
    Beachten Sie zur Uhrzeitsynchronisation im NTP−Verfahren:
    Wird vom CP ein NTP−Telegramm als ”nicht genau” erkannt (Beispiel: NTP−Server
    ist nicht extern synchronisiert), erfolgt keine Weiterleitung auf den K−Bus. Tritt
    dieses Problem auf, wird in der Diagnose keiner der NTP−Server als ”NTP−Master”
    angezeigt; vielmehr werden alle NTP−Server nur als ”erreichbar” angezeigt.
    Schau doch mal in der Diagnose Deines CPs nach, ob das bei Dir der Fall sein könnte.

    Grüße
    Gebs

  9. #8
    MrFisch ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    21.09.2011
    Beiträge
    9
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Mit der Version 2.0 hat es tatsächlich funktioniert.... Meine auch mal gelesen zu haben, das es mit einem Hotfix 4 für Step 7 5.5 dieser Bug behoben sein soll...
    VIELEN VIELEN DANK für deine super Hilfe!!!

  10. #9
    Registriert seit
    22.01.2009
    Beiträge
    288
    Danke
    61
    Erhielt 32 Danke für 25 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Mit dem SP1 für STEP7 5.5 ist das Problem auch behoben.

Ähnliche Themen

  1. Antworten: 3
    Letzter Beitrag: 22.09.2010, 18:51
  2. Schneider Concept (Quantum): Zykluszeit im Programm verwenden
    Von flisse im Forum Sonstige Steuerungen
    Antworten: 1
    Letzter Beitrag: 17.02.2010, 11:33
  3. Step7 und WinCC-Programm kombinieren
    Von zigelei im Forum HMI
    Antworten: 5
    Letzter Beitrag: 06.02.2009, 15:42
  4. Antworten: 10
    Letzter Beitrag: 02.01.2008, 16:54
  5. CP343-IT Applets verwenden
    Von lorenz2512 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 25.11.2007, 09:43

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •