Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 21

Thema: Zykluszeit einer Anlage messen

  1. #1
    Registriert seit
    27.12.2011
    Beiträge
    8
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo

    Habe bei meinem neusten Projekt leider ein Paar schwierigkeiten...
    Ich sollte zur Veranschaulichung die Zykluszeit meiner Anlage in einem TP177B anzeigen
    Meine Idee war, die Zeit zwischen dem Startimpuls meiner Schrittkette und dem Endschritt der Schrittkette zu messen.
    Leider habe ich hierzu keinerlei Ideen wie ich das nun am dümmsten lösen könnte
    Zykluszeiten liegen bei etwa 5 sekunden und sollten im 10 ms Raster angezeigt werden
    Ich hoffe ihr könnt mir irgendwie helfen

    Habe übrigens eine CPU 315-2DP

    Danke schonmal im Vorraus
    Zitieren Zitieren Zykluszeit einer Anlage messen  

  2. #2
    Registriert seit
    05.10.2005
    Beiträge
    2.387
    Danke
    321
    Erhielt 298 Danke für 268 Beiträge

    Standard

    ... beim Startimpuls die aktuelle OB1-Zeit in einen DB schreiben, beim Beenden der Schrittkette die OB1-Zeit nehmen und von ihr die gespeicherte subtrahieren.

    Thomas

  3. #3
    Häring ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    27.12.2011
    Beiträge
    8
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Also einfach die Aktuelle Systemzeit der CPU laden und das subtrahieren?
    Klingt nichtmal so kompliziert wie ich das gedacht habe

  4. #4
    Registriert seit
    23.04.2009
    Ort
    Allgäu
    Beiträge
    3.042
    Danke
    241
    Erhielt 863 Danke für 617 Beiträge

    Standard

    Zitat Zitat von Häring Beitrag anzeigen
    Zykluszeiten liegen bei etwa 5 sekunden und sollten im 10 ms Raster angezeigt werden
    Hallo Häring,
    bei Zykluszeiten von 5 Sekunden solltest du dein Programm nochmals überarbeiten.
    Oder hast du für die Schulungszwecke ein paar "Bremsen" eingebaut?
    Gruß
    Paule
    ----------------------------------------------------------------------------
    > manchmal verliert man und manchmal gewinnen die anderen <

  5. #5
    Häring ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    27.12.2011
    Beiträge
    8
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Paule,
    Inwiefern überarbeiten?
    Bremsen gibt es leider nicht, da es sehr strikte Vorgaben seitens der Stückzahlen der Maschine gibt

  6. #6
    Registriert seit
    23.04.2009
    Ort
    Allgäu
    Beiträge
    3.042
    Danke
    241
    Erhielt 863 Danke für 617 Beiträge

    Standard

    Zitat Zitat von Häring Beitrag anzeigen
    Inwiefern überarbeiten?
    Ich würde jetzt mal behaupten dass es nicht 5 Sekunden sondern 5 Millisekunden heißen soll.
    Die Maximale Zykluszeit der CPU ist zwar einstellbar, aber 5 Sekunden?
    Da kommt dann schon langsam mal der Fehler-OB ins Spiel.
    Gruß
    Paule
    ----------------------------------------------------------------------------
    > manchmal verliert man und manchmal gewinnen die anderen <

  7. #7
    Häring ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    27.12.2011
    Beiträge
    8
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Nicht die Zykluszeit des Bausteines sollte gemessen werden
    sondern die zeit vom Einlegen eines Rohteiles durch einen Roboter bis zum Entnehmen des Fertigteils
    Diese zeit sollte ich anzeigen

  8. #8
    Registriert seit
    09.06.2008
    Beiträge
    138
    Danke
    16
    Erhielt 13 Danke für 13 Beiträge

    Standard

    5 Sekunden ist schon derbe lang.
    Da musst Du ja schon bald aufpassen das Du nicht die max. mögliche Zykluszeit erreichst und Dir die Anlage in Stop geht
    Kenne die 300er Steuerungen nicht bei den 400er liegt die bei 6 Sekunden. -> Aufpassen!

    Edit:
    Ach Du meinst gar nicht die CPU-Zykluszeit ?
    Na dann einfach wie beschrieben oder aber gibt auch fertige Bausteine glaube TIME_Begin und TIME_END
    Geändert von ich988 (27.12.2011 um 23:45 Uhr)

  9. #9
    Registriert seit
    23.04.2009
    Ort
    Allgäu
    Beiträge
    3.042
    Danke
    241
    Erhielt 863 Danke für 617 Beiträge

    Standard

    Zitat Zitat von Häring Beitrag anzeigen
    Nicht die Zykluszeit des Bausteines sollte gemessen werden
    sondern die zeit vom Einlegen eines Rohteiles durch einen Roboter bis zum Entnehmen des Fertigteils
    Diese zeit sollte ich anzeigen
    Oh je, klar, hier steht es ja:
    Zitat Zitat von Häring Beitrag anzeigen
    Meine Idee war, die Zeit zwischen dem Startimpuls meiner Schrittkette und dem Endschritt der Schrittkette zu messen
    Sorry, mein Fehler.
    Gruß
    Paule
    ----------------------------------------------------------------------------
    > manchmal verliert man und manchmal gewinnen die anderen <

  10. #10
    Häring ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    27.12.2011
    Beiträge
    8
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Kein Problem
    Naja dann werd ich mal morgen den Simatic Manager durchstöbern
    Zum Glück ist Urlaubszeit und es ist genug zeit um es auszuprobieren
    Dankeschön für eure Tipps

Ähnliche Themen

  1. Hilfe! Automatisieren einer Anlage
    Von yoyo99 im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 24.11.2011, 15:56
  2. [S5] Zykluszeit messen bei einer S5-135U
    Von euro im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 13.01.2010, 11:19
  3. Steuerungsproblem beim Erweitern einer Anlage
    Von Outrider im Forum Schaltschrankbau
    Antworten: 2
    Letzter Beitrag: 23.09.2009, 15:11
  4. Antworten: 4
    Letzter Beitrag: 23.06.2009, 17:50
  5. Zykluszeit eines Bausteines messen?!
    Von Hawkster im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 17.12.2006, 20:31

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •