Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 2 von 2

Thema: TIA 11 SP2 - Wert wird nicht gelöscht

  1. #1
    Registriert seit
    28.11.2011
    Beiträge
    58
    Danke
    34
    Erhielt 4 Danke für 3 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Guten Tag

    Verwende:

    TIA V11 SP2
    SP-1200 1212AC/DC/RLY

    Ich habe mir ein FC programmiert und diesen in ein OB eingefügt.

    Ich habe an meinem FC den Eingang EN mit einem Eingang belegt. Wenn ich den Eingang aktivieren wird der Baustein sauber bearbeitet.
    Wenn ich nun den Eingang ausschalte dann wird der Baustein nicht mehr bearbeitet aber die Werte am Ausgang bleiben bestehen.

    Das sind Reale Werte die Ausgeben werden.

    Habe ich etwas falsch eingestellt oder ist das Software/Hardware bedingt?

    Gruß
    Zitieren Zitieren TIA 11 SP2 - Wert wird nicht gelöscht  

  2. #2
    Registriert seit
    05.10.2005
    Beiträge
    2.373
    Danke
    321
    Erhielt 296 Danke für 266 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Das ist normal, wenn du die Variablen nirgends anders beschreibst. Dann behalten sie ihren Wert bis du wieder was auf sie zuweist.
    Dann sollte dein Enable Eingang nicht auf Enable gehen, sondern im Baustein die Variablenausgabe steuern. Wenn 1 dann errechneter Wert, wenn 0 dann 0. ....
    Thomas

Ähnliche Themen

  1. KTP Meldeanzeige wird nicht gelöscht
    Von Sinix im Forum HMI
    Antworten: 2
    Letzter Beitrag: 13.12.2010, 13:54
  2. Antworten: 4
    Letzter Beitrag: 29.07.2010, 20:53
  3. Wert in Schrittkette wird nicht gesetzt
    Von tymanis im Forum Simatic
    Antworten: 15
    Letzter Beitrag: 18.05.2010, 16:44
  4. Antworten: 9
    Letzter Beitrag: 18.11.2009, 16:04

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •