Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 23

Thema: Sprungbefehl, Ausgang bleib gesetzt

  1. #1
    Registriert seit
    17.03.2010
    Beiträge
    327
    Danke
    66
    Erhielt 3 Danke für 3 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    ich teste eben die Sprungbefehle.
    Hab folgendes gemacht:

    U E1.0 „Fahrt nach oben“
    U E1.1 „ Endschalter oben“
    SPBN M1
    = A1.2 "Antrieb nach oben"

    M1: NOP 0

    Was mich wundert ist, das der Ausgang A1.2 dauerd gesetzt bleibt. Müßte doch bei betädigen der Taster mal auf "0" gehn, oder ?

    Gruß Markus



    Zitieren Zitieren Sprungbefehl, Ausgang bleib gesetzt  

  2. #2
    Registriert seit
    30.10.2009
    Ort
    10 km vom Herzen der Natur
    Beiträge
    1.628
    Danke
    120
    Erhielt 340 Danke für 255 Beiträge

    Standard

    Die Anweisung =A1.2 wird nur bei VKE 1 bearbeitet und bei VKE 0 übersprungen, deswegen wird die 0 nicht auf A1.2 geschrieben.

    Was willst Du eigentlich mit diesem Sprung erreichen?
    Gruß
    Michael

  3. Folgender Benutzer sagt Danke zu M-Ott für den nützlichen Beitrag:

    Pockebrd (06.01.2012)

  4. #3
    Registriert seit
    11.09.2007
    Ort
    Suedwestpfalz
    Beiträge
    917
    Danke
    81
    Erhielt 209 Danke für 192 Beiträge

    Standard

    Immerhin hast Du den Beweis erbringen können das der Sprung funktioniert ...
    Das Grauen lauert in der Zwischenablage !!

  5. #4
    Registriert seit
    19.06.2003
    Ort
    Im Staub ...
    Beiträge
    337
    Danke
    115
    Erhielt 26 Danke für 23 Beiträge

    Standard

    Außerdem ist nach einem SPB oder SPBN das VKE immer 1, egal ob das VKE vor dem Sprung 0 bzw. 1 war
    Geändert von ssound1de (05.01.2012 um 13:12 Uhr)

  6. #5
    Registriert seit
    30.10.2009
    Ort
    10 km vom Herzen der Natur
    Beiträge
    1.628
    Danke
    120
    Erhielt 340 Danke für 255 Beiträge

    Standard

    Zitat Zitat von ssound1de Beitrag anzeigen
    Außerdem ist nach einem SPB oder SPBN das VKE immer 1, egal ob das VKE vor dem Sprung 0 bzw. 1 war
    Das wäre mir neu.
    Gruß
    Michael

  7. #6
    Pockebrd ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    17.03.2010
    Beiträge
    327
    Danke
    66
    Erhielt 3 Danke für 3 Beiträge

    Standard

    Zitat Zitat von M-Ott Beitrag anzeigen
    Das wäre mir neu.
    Und wer hat recht ?


    Ich wollte mit einem Starttaster verschiedene Antriebe nacheinander in Grundstellung fahren lassen.

    Start, erster Antrieb (1) nach oben
    dann, nach rechts,
    dann einen weiteren Antrieb (2) zurück,
    dann ein weiteren Antrieb (3) zurück
    fertig

    Antriebe sind jeweils mit Endschalter abfragt.
    Wenn ein Antrieb schon in Position ist, wollte ich ihn überspringen.


    Dachte wenn ich anstatt "setzten" A1.2 ein " = " verwende, geht der Ausgang wieder zurück auf 0

  8. #7
    Registriert seit
    27.04.2006
    Ort
    Sauerland
    Beiträge
    626
    Danke
    183
    Erhielt 88 Danke für 81 Beiträge

    Standard

    Und wenn die anweisung nicht bearbeitet wird? dann ist es völlig egal wer recht hat, ob das vke nun immer 1 wird oder nicht. du springst doch über die zuweisung des ausgangs weg. was soll da dann noch passieren? der bleibt solange auf 1 bis die cpu auf stop geht.
    Die Kunst in der Personalführung ist es
    die Mitarbeiter so über den Tisch zu ziehen,
    dass sie die Reibungshitze als Nestwärme empfinden.

  9. #8
    Registriert seit
    23.10.2009
    Beiträge
    399
    Danke
    59
    Erhielt 114 Danke für 88 Beiträge

    Standard

    Zitat Zitat von M-Ott Beitrag anzeigen
    Das wäre mir neu.
    Aber man ist ja noch lernfähig
    Tip: Online-Hilfe
    Gruß
    Erich

  10. #9
    Registriert seit
    05.03.2007
    Ort
    Lindlar
    Beiträge
    112
    Danke
    19
    Erhielt 20 Danke für 18 Beiträge

    Standard

    Zitat Zitat von LargoD Beitrag anzeigen
    Aber man ist ja noch lernfähig
    Tip: Online-Hilfe
    Gruß
    Erich
    Steht nicht nur in der Online-Hilfe so drin sondern ist auch in der Realität so!

    Gruß
    Matthias
    IF Time < '09:00:00' THEN
    SELECT finger from right hand where ID=3
    END IF

  11. #10
    Registriert seit
    30.10.2009
    Ort
    10 km vom Herzen der Natur
    Beiträge
    1.628
    Danke
    120
    Erhielt 340 Danke für 255 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Panzerknacker Beitrag anzeigen
    Steht nicht nur in der Online-Hilfe so drin sondern ist auch in der Realität so!

    Gruß
    Matthias
    Da gibt's ja des öfteren Mal Abweichungen aber diesmal stimmt's! Hab's gerade überprüft! Übrigens unabhängig davon, ob der Srpung ausgeführt wird oder nicht.
    Gruß
    Michael

Ähnliche Themen

  1. Antworten: 5
    Letzter Beitrag: 05.03.2010, 11:45
  2. Sprungbefehl
    Von Bollmann im Forum Simatic
    Antworten: 27
    Letzter Beitrag: 06.08.2009, 12:07
  3. Sprungbefehl SPBN
    Von petzi im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 10.05.2009, 15:16
  4. Ausgang wird mal gesetzt mal nicht!?
    Von Deyn im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 04.05.2009, 13:48
  5. Codesys und Wago 750 Ausgang bleibt gesetzt ?
    Von Waelder im Forum Sonstige Steuerungen
    Antworten: 3
    Letzter Beitrag: 24.05.2006, 08:30

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •