Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 6 von 7 ErsteErste ... 4567 LetzteLetzte
Ergebnis 51 bis 60 von 61

Thema: Timerproblem...

  1. #51
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.732
    Danke
    314
    Erhielt 1.520 Danke für 1.282 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Womit testest du, hast du die HW-Konfig bzw. die Systemdaten mit übertragen?

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  2. #52
    schnecke ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.07.2010
    Beiträge
    148
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ja Manuel,

    habe die Systemdaten mit übertragen... teste mit PLCSIM.

    Wobei mir ehrlich gesagt auch nicht ganz klar ist, warum es bei den Timern diesen Unterschied in der Ablaufzeit gibt - es werden doch beide Timer gleichzeitig gestartet und beide Merker im OB1 zugewiesen. Der OB35 unterbricht doch für beide Timer den OB1-Zyklus gleich...

    Muss mir das nochmal in Ruhe ansehen, kapier es momentan echt nicht.
    L.G. schnecke

  3. #53
    Registriert seit
    14.02.2012
    Beiträge
    8
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo schnecke,

    Die unterschiede in den Zeiten Rühren daher, das der OB35 den S7-Timer unterbricht, weil es ein Baustein-Aufruf ist.
    Der S5Timer läuft aber weiter wenn er einmal gesetzt worden ist. (Läuft ja im Betriebssystem der S7)

    MfG
    Günther

  4. #54
    schnecke ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.07.2010
    Beiträge
    148
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke Günther,

    im Grunde werden aber doch beide Timer zeitgleich bei Aktivität des OB35 aufgerufen, richtig?

    Dann laufen Timer1 und Timer TON ab... bis der Timer TON nach 10s vom OB35 erneut aufgerufen wird, ist er (mit seinen 5s Laufzeit) doch schon längst abgelaufen.
    L.G. schnecke

  5. #55
    Registriert seit
    14.02.2012
    Beiträge
    8
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Berichtigung !!!

    Tut mir leid, meine Antwort war natürlich Blödsinn
    Kommt davon, wenn man mit zig verschiedenen Steuerungen konfrontiert wird.
    Aber ich vermute mal das der Simulator vielleicht auch nicht unbedingt echtzeitmäßig arbeitet.
    Ist ja auch eine ganz eindeutige Aussage im Handbuch der Software.

    MfG
    Günther

  6. #56
    Registriert seit
    26.05.2009
    Beiträge
    541
    Danke
    35
    Erhielt 78 Danke für 69 Beiträge

    Standard

    Hallo schnecke,

    also bei mir funktionierts auch mit PLCSIM.
    Anscheinend machst du was falsch.

    Der Unterschied ist der, dass der Timer1 unabhängig vom OB35 schaltet.
    Der Timer1 schaltet also nach 5s.
    Der TON schaltet vom Prinzip her auch nach 5s, wird aber erst nach 10s wieder aufgerufen und erst dann gibt er sein 1-Signal an den entsprechenden Merker, der dann einen Ausgang schaltet.

    Also nach 5s wird der Timer1 geschaltet und dementsprechend ein Ausgang im OB1.
    Erst nach weiteren 5s schaltet der TON im OB35 den Merker, der dann im OB1 einen Ausgang schaltet.

    Ich hab mir zwar jetzt Manuels Programm nicht angeschaut, sondern selber eins gebastelt, um das mit dem Simulator zu testen.

    Ich hoffe, so langsam wird es dir klarer.

    Gruß wolder
    Wenn du denkst du denkst, dann denkst du nur, dass du denkst, denn beim Denken der Gedanken, kommt dir der Gedanke, dass das Denken der Gedanken ein gedankenloses Denken ist

  7. #57
    schnecke ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.07.2010
    Beiträge
    148
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Lieben Dank für deine Hilfe, wolder!

    Glaube echt, ich bin zu blöd das zu verstehen…

    Beide Timer werden doch erst gestartet, sobald Merker 1.0 auf "true" gesetzt wird UND der OB35 aktiv ist.
    Timer1 läuft nach 5s ab und schaltet im OB1 den Merker 2.0 - hoffe mal, bis hierhin stimmt's?

    Was ich nich verstehe:

    Der Timer TON läuft doch gleichzeitig mit dem Timer1 ab und ist deswegen ebenfalls nach 5s abgelaufen und kann jetzt im OB1 ebenfalls nach 5s den Merker 2.1 schalten. Wenn der OB35 das 2. Mal aufgerufen wird, ist doch der Merker 2.1 schon längst zugewiesen…

    Oder muss der TON-Timer im Unterschied zum S5-Timer erneut aufgerufen werden, damit er nach Ablauf der Zeit beispielsweise einen Ausgang setzen kann?
    L.G. schnecke

  8. #58
    Registriert seit
    26.05.2009
    Beiträge
    541
    Danke
    35
    Erhielt 78 Danke für 69 Beiträge

    Standard

    Richtig, die Timer laufen gleichzeitig ab.
    Allerdings kann der TON seinen Merker erst schalten, wenn der TON bearbeitet wird!
    Und das ist ja im OB35, der ja nur alle 10s aufgerufen wird.
    Somit wird der Merker am TON-Baustein erst nach 10s auf 1 geschaltet, auch wenn die Zeit schon lange abgelaufen ist.
    Dieser Merker schaltet ja dann im OB1 einen Ausgang oder Merker. (ich hab das Programm jetzt nicht im Kopf)

    Gruß wolder
    Wenn du denkst du denkst, dann denkst du nur, dass du denkst, denn beim Denken der Gedanken, kommt dir der Gedanke, dass das Denken der Gedanken ein gedankenloses Denken ist

  9. #59
    schnecke ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.07.2010
    Beiträge
    148
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Supi, denke jetzt hab' ich es verstanden - puh, schwere Geburt mit mir.

    D.h. also, auch wenn vom TON die Zeit längst abgelaufen ist, kann dieser erst dann einen Ausgang schalten, wenn er erneut aufgerufen wird?

    In einem normalen Programm (also ohne OB35) hieße das dann, dass der Ausgang erst dann geschaltet wird, nachdem die Zeit abgelaufen UND die Programmzeile, in der der TON-Timer programmiert ist, wieder bearbeitet wird. Stimmt das so?
    L.G. schnecke

  10. #60
    Registriert seit
    26.05.2009
    Beiträge
    541
    Danke
    35
    Erhielt 78 Danke für 69 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren


    Sieht so aus als hättest du es jetzt!

    War wirklich ne schwierige Geburt.

    Gruß wolder
    Wenn du denkst du denkst, dann denkst du nur, dass du denkst, denn beim Denken der Gedanken, kommt dir der Gedanke, dass das Denken der Gedanken ein gedankenloses Denken ist

Ähnliche Themen

  1. Timerproblem in SCL
    Von schnecke im Forum Simatic
    Antworten: 23
    Letzter Beitrag: 15.09.2010, 14:10
  2. Timerproblem
    Von Tobias2k9 im Forum Programmierstrategien
    Antworten: 5
    Letzter Beitrag: 14.01.2009, 13:29
  3. Parallel laufende Programme - Timerproblem?
    Von ogstyle im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 27.06.2007, 13:45
  4. Timerproblem!
    Von Merker0.0 im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 04.08.2006, 22:48
  5. Timerproblem im FB
    Von samson im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 24.09.2005, 13:20

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •