Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: Verbindung vom Laptop zu CP343-IT herstellen

  1. #1
    Registriert seit
    02.09.2005
    Beiträge
    8
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    für ein Schulprojekt versuche ich eine Verbindung von meinem Laptop mit WinXP + Step7 Version V5.3(+HF2) und CP343-IT (V 1.0.1) herzustellen. Und es klappt einfach nicht.

    Ich habe meinen Laptop über ein gekreuztes Patchkabel (CrossOver) mit der CP343 verbunden.
    Sobald ich das Kabel in meinen Laptop stecke leuchtet am CP auch die LINK-Lampe.

    Dann habe ich versucht die Schnittstellen einzustellen IP-Adressen und so weiter. Wenn ich nun versuche über S7-Diagnose eine Verbindung aufzubauen bekomme ich immer die Meldung:
    "Es konnte keine Verbindung hergestellt werden, der Teilnehmer meldet sich nicht"
    Auch über Eingabeaufforderung und ping habe ich es schon versucht => 100% Verlust.
    Sobald ich aber sende fängt die Lampe RX/TX an der CP343 an zu blinken.

    Vielleicht liegt es an den Schnittstelleneinstellungen, aber darüber habe ich keine Infos gefunden.

    Kann mir jemand weiterhelfen? Mir ist jede Idee recht.
    Zitieren Zitieren Verbindung vom Laptop zu CP343-IT herstellen  

  2. #2
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.862
    Danke
    78
    Erhielt 805 Danke für 548 Beiträge

    Standard

    wie ist denn die ip am cp und am laptop? welche subnetmask?

    für die erste konfiguration must du die cp über mpi/dp einspielen.
    die blinkende rx/tx deuten nur auf eine korrekte hardware hin.
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  3. #3
    Registriert seit
    23.05.2005
    Ort
    Mönchengladbach
    Beiträge
    124
    Danke
    18
    Erhielt 5 Danke für 4 Beiträge

    Standard

    Hallo,

    ich habe meinen Laptop auch über ein Crossover an die IT angeschlossen.
    Da Du nicht weiter auf die Einstellungen eingegangen bist, schau doch mal nach ob dort eventuell der Hase begraben liegt.

    Ich habe zB der IT die Adresse 192.168.1.1 gegeben und der Laptop hat die IP 192.168.1.13

    Das klappt wunderbar und muss eigendlich nur an der IT projektiert werden und in den TCP/IP-Einstellungen am Laptop eingestellt werden.

    Da die CP leider in der Schule ist und ich im Moment auch den Laptop nicht hier habe, kann ich leider nicht sagen wie genau Du wo was einstellen musst, sorry.

    Michael

  4. #4
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.862
    Danke
    78
    Erhielt 805 Danke für 548 Beiträge

    Standard

    auch so noch was.

    wenn dein laptop seine ip nicht über einen dhcp server bekommt, wählt windows wahlos eine aus.
    es sei denn du hast deinem laptop eine feste ip zugewiesen.

    die subnetmask ist immer 255.255.0.0 (also ein klasse b netz)
    die ip ist immer 192.168.x.y

    meist wird der cp auf ein klasse c netz konfiguriert. 255.255.255.0

    dann klappt das nicht.
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  5. #5
    Anonymous Gast

    Standard

    Hallo Paula,

    zuerst mußt Du die Parameter in der Hardwarekonfiguration einstellen. Diese müssen zu Deinem PC passen. Bei Direktverbindug sollte am PC eine feste IP-Adresse konfiguriert sein, da mein Freund Bill sonst "wilde" Adresse vergibt. Mit diesen ist ein Verbindungsaufbau zum CP nicht möglich. Desweiteren müssen die IP-Adressen im selben Segment liegen, da ein Router bei Direktverbindung nicht existiert.
    Deshalb: Hardware projektieren, über MPI auf die SPS übertragen und dann auf TCP/IP umstellen.
    Ich hoffe das hilft

    Grüße
    WK

  6. #6
    Paula ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.09.2005
    Beiträge
    8
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich habe die HW-Konfig angepasst und über MPI (verbunden mit der CPU 315 DP-2, die auf dem selben Rack wie die CP343 sitzt) geladen.

    Anschließend habe ich der CP343 die IP-Adresse 192.168.178.17 und meinem Rechner die IP 192.168.178.2 zugewiesen (SuBNetzmaske 255.255.255.0)

    Habe ich das richtig verstanden, dass die SUB-Netzmaske falsch ist?
    Muss ich sie auf 255.255.0.0 umstellen?

  7. #7
    Anonymous Gast

    Standard

    Zitat Zitat von Paula
    Ich habe die HW-Konfig angepasst und über MPI (verbunden mit der CPU 315 DP-2, die auf dem selben Rack wie die CP343 sitzt) geladen.
    Prima.

    Zitat Zitat von Paula
    Anschließend habe ich der CP343 die IP-Adresse 192.168.178.17 und meinem Rechner die IP 192.168.178.2 zugewiesen (SuBNetzmaske 255.255.255.0)
    Wieso der CP anschließend? Die Daten müssen mit dem Rest der Hardwarekonfig auf die CPU (und dadurch auch auf die CP)

    Zitat Zitat von Paula
    Habe ich das richtig verstanden, dass die SUB-Netzmaske falsch ist?
    Muss ich sie auf 255.255.0.0 umstellen?
    Die parametrierte Subnetmask ist bei Deinen verwendeten IP-Adresse korrekt. Jetzt sollte nach Umstellung auf TCP/IP alles funktionieren.

    Grüße
    WK

  8. #8
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.862
    Danke
    78
    Erhielt 805 Danke für 548 Beiträge

    Standard

    Zitat Zitat von Paula
    Anschließend habe ich der CP343 die IP-Adresse 192.168.178.17 und meinem Rechner die IP 192.168.178.2 zugewiesen (SuBNetzmaske 255.255.255.0)
    so sollte es gehe.

    aber wie ich oben bereits erwähnt habe vergibt windows eine ip adresse aus einer klasse b netz subnetmask. also 255.255.0.0

    die ersten beiden zahlen sind immer 192.168.x.y
    x und y werden von windows wild vergeben. z.b. 192.168.10.100

    es reicht also wenn du dem cp eine ip aus dieser mask gibst.
    also irgendwas 192.168.x.y
    z.b. 192.168.20.50

    im prinzip bedeutet das, dass alle adressen von 192.168.1.1 bis 192.168.255.255 im gleichen netzwerk liegen.


    der vorteil einer subnetmask von 255.255.0.0 ist folgender:
    wenn du mit deinem laptop auch ab und an in einem anderen netzwerk arbeitest in dem du eine dynamische ip vom dhcp-server bekommst, musst du nicht ständig die ip der netzwerkkarte in deinem laptop umstellen.
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  9. #9
    Paula ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.09.2005
    Beiträge
    8
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Es lag gar nicht an den Netzwerkeinstellungen sondern an der Busanbindung auf dem S7-Basisgerät. Die CP343 hatte gar keine Busanbindung und hat somit auch meine IP-Einstellungen nicht mitgemacht.

    Ich hätte ja gedacht, das die CPU315 einen Fehler rausgibt wenn Geräte über die HW-Konfig geladen werden, die nicht am Bus sind, aber naja.
    Ich habe es über den Betriebszustand der CP heraus gefunden. Dort wurde angezeigt, das die CP gar nicht in echt verbaut sei.

    Nachdem ich den Busanschluss richtig hergestellt hatte hat es auch mit meinen Einstellungen funktioniert über Ethernet auf die CP zuzugreifen.

    Trotz allem vielen Dank.
    Zitieren Zitieren Problem gelöst  

Ähnliche Themen

  1. USB MPI Verbindung herstellen
    Von GOPL im Forum Simatic
    Antworten: 21
    Letzter Beitrag: 10.08.2011, 19:14
  2. Verbindung zu OPC Server herstellen (Servername nicht bekannt)
    Von matziane im Forum Hochsprachen - OPC
    Antworten: 21
    Letzter Beitrag: 01.02.2011, 15:39
  3. Profibus verbindung herstellen
    Von hbedir im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 14.11.2009, 20:19
  4. Verbindung zu S5 herstellen
    Von ditschio im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 18.04.2009, 19:31
  5. Antworten: 4
    Letzter Beitrag: 10.08.2007, 13:09

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •