Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 5 ErsteErste 1234 ... LetzteLetzte
Ergebnis 11 bis 20 von 43

Thema: Positionierungsproblem - Timer schuld?

  1. #11
    pinolino ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.10.2007
    Beiträge
    261
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Danke - der Vorschlag, wenn der Ausgang des Bandes über den Timer rückgesetzt wurde gleich in das PAA zu schreiben, bringt keine Verbesserung, oder?

  2. #12
    Registriert seit
    12.05.2010
    Ort
    Dortmund
    Beiträge
    889
    Danke
    57
    Erhielt 121 Danke für 89 Beiträge

    Standard

    nee-
    teste das Ganze doch erst mal, wie ich beschrieben hatte - ob deine Hardware/Antrieb das überhaupt hergibt.

    Was nützt es dir wenn die CPU noch so schnell abschaltet??
    Weil Denken die schwerste Arbeit ist, die es gibt, beschäftigen sich auch nur wenige damit.

  3. #13
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Ich würde einen Schütz von der Lichtschranke schalten lassen.
    Da kannst du prüfen, ob die Mechanik die Toleranz kann die brauchst.

    Das Habe dir die Vorschreiber ja schon geraten.
    Nicht zuerst die Steuerung im Verdacht zu haben, wenn es nicht so genau klappt wie gewollt.


    bike

  4. #14
    Registriert seit
    06.01.2005
    Ort
    im schönen Lipperland
    Beiträge
    4.472
    Danke
    498
    Erhielt 1.143 Danke für 736 Beiträge

    Standard

    Ich denke bei 1,5m/s kannste du das Positionieren über die SPS vergessen. Vor allem wenn du nicht mal einen FU hast. Überleg mal..... 1500mm pro Sekunde. Das macht 1.5mm pro Millisekunde .. macht bei deiner Zykluszeit von 11ms eine Abweichung von 16,5 mm aus.... dazu kommen dann noch die mech. unzulänglichkeiten.........
    Früher gab es Peitschen .... heute Terminkalender

  5. #15
    pinolino ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.10.2007
    Beiträge
    261
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von bike Beitrag anzeigen
    Nicht zuerst die Steuerung im Verdacht zu haben, wenn es nicht so genau klappt wie gewollt.
    bike
    Danke für eure Antworten!

    @bike: Aber das Hauptproblem ist doch eigentlich schon die Zykluszeit der SPS, d.h., dass nach Auslösen des Timers noch x-Zyklen durchlaufen werden...

    Ok, mache mal die mech. Versuche mit einem Schütz.

    Grüße
    pinolino

  6. #16
    Registriert seit
    12.05.2010
    Ort
    Dortmund
    Beiträge
    889
    Danke
    57
    Erhielt 121 Danke für 89 Beiträge

    Standard

    nee..das Hauptproblem wird (wahrscheinlich sein), dass deine Hardware es nicht zulässt genau an der Position zu halten .Motor ohne FU/kein Stopper/1,5m/s etc.
    da nützt dir auch die schnellste CPU der Welt nicht.
    Weil Denken die schwerste Arbeit ist, die es gibt, beschäftigen sich auch nur wenige damit.

  7. #17
    pinolino ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.10.2007
    Beiträge
    261
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ok, stimmt rheumakay!

    Aber rein auf die SPS bezogen würde die Aussage schon stimmen, dass nach Timerauslösung noch x-Zyklen durchlaufen werden, bis der Ausgang tatsächlich rückgesetzt wird, oder?

  8. #18
    Registriert seit
    12.05.2010
    Ort
    Dortmund
    Beiträge
    889
    Danke
    57
    Erhielt 121 Danke für 89 Beiträge

    Standard

    schon wieder nee..auch bei der 1200 ist die Bearbeitungsreihenfolge herkömlich wie bei den anderen Steuerungen.
    D.h. wird deiner Timer.Q =1 und daran ist direkt der Ausgang beschaltet,so wir dann entsprechend am Ende des Zyklus der Ausgang entsprechen angesteuert.
    Weil Denken die schwerste Arbeit ist, die es gibt, beschäftigen sich auch nur wenige damit.

  9. #19
    pinolino ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.10.2007
    Beiträge
    261
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Aja sorry, ich meinte mit Timerauslösung die Auslösung des Timers durch die Lichtschranke. Dann wäre es aber doch so... oder wieder nee?

  10. #20
    Registriert seit
    12.05.2010
    Ort
    Dortmund
    Beiträge
    889
    Danke
    57
    Erhielt 121 Danke für 89 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    verstehe ich nicht..mach mal nen screenshot von deinem Programm (oder Ausdruck)
    Weil Denken die schwerste Arbeit ist, die es gibt, beschäftigen sich auch nur wenige damit.

Ähnliche Themen

  1. Timer
    Von lieuthnant im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 08.01.2010, 14:33
  2. Timer
    Von the im Forum CODESYS und IEC61131
    Antworten: 6
    Letzter Beitrag: 06.07.2009, 19:11
  3. Suche Ersatz für IFM TIMER LG ( Logik Timer)
    Von GrafLaugenkotz im Forum Sonstige Steuerungen
    Antworten: 1
    Letzter Beitrag: 16.01.2007, 17:02
  4. S7 Timer
    Von Elektro im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 06.11.2006, 11:30
  5. S7 Timer
    Von Patrick_B. im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 03.01.2006, 07:10

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •