Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 22

Thema: Variablen setzen sich bei übertragung in die SPS willkürlich????????

  1. #11
    Registriert seit
    09.06.2008
    Beiträge
    138
    Danke
    16
    Erhielt 13 Danke für 13 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ist immer eine unschöne Sache, wenn man hier um Hilfe bittet.
    Die Lösung dann verschweigt.
    Es gibt mit Sicherheit noch andere die den gleichen Fehler begehen und so nur erfahren, dass er lösbar ist...

  2. #12
    Registriert seit
    03.07.2006
    Beiträge
    1.725
    Danke
    515
    Erhielt 303 Danke für 223 Beiträge

    Standard

    Das ist meistens so wenn man merkt das man scheisse gebaut hat und sich dann schämt seinen Fehler online zu stellen.....
    Das es keine Selbstheilung der SPS war sondern Bockmist im Programm... denke das wissen wir alle

  3. #13
    Registriert seit
    11.12.2009
    Beiträge
    2.120
    Danke
    388
    Erhielt 390 Danke für 271 Beiträge

    Standard

    Meine Glaskugel sagt mir, das wenn du Ausgänge über die HMI steuerst, und das über DBs rangierst. Deine DBs offline einen alten Stand deiner Aktualwerte hat, und nicht alle Bits auf 0 stehen, und daher deine Ausgänge angesteuert werden.

    Grüße

    Marcel

  4. #14
    Registriert seit
    14.10.2010
    Ort
    Telgte
    Beiträge
    655
    Danke
    97
    Erhielt 129 Danke für 99 Beiträge

    Standard

    Jeder von uns hat schon mal einen solchen oder ähnlichen Bockmist gebaut.
    Vielleicht wurde der nur nicht online ausdiskutiert...
    Doch wenn, dann sollte man manns genug sein diesen Fehler einzugestehen.
    Vielleicht überlegt sich der TE es ja noch und lässt uns an der Lösung teilhaben...

    Gruß
    Toki
    Programmierumgebung: Step7 V5.5, WinCCflex2008-SP3, TIA-PortalV13, MicroWinV4.0

  5. #15
    Registriert seit
    08.07.2011
    Beiträge
    55
    Danke
    38
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Leute Leute bleibt locker, @ alle, hab kein Problem damit meine Fehler zu gestehen, bin Meisterschüler und muss eh noch sehr viel lernen, hab zwar den SPS techniker auf teilzeit gemacht jedoch gab mir die weiterbildung zu wenig praxis und erahrung mit.


    ALSO mein Gefühl:


    Hab lokal Variablen benutz als Temporäre Variablen in einem FC als Speicher meiner RS Glieder, denke das die irgendwie sich immer wieder gesetzt haben....

    hab die gelöscht und durch DB variablen ersetzt und schon war das problem behoben.

    Hoffe der Fehler ist dauerhaft behoben....

    DANKE aber noch mal an alle....

    LG Benedikt

  6. #16
    Registriert seit
    13.10.2007
    Beiträge
    12.055
    Danke
    2.793
    Erhielt 3.285 Danke für 2.165 Beiträge

    Standard

    Hallo Benedikt,
    bei Temponären lokalen Variablen musst du aufpassen, sie sollten
    oder besser dürfen nur innerhalb der Laufzeit des Baustein
    verwendet werden. Diesen Speicherbereich nutzen auch andere
    Bausteine, da kann es zu Überschneidungen kommen.

    Gruß RN
    Geändert von rostiger Nagel (27.02.2012 um 06:08 Uhr)

  7. Folgender Benutzer sagt Danke zu rostiger Nagel für den nützlichen Beitrag:

    Benedikt (28.02.2012)

  8. #17
    Registriert seit
    13.09.2010
    Beiträge
    2.292
    Danke
    178
    Erhielt 375 Danke für 355 Beiträge

    Standard

    TempVar´s haben beim FC-Aufruf zunächst einen undefinierten Zustand, bis sie zur FC-Laufzeit zugewiesen werden. Du kannst sie alternativ zu Beginn deines FC´s auch setzen oder besser löschen (CLR und = xx.x oder L 0 und T yyy)
    Mit den DB´s wirst du aber wohl auch keine Probleme mehr haben


    Zitat Zitat von Matze001 Beitrag anzeigen
    Meine Glaskugel sagt mir, das wenn du Ausgänge über die HMI steuerst, und das über DBs rangierst. Deine DBs offline einen alten Stand deiner Aktualwerte hat, und nicht alle Bits auf 0 stehen, und daher deine Ausgänge angesteuert werden. Grüße Marcel
    Das geht nur, wenn er beim erneuten Laden eine Online-Kopie eines DB´s wieder einspielt oder einen aus dem Projekt eingespielten DB auf seine Anfangswerte initialisiert.

    Hat er aber beides nicht getan und hat auch beides nichts mit HMI zu tun
    kind regards
    SoftMachine

  9. Folgender Benutzer sagt Danke zu SoftMachine für den nützlichen Beitrag:

    Benedikt (28.02.2012)

  10. #18
    Registriert seit
    11.12.2009
    Beiträge
    2.120
    Danke
    388
    Erhielt 390 Danke für 271 Beiträge

    Standard

    Klar hat es nix mit der HMI zu tun,.... ich wollte eher auf die zwei Möglichkeiten die du genannt hast hinaus.

    Je nach Aktualisierungszeit der HMI-Variablen behalten nämlich die DB-Variablen ihren Zustand bis sie überschrieben werden.

    Grüße

    Marcel

  11. Folgender Benutzer sagt Danke zu Matze001 für den nützlichen Beitrag:

    Benedikt (28.02.2012)

  12. #19
    Registriert seit
    08.07.2011
    Beiträge
    55
    Danke
    38
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Noch mal dankeschön, waren wirklich die Temporären Variablen dran schuld....

    da bleib ich doch lieber bei meinen DB variablen!

    LG Benedikt

  13. #20
    Registriert seit
    06.02.2012
    Beiträge
    7
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von vonphilipp Beitrag anzeigen
    Wenn die Ausgänge nach dem Start immer unterschiedlich kommen, würde ich auf ein Problem mit den Temp Variablen tippen, aber das ist nur eine Vermutung.
    Wüste gar nicht das meine Glaskugel wieder funktioniert!

Ähnliche Themen

  1. Messwerte auf SPS Speichern: Wo befindet sich die Datei?
    Von Tenobaal im Forum CODESYS und IEC61131
    Antworten: 2
    Letzter Beitrag: 16.12.2011, 17:59
  2. ab wann lohnt sich die installation einer sps
    Von spickl im Forum Stammtisch
    Antworten: 14
    Letzter Beitrag: 01.06.2011, 18:07
  3. Antworten: 46
    Letzter Beitrag: 26.03.2010, 10:23
  4. bei SPS Stop merker setzen, wie?
    Von thorsten im Forum Simatic
    Antworten: 25
    Letzter Beitrag: 16.01.2008, 08:40
  5. Antworten: 0
    Letzter Beitrag: 12.07.2006, 11:06

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •